package debtags 2.0.1ubuntu6 failed to install/upgrade: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück

Bug #1719174 reported by Hungerburg on 2017-09-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
debtags (Ubuntu)
Undecided
Unassigned

Bug Description

debtags (2.0.1ubuntu6) wird eingerichtet ...
Traceback (most recent call last):
  File "/usr/bin/debtags", line 700, in <module>
    main()
  File "/usr/bin/debtags", line 694, in main
    sys.exit(action.main(args))
  File "/usr/bin/debtags", line 638, in main
    for pkg, tags in self.tags_from_apt():
  File "/usr/bin/debtags", line 261, in tags_from_apt
    tags = tags_from_apt_record(cand.record)
  File "/usr/lib/python3/dist-packages/apt/package.py", line 592, in record
    return Record(self._records.record)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xef in position 379: invalid continuation byte

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: debtags 2.0.1ubuntu6
ProcVersionSignature: Ubuntu 4.4.0-96.119-generic 4.4.83
Uname: Linux 4.4.0-96-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.10
Architecture: amd64
Date: Sun Sep 24 12:35:02 2017
ErrorMessage: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
InstallationDate: Installed on 2014-03-13 (1290 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140225)
PackageArchitecture: all
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.2
 apt 1.2.24
SourcePackage: debtags
Title: package debtags 2.0.1ubuntu6 failed to install/upgrade: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
UpgradeStatus: No upgrade log present (probably fresh install)

Hungerburg (pch-myzel) wrote :
Hungerburg (pch-myzel) wrote :

I add "print(cand.record)" before line 261 of "debtags" and get the offending record?

Package: linux-image-4.4.0-57-lowlatency
Architecture: i386
Version: 4.4.0-57.78

… NO special char there, BUT in the next entry in /var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_xenial-security_main_binary-amd64_Packages

Package: linux-image-4.4.0-59-generic
Architecture: amd64
Version: 4.4.0-59.80
Priority: optional
Section: kernel
Source: linux
Origin: Ubuntu
Maintainer: Ubuntu Kernel Team <email address hidden>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 63212
Provides: fuse-module, ivtv-modules, kvm-api-4, linux-image, redhat-cluster-modules, spl-dkms, virtualb<EF>x-guest-modules, zfs-dkms

There it is - virtualbïx-guest-modules!

s/ï/o/ - write file, no more failure!

Hungerburg (pch-myzel) wrote :

Good, now how did the typo get there? It is not in the control files of the package as available online! The package is not even installed on this system here. It is also not in http://security.ubuntu.com/ubuntu/dists/xenial-security/main/binary-amd64/Packages.gz

Now, this is mysterious. A bit flipped by a cosmic ray? ascii 'o' => 0x6F
Who will ever know…

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers