wrong encoding of man pages

Bug #352744 reported by Florent on 2009-03-31
4
Affects Status Importance Assigned to Milestone
deborphan (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: deborphan

The French man pages do not display correctly: deborphan, orphaner, editkeep

user@jaunty$ echo $LANG
fr_FR.UTF-8
user@jaunty$ man 1 deborphan

It seems that the UTF-8 file was converted again from ISO-8859-1 to UTF-8.

The command that revert to the right encoding:

user@jaunty$ zcat /usr/share/man/fr/man1/deborphan.1.gz | iconv -f UTF-8 -t ISO-8859-1 | man -l -

Same analysis for :
 /usr/share/man/fr/man8/editkeep.8.gz
 /usr/share/man/fr/man8/orphaner.8.gz

ProblemType: Bug
Architecture: i386
Dependencies:
 libgcc1 1:4.3.3-5ubuntu4
 gcc-4.3-base 4.3.3-5ubuntu4
 findutils 4.4.0-2ubuntu3
 libc6 2.9-4ubuntu4
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: ath_hal
Package: deborphan 1.7.27
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: deborphan
Uname: Linux 2.6.28-11-generic i686

Thank you for reporting this issue, it helps make Ubuntu better. Confirmed.

Changed in deborphan:
status: New → Confirmed
CarstenHey (c.hey) wrote :

French man pages in deborphan include a note about how to report translation bugs. The file including this note in encoded in ISO, but the French po files are encoded in UTF-8.

It looks like po4a-translate and po4a-updatepo, which create the man pages whilst building the package, don't like mixed encodings ...

This will probably be fixed in deborphan 1.7.29. If my first guess is correct (I did not check if it is) the note itself should be correctly encoded, unlike the rest of the French man pages.

Thanks for the bug report
Carsten

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deborphan - 1.7.28ubuntu1

---------------
deborphan (1.7.28ubuntu1) lucid; urgency=low

  * Treat -dbgsym packages as -dbg (LP: #533881)
  * Fix encoding for French manpages (LP: #352744)
 -- Laurent Bigonville <email address hidden> Sun, 07 Mar 2010 18:08:04 +0100

Changed in deborphan (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers