Add Ubuntu disco as as supported release

Bug #1800945 reported by Brian Murray on 2018-10-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
debootstrap (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Brian Murray
Xenial
Undecided
Brian Murray
Bionic
Undecided
Brian Murray
Cosmic
Undecided
Brian Murray

Bug Description

Add Ubuntu disco 19.04 debootstrap.

summary: - Add Ubuntu dingo as as supported release
+ Add Ubuntu disco as as supported release
description: updated
Brian Murray (brian-murray) wrote :

debootstrap (1.0.108ubuntu2) disco; urgency=medium

  * Add a script for disco.

 -- Matthias Klose <email address hidden> Tue, 30 Oct 2018 16:40:26 +0100

Changed in debootstrap (Ubuntu):
status: New → Fix Released
Changed in debootstrap (Ubuntu Cosmic):
status: New → In Progress
assignee: nobody → Brian Murray (brian-murray)
Changed in debootstrap (Ubuntu Bionic):
status: New → In Progress
Changed in debootstrap (Ubuntu Xenial):
status: New → In Progress
Changed in debootstrap (Ubuntu Trusty):
status: New → In Progress
assignee: nobody → Brian Murray (brian-murray)
Changed in debootstrap (Ubuntu Xenial):
assignee: nobody → Brian Murray (brian-murray)
Changed in debootstrap (Ubuntu Bionic):
assignee: nobody → Brian Murray (brian-murray)

Hello Brian, or anyone else affected,

Accepted debootstrap into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debootstrap/1.0.108ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in debootstrap (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Andy Whitcroft (apw) wrote :

Hello Brian, or anyone else affected,

Accepted debootstrap into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debootstrap/1.0.78+nmu1ubuntu1.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in debootstrap (Ubuntu Bionic):
status: In Progress → Fix Committed
Changed in debootstrap (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Changed in debootstrap (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed-trusty
Andy Whitcroft (apw) wrote :

Hello Brian, or anyone else affected,

Accepted debootstrap into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debootstrap/1.0.59ubuntu0.11 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Dimitri John Ledkov (xnox) wrote :

Adding just the symlink is not good enough for disco+ as one also needs to backport MERGED_USR=yes stanza, and/or MERGED_USR support, depending on how far back one wants to go. Otherwise, older releases will bootstrap disco non-usr-merged.

Hence e.g. bionic's upload is bad. (which by the way was done with https://bugs.launchpad.net/ubuntu/+source/debootstrap/+bug/1773496 as a bugnumber reference)

tags: added: verification-failed-trusty verification-failed-xenial
removed: verification-needed-trusty verification-needed-xenial
Dimitri John Ledkov (xnox) wrote :

ubuntu@xnoxtest:~$ ls -latr foo/ | grep sbin
drwxr-xr-x 2 root root 4096 Nov 7 12:39 sbin
ubuntu@xnoxtest:~$ dpkg-query -W debootstrap
debootstrap 1.0.95ubuntu0.2

Which is bad, as sbin should be -> usr/sbin

Dimitri John Ledkov (xnox) wrote :

Cosmic is good:

ubuntu@xnoxcosmic:~$ ls -latr foo | grep sbin
lrwxrwxrwx 1 root root 8 Nov 7 12:47 sbin -> usr/sbin
ubuntu@xnoxcosmic:~$ dpkg-query -W debootstrap
debootstrap 1.0.108ubuntu1.1

tags: added: verification-done verification-done-cosmic
removed: verification-needed verification-needed-cosmic
Brian Murray (brian-murray) wrote :

Confirming that cosmic does setup a disco chroot correctly.

 $ ls -altr /run/schroot/mount/disco-amd64-39c1df8a-06d8-4dd7-a799-f38bf8fb6ec3/sbin
lrwxrwxrwx 1 root root 8 Oct 31 15:55 /run/schroot/mount/disco-amd64-39c1df8a-06d8-4dd7-a799-f38bf8fb6ec3/sbin -> usr/sbin

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debootstrap - 1.0.108ubuntu1.1

---------------
debootstrap (1.0.108ubuntu1.1) cosmic; urgency=medium

  * Add (Ubuntu) disco as a symlink to gutsy. (LP: #1800945)

 -- Brian Murray <email address hidden> Wed, 31 Oct 2018 15:31:00 -0700

Changed in debootstrap (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for debootstrap has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Thank you for taking the time to verify this stable release fix. We have noticed that you have used the verification-done tag for marking the bug as verified and would like to point out that due to a recent change in SRU bug verification policy fixes now have to be marked with per-release tags (i.e. verification-done-$RELEASE). Please remove the verification-done tag and add one for the release you have tested the package in. Thank you!

https://wiki.ubuntu.com/StableReleaseUpdates#Verification

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers