Add Ubuntu bionic as a supported release

Bug #1727732 reported by Andy Whitcroft on 2017-10-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
debootstrap (Ubuntu)
Medium
Andy Whitcroft
Trusty
Medium
Andy Whitcroft
Xenial
Medium
Andy Whitcroft
Zesty
Medium
Andy Whitcroft
Artful
Medium
Andy Whitcroft

Bug Description

Add Ubuntu bionic 18.04 LTS to debootstrap.

Andy Whitcroft (apw) wrote :

Fixed in bionic:

debootstrap (1.0.91ubuntu2) bionic; urgency=medium

  * Add (Ubuntu) bionic as a symlink to gutsy.

 -- Adam Conrad <email address hidden> Wed, 25 Oct 2017 20:30:18 -0600

Changed in debootstrap (Ubuntu):
status: New → Fix Released
importance: Undecided → Medium
assignee: nobody → Andy Whitcroft (apw)
Changed in debootstrap (Ubuntu Trusty):
importance: Undecided → Medium
Changed in debootstrap (Ubuntu Xenial):
importance: Undecided → Medium
Changed in debootstrap (Ubuntu Zesty):
importance: Undecided → Medium
Changed in debootstrap (Ubuntu Artful):
importance: Undecided → Medium
status: New → In Progress
assignee: nobody → Andy Whitcroft (apw)
Changed in debootstrap (Ubuntu Xenial):
assignee: nobody → Andy Whitcroft (apw)
Changed in debootstrap (Ubuntu Zesty):
assignee: nobody → Andy Whitcroft (apw)
Changed in debootstrap (Ubuntu Trusty):
assignee: nobody → Andy Whitcroft (apw)

Hello Andy, or anyone else affected,

Accepted debootstrap into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debootstrap/1.0.91ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in debootstrap (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-artful
Brian Murray (brian-murray) wrote :

Hello Andy, or anyone else affected,

Accepted debootstrap into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debootstrap/1.0.81ubuntu3.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in debootstrap (Ubuntu Zesty):
status: New → Fix Committed
tags: added: verification-needed-zesty
Changed in debootstrap (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Andy, or anyone else affected,

Accepted debootstrap into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debootstrap/1.0.78+nmu1ubuntu1.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in debootstrap (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed-trusty
Brian Murray (brian-murray) wrote :

Hello Andy, or anyone else affected,

Accepted debootstrap into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debootstrap/1.0.59ubuntu0.9 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Andrea Azzarone (azzar1) wrote :

Works as expected in xenial.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Andy Whitcroft (apw) wrote :

Also confirming in xenial.

Timo Aaltonen (tjaalton) wrote :

artful ok

tags: added: verification-done-artful
removed: verification-needed-artful
Witold Szczeponik (wsz) wrote :

debootstrap 1.0.59ubuntu0.9 fails on trusty with the following output:

I: Chosen extractor for .deb packages: dpkg-deb
I: Extracting base-files...
I: Extracting base-passwd...
E: debootstrap failed
W: Aborting with an error

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debootstrap - 1.0.91ubuntu1.1

---------------
debootstrap (1.0.91ubuntu1.1) artful; urgency=medium

  * Add (Ubuntu) bionic as a symlink to gutsy. (LP: #1727732)

 -- Andy Whitcroft <email address hidden> Thu, 26 Oct 2017 14:30:19 +0100

Changed in debootstrap (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for debootstrap has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Witold Szczeponik (wsz) wrote :

Adding to comment #9, I tried to look at the content of "base-passwd" and here's what I found:

$ dpkg-deb -W ./base-passwd_3.5.44_amd64.deb
dpkg-deb: error: archive './base-passwd_3.5.44_amd64.deb' has premature member 'control.tar.xz' before 'control.tar.gz', giving up

This might be the root cause of the problem.

Witold Szczeponik (wsz) wrote :

Adding to comment #12, I created bug #1730627 where the problem of not accepting the file name 'control.tar.xz' is being tracked. A possible fix is included.

Brian Murray (brian-murray) wrote :

v-done for zesty:

(zesty-amd64)root@impulse:/home/bdmurray/Documents/ebooks# apt install debootstrap
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  debootstrap
1 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
Need to get 36.3 kB of archives.
After this operation, 1024 B of additional disk space will be used.
Get:1 http://192.168.10.7/ubuntu zesty-proposed/main amd64 debootstrap all 1.0.81ubuntu3.3 [36.3 kB]
Fetched 36.3 kB in 0s (1328 kB/s)
(Reading database ... 16816 files and directories currently installed.)
Preparing to unpack .../debootstrap_1.0.81ubuntu3.3_all.deb ...
Unpacking debootstrap (1.0.81ubuntu3.3) over (1.0.81ubuntu3.2) ...
Setting up debootstrap (1.0.81ubuntu3.3) ...
(zesty-amd64)root@impulse:/home/bdmurray/Documents/ebooks# dpkg -L debootstrap | grep bioinic
(zesty-amd64)root@impulse:/home/bdmurray/Documents/ebooks# dpkg -L debootstrap | grep bionic
/usr/share/debootstrap/scripts/bionic

tags: added: verification-done-zesty
removed: verification-needed-zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debootstrap - 1.0.81ubuntu3.3

---------------
debootstrap (1.0.81ubuntu3.3) zesty; urgency=medium

  * Add (Ubuntu) bionic as a symlink to gutsy. (LP: #1727732)

 -- Andy Whitcroft <email address hidden> Thu, 26 Oct 2017 14:34:51 +0100

Changed in debootstrap (Ubuntu Zesty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debootstrap - 1.0.78+nmu1ubuntu1.5

---------------
debootstrap (1.0.78+nmu1ubuntu1.5) xenial; urgency=medium

  * Add (Ubuntu) bionic as a symlink to gutsy. (LP: #1727732)

 -- Andy Whitcroft <email address hidden> Thu, 26 Oct 2017 14:36:48 +0100

Changed in debootstrap (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers