debootstrap: learn about Debian buster

Bug #1698686 reported by Mattia Rizzolo on 2017-06-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
debootstrap (Ubuntu)
Undecided
Unassigned
Trusty
Medium
Mattia Rizzolo
Xenial
Medium
Mattia Rizzolo
Yakkety
Medium
Mattia Rizzolo
Zesty
Medium
Mattia Rizzolo

Bug Description

[Impact]
* people can't easily debootstrap the current debian testing (buster) with the tools available in Ubuntu's stable

[Test case]
* `debootstrap buster foo` --> fail with a "suite buster not known message"

[Regression Potential]
* really, none.

[Other Info]
* this kind of change is routinely done in debootstrap, just adding support
  for new releases
* my proposed package also add support for "bullseye", i.e. buster+1, even if it will be released in who knows how many years… That's just being
pro-active, most probably xenial will still be supported when bullseye will be interesting.

Mattia Rizzolo (mapreri) on 2017-06-18
Changed in debootstrap (Ubuntu):
status: New → Fix Released
Changed in debootstrap (Ubuntu):
assignee: nobody → Mattia Rizzolo (mapreri)
Changed in debootstrap (Ubuntu Xenial):
assignee: nobody → Mattia Rizzolo (mapreri)
Changed in debootstrap (Ubuntu Yakkety):
assignee: nobody → Mattia Rizzolo (mapreri)
Changed in debootstrap (Ubuntu Zesty):
assignee: nobody → Mattia Rizzolo (mapreri)
Changed in debootstrap (Ubuntu Xenial):
status: New → In Progress
Changed in debootstrap (Ubuntu Yakkety):
status: New → In Progress
Changed in debootstrap (Ubuntu Zesty):
status: New → In Progress
Mattia Rizzolo (mapreri) on 2017-06-18
Changed in debootstrap (Ubuntu Xenial):
importance: Undecided → Medium
Changed in debootstrap (Ubuntu Yakkety):
importance: Undecided → Medium
Changed in debootstrap (Ubuntu Zesty):
importance: Undecided → Medium
Changed in debootstrap (Ubuntu):
assignee: Mattia Rizzolo (mapreri) → nobody
Mattia Rizzolo (mapreri) on 2017-06-19
description: updated
Changed in debootstrap (Ubuntu Xenial):
status: In Progress → Fix Committed
Changed in debootstrap (Ubuntu Yakkety):
status: In Progress → Fix Committed
Changed in debootstrap (Ubuntu Zesty):
status: In Progress → Fix Committed

Hello Mattia, or anyone else affected,

Accepted debootstrap into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debootstrap/1.0.81ubuntu3.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty.If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-zesty
tags: added: verification-needed-yakkety
Andy Whitcroft (apw) wrote :

Hello Mattia, or anyone else affected,

Accepted debootstrap into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debootstrap/1.0.81ubuntu2.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-yakkety to verification-done-yakkety.If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-yakkety. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed-xenial
Andy Whitcroft (apw) wrote :

Hello Mattia, or anyone else affected,

Accepted debootstrap into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debootstrap/1.0.78+nmu1ubuntu1.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial.If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Mattia Rizzolo (mapreri) on 2017-06-30
Changed in debootstrap (Ubuntu Trusty):
importance: Undecided → Medium
assignee: nobody → Mattia Rizzolo (mapreri)
status: New → In Progress
Andy Whitcroft (apw) wrote :

Hello Mattia, or anyone else affected,

Accepted debootstrap into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debootstrap/1.0.59ubuntu0.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty.If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in debootstrap (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed-trusty
Mattia Rizzolo (mapreri) on 2017-06-30
tags: added: verification-done-trusty verification-done-xenial verification-done-yakkety verification-done-zesty
removed: verification-needed verification-needed-trusty verification-needed-xenial verification-needed-yakkety verification-needed-zesty
Łukasz Zemczak (sil2100) wrote :

When performing verification of SRU bugs it is required to specify the details of testing - even for trivial changes like these. We would at least like to know which versions have been tested and which steps performed as part of the test. Think of it like this: you need to convince the SRU team that the change was actually tested, since otherwise we might think you just switched the bug as-is.

Changed in debootstrap (Ubuntu Trusty):
status: Fix Committed → Incomplete
Changed in debootstrap (Ubuntu Xenial):
status: Fix Committed → Incomplete
Changed in debootstrap (Ubuntu Yakkety):
status: Fix Committed → Incomplete
Changed in debootstrap (Ubuntu Zesty):
status: Fix Committed → Incomplete
Mattia Rizzolo (mapreri) wrote :

...
For each of the ubuntu releases I installed the proposed packages from -proposed in a clean installation, and checked that I could successfully bootstrap a stretch and buster chroots, as well as chroot in and run an `apt update` (just to check it's not a completely busted chroot).

At any rate, they are so simple, with no regression potential at all that even if I didn't test them when I switched the tags, I would consider to accept them just by looking at the diff...

Changed in debootstrap (Ubuntu Trusty):
status: Incomplete → Fix Committed
Changed in debootstrap (Ubuntu Xenial):
status: Incomplete → Fix Committed
Changed in debootstrap (Ubuntu Yakkety):
status: Incomplete → Fix Committed
Changed in debootstrap (Ubuntu Zesty):
status: Incomplete → Fix Committed

The verification of the Stable Release Update for debootstrap has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debootstrap - 1.0.78+nmu1ubuntu1.4

---------------
debootstrap (1.0.78+nmu1ubuntu1.4) xenial; urgency=medium

  * Add (Debian) buster and bullseye as a symlink to sid. LP: #1698686

 -- Mattia Rizzolo <email address hidden> Mon, 19 Jun 2017 19:54:11 +0200

Changed in debootstrap (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debootstrap - 1.0.81ubuntu2.3

---------------
debootstrap (1.0.81ubuntu2.3) yakkety; urgency=medium

  * Add (Debian) buster and bullseye as a symlink to sid. LP: #1698686

 -- Mattia Rizzolo <email address hidden> Mon, 19 Jun 2017 19:53:12 +0200

Changed in debootstrap (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debootstrap - 1.0.81ubuntu3.2

---------------
debootstrap (1.0.81ubuntu3.2) zesty; urgency=medium

  * Add (Debian) buster and bullseye as a symlink to sid. LP: #1698686

 -- Mattia Rizzolo <email address hidden> Mon, 19 Jun 2017 19:51:22 +0200

Changed in debootstrap (Ubuntu Zesty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debootstrap - 1.0.59ubuntu0.8

---------------
debootstrap (1.0.59ubuntu0.8) trusty; urgency=medium

  * Add (Debian) stretch, buster and bullseye as a symlink to sid.
    LP: #1698686

 -- Mattia Rizzolo <email address hidden> Fri, 30 Jun 2017 16:34:26 +0200

Changed in debootstrap (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers