debmirror's rsync method does not download all available updates

Bug #560826 reported by Steve Beattie on 2010-04-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
debmirror (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: debmirror

After the recent upgrade to debmirror 1:2.4.4ubuntu1, apt-get dist-upgrades off of my local mirror were failing due to packages being unavailable (i.e. 404 errors). Looking over my debmirror cronjob output, the "want ..." output lines added by the patch drop-redundant-rsync.patch is incrementing by 2:

  want pool/main/h/hplip/hpijs-ppds_3.10.2-2ubuntu1_all.deb (1/351 1/500)
  want pool/main/h/hplip/hpijs_3.10.2-2ubuntu1_amd64.deb (3/351 2/500)
  want pool/main/h/hplip/hpijs_3.10.2-2ubuntu1_i386.deb (5/351 3/500)
  want pool/main/h/hplip/hplip-cups_3.10.2-2ubuntu1_amd64.deb (7/351 4/500)
  want pool/main/h/hplip/hplip-cups_3.10.2-2ubuntu1_i386.deb (9/351 5/500)
  [...]

this also would cause it to run past the maximum number of wanted packages if the number of wanted packages was even:

  [...]
  want pool/main/l/language-pack-kde-lo-base/language-pack-kde-lo-base_10.04+20100406_all.deb (455/458 228/500)
  want pool/main/l/language-pack-kde-lo/language-pack-kde-lo_10.04+20100406_all.deb (457/458 229/500)
  want pool/main/l/language-pack-kde-mg-base/language-pack-kde-mg-base_10.04+20100406_all.deb (459/458 230/500)
  want pool/main/l/language-pack-kde-mg/language-pack-kde-mg_10.04+20100406_all.deb (461/458 231/500)
  want pool/main/l/language-pack-kde-mt-base/language-pack-kde-mt-base_10.04+20100406_all.deb (463/458 232/500)
  [...]

The problem is the patch adds an $i++ but $i is already getting incremented in the test against $max_batch. Converting the latter test to not increment appears to fix both the odd output and the missing package downloads.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debmirror - 1:2.4.4ubuntu2

---------------
debmirror (1:2.4.4ubuntu2) lucid; urgency=low

  * drop-redundant-rsync.patch: fix index double-increment (LP: #560826)
 -- Steve Beattie <email address hidden> Sun, 11 Apr 2010 10:02:11 -0700

Changed in debmirror (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers