Failed to install grub in expert mode

Bug #985836 reported by Ivan Frederiks on 2012-04-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Low
Unassigned

Bug Description

Based on this test: http://testcases.qa.ubuntu.com/Install/AlternateExpert
And on this image: http://cdimage.ubuntu.com/daily/20120419/precise-alternate-i386.iso
Installation was performed on VirtualBox:
virtualbox-4.1:
  Installed: 4.1.12-77245~Ubuntu~natty
  Candidate: 4.1.12-77245~Ubuntu~natty
  Version table:
 *** 4.1.12-77245~Ubuntu~natty 0
        500 http://download.virtualbox.org/virtualbox/debian/ natty/contrib i386 Packages
        100 /var/lib/dpkg/status
Below is part of syslog corresponding to grub installation. Full syslog is attached to report.

Apr 19 19:06:27 main-menu[287]: INFO: Menu item 'grub-installer' selected
Apr 19 19:06:27 grub-installer: info: architecture: i386/generic
Apr 19 19:06:28 in-target: Reading package lists...
Apr 19 19:06:30 in-target:
Apr 19 19:06:30 in-target: Building dependency tree...
Apr 19 19:06:30 in-target:
Apr 19 19:06:30 in-target: Reading state information...
Apr 19 19:06:30 in-target:
Apr 19 19:06:30 in-target: You might want to run 'apt-get -f install' to correct these:
Apr 19 19:06:30 in-target: The following packages have unmet dependencies:
Apr 19 19:06:30 in-target: language-pack-gnome-en : Depends: language-pack-gnome-en-base (>= 1:12.04+20120417) but it is not going to be installed
Apr 19 19:06:30 in-target: E
Apr 19 19:06:30 in-target: :
Apr 19 19:06:30 in-target: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Apr 19 19:06:30 in-target:
Apr 19 19:06:32 in-target: Reading package lists...
Apr 19 19:06:32 in-target:
Apr 19 19:06:32 in-target: Building dependency tree...
Apr 19 19:06:32 in-target:
Apr 19 19:06:32 in-target: Reading state information...
Apr 19 19:06:32 in-target:
Apr 19 19:06:32 in-target: You might want to run 'apt-get -f install' to correct these:
Apr 19 19:06:32 in-target: The following packages have unmet dependencies:
Apr 19 19:06:32 in-target: language-pack-gnome-en : Depends: language-pack-gnome-en-base (>= 1:12.04+20120417) but it is not going to be installed
Apr 19 19:06:32 in-target: E
Apr 19 19:06:32 in-target: :
Apr 19 19:06:32 in-target: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Apr 19 19:06:32 in-target:
Apr 19 19:06:33 grub-installer: info: Identified partition label for /dev/sda1: msdos
Apr 19 19:06:34 grub-installer: dpkg: warning: there's no installed package matching grub
Apr 19 19:06:34 grub-installer: dpkg: warning: there's no installed package matching grub-legacy
Apr 19 19:06:34 grub-installer: dpkg: warning: there's no installed package matching grub-efi
Apr 19 19:06:34 grub-installer: dpkg: warning: there's no installed package matching grub-efi-amd64-bin
Apr 19 19:06:34 grub-installer: dpkg: warning: there's no installed package matching grub-efi-amd64
Apr 19 19:06:34 grub-installer: dpkg: warning: there's no installed package matching grub-efi-ia32-bin
Apr 19 19:06:34 grub-installer: dpkg: warning: there's no installed package matching grub-efi-ia32
Apr 19 19:06:35 in-target: Reading package lists...
Apr 19 19:06:35 in-target:
Apr 19 19:06:35 in-target: Building dependency tree...
Apr 19 19:06:35 in-target:
Apr 19 19:06:35 in-target: Reading state information...
Apr 19 19:06:35 in-target:
Apr 19 19:06:35 in-target: You might want to run 'apt-get -f install' to correct these:
Apr 19 19:06:35 in-target: The following packages have unmet dependencies:
Apr 19 19:06:35 in-target: grub-pc : Depends: grub-common but it is not going to be installed
Apr 19 19:06:35 in-target: Depends: grub2-common (= 1.99-21ubuntu3) but it is not going to be installed
Apr 19 19:06:35 in-target: Depends: grub-pc-bin (= 1.99-21ubuntu3) but it is not going to be installed
Apr 19 19:06:35 in-target: Depends: grub-gfxpayload-lists but it is not going to be installed
Apr 19 19:06:35 in-target: language-pack-gnome-en : Depends: language-pack-gnome-en-base (>= 1:12.04+20120417) but it is not going to be installed
Apr 19 19:06:35 in-target: E
Apr 19 19:06:35 in-target: :
Apr 19 19:06:35 in-target: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Apr 19 19:06:35 in-target:
Apr 19 19:06:36 grub-installer: info: Calling 'apt-install grub-pc' failed
Apr 19 19:06:46 main-menu[287]: (process:11159): chroot: can't execute 'grub-probe': No such file or directory
Apr 19 19:06:46 main-menu[287]: (process:11159): chroot: can't execute 'grub-probe': No such file or directory
Apr 19 19:06:46 main-menu[287]: (process:11159): File descriptor 3 (pipe:[6948]) leaked on lvdisplay invocation.
Apr 19 19:06:46 main-menu[287]: (process:11159): Parent PID 11372: /bin/sh
Apr 19 19:06:46 main-menu[287]: (process:11159): File descriptor 4 (/dev/pts/0) leaked on lvdisplay invocation.
Apr 19 19:06:46 main-menu[287]: (process:11159): Parent PID 11372: /bin/sh
Apr 19 19:06:46 main-menu[287]: (process:11159): File descriptor 5 (/dev/pts/0) leaked on lvdisplay invocation.
Apr 19 19:06:46 main-menu[287]: (process:11159): Parent PID 11372: /bin/sh
Apr 19 19:06:46 main-menu[287]: (process:11159): File descriptor 6 (/dev/pts/0) leaked on lvdisplay invocation.
Apr 19 19:06:46 main-menu[287]: (process:11159): Parent PID 11372: /bin/sh
Apr 19 19:06:46 main-menu[287]: (process:11159):
Apr 19 19:06:46 main-menu[287]: (process:11159): Volume group "sda" not found
Apr 19 19:06:46 main-menu[287]: (process:11159):
Apr 19 19:06:46 main-menu[287]: (process:11159):
Apr 19 19:06:46 main-menu[287]: (process:11159): Skipping volume group sda
Apr 19 19:06:46 main-menu[287]: (process:11159):
Apr 19 19:06:46 main-menu[287]: INFO: Menu item 'grub-installer' succeeded but requested to be left unconfigured.
Apr 19 19:06:46 main-menu[287]: DEBUG: resolver (libnewt0.52): package doesn't exist (ignored)
Apr 19 19:06:46 main-menu[287]: DEBUG: resolver (ext2-modules): package doesn't exist (ignored)
Apr 19 19:06:46 main-menu[287]: DEBUG: resolver (efi-modules): package doesn't exist (ignored)

Ivan Frederiks (idfred) wrote :
Ivan Frederiks (idfred) wrote :
description: updated
Ivan Frederiks (idfred) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/985836

tags: added: iso-testing
Stéphane Graber (stgraber) wrote :

Looking at your logs, this look like a version mismatch between package on the media and packages on your local mirror.

You seem to have done the install using de.archive.ubuntu.com which may have outdated packages explaining that failure.
Could you try installing with archive.ubuntu.com instead or install without internet connectivity?

Thanks

Changed in debian-installer (Ubuntu):
status: New → Incomplete
Ivan Frederiks (idfred) wrote :

Ok, I'll try.

Ivan Frederiks (idfred) wrote :
Download full text (5.5 KiB)

Using archive.ubuntu.com as mirror gave no effect:
Apr 20 09:32:22 main-menu[281]: INFO: Menu item 'grub-installer' selected
Apr 20 09:32:22 grub-installer: info: architecture: i386/generic
Apr 20 09:32:24 in-target: Reading package lists...
Apr 20 09:32:28 in-target:
Apr 20 09:32:28 in-target: Building dependency tree...
Apr 20 09:32:29 in-target:
Apr 20 09:32:29 in-target: Reading state information...
Apr 20 09:32:29 in-target:
Apr 20 09:32:29 in-target: You might want to run 'apt-get -f install' to correct these:
Apr 20 09:32:29 in-target: The following packages have unmet dependencies:
Apr 20 09:32:29 in-target: language-pack-gnome-de : Depends: language-pack-gnome-de-base (>= 1:12.04+20120417) but it is not going to be installed
Apr 20 09:32:29 in-target: E
Apr 20 09:32:29 in-target: :
Apr 20 09:32:29 in-target: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Apr 20 09:32:29 in-target:
Apr 20 09:32:30 in-target: Reading package lists...
Apr 20 09:32:31 in-target:
Apr 20 09:32:31 in-target: Building dependency tree...
Apr 20 09:32:31 in-target:
Apr 20 09:32:31 in-target: Reading state information...
Apr 20 09:32:31 in-target:
Apr 20 09:32:31 in-target: You might want to run 'apt-get -f install' to correct these:
Apr 20 09:32:31 in-target: The following packages have unmet dependencies:
Apr 20 09:32:31 in-target: language-pack-gnome-de : Depends: language-pack-gnome-de-base (>= 1:12.04+20120417) but it is not going to be installed
Apr 20 09:32:31 in-target: E
Apr 20 09:32:31 in-target: :
Apr 20 09:32:31 in-target: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Apr 20 09:32:31 in-target:
Apr 20 09:32:32 grub-installer: info: Identified partition label for /dev/sda1: msdos
Apr 20 09:32:33 grub-installer: dpkg: warning: there's no installed package matching grub
Apr 20 09:32:33 grub-installer: dpkg: warning: there's no installed package matching grub-legacy
Apr 20 09:32:33 grub-installer: dpkg: warning: there's no installed package matching grub-efi
Apr 20 09:32:33 grub-installer: dpkg: warning: there's no installed package matching grub-efi-amd64-bin
Apr 20 09:32:33 grub-installer: dpkg: warning: there's no installed package matching grub-efi-amd64
Apr 20 09:32:33 grub-installer: dpkg: warning: there's no installed package matching grub-efi-ia32-bin
Apr 20 09:32:33 grub-installer: dpkg: warning: there's no installed package matching grub-efi-ia32
Apr 20 09:32:34 in-target: Reading package lists...
Apr 20 09:32:35 in-target:
Apr 20 09:32:35 in-target: Building dependency tree...
Apr 20 09:32:36 in-target:
Apr 20 09:32:36 in-target: Reading state information...
Apr 20 09:32:36 in-target:
Apr 20 09:32:36 in-target: You might want to run 'apt-get -f install' to correct these:
Apr 20 09:32:36 in-target: The following packages have unmet dependencies:
Apr 20 09:32:36 in-target: grub-pc : Depends: grub-common but it is not going to be installed
Apr 20 09:32:36 in-target: Depends: grub2-common (= 1.99-21ubuntu3) but it is not going to be installed
Apr 20 09:32:36 in-target: Depends: grub-pc-bin (= 1.99-21ubuntu3) but it is not going t...

Read more...

Ivan Frederiks (idfred) wrote :

Tried once again, answered no to "network mirror" question. Syslog got even "better"
I'll try to install once again with "disconnected network cable".

I've already seen messages like
> Apr 20 10:06:23 main-menu[281]: (process:2969): : No space left on device
during one of installation attempts. I use 8GB virtual hard disk, it should be sufficient.
This looks like different bug, should I file it?

Ivan Frederiks (idfred) wrote :

Tired completely offline installation. This time I also used new clean harddrive. GRUB setup failed. Syslog attached.
I think next time I'll try to perform non-expert install on same machine.

Ivan Frederiks (idfred) wrote :

Installation in regular mode succeeded.

Changed in debian-installer (Ubuntu):
importance: Undecided → Low
Ivan Frederiks (idfred) wrote :

Expert-install attempt failed with 20120423 image .
I'll try 20120423.2 now.

P.S.
But jbel somehow managed to complete installation: http://iso.qa.ubuntu.com/qatracker/milestones/214/builds/15981/testcases/23/results

Ivan Frederiks (idfred) wrote :

Sorry, I wanted to say jibel: http://launchpad.net/~jibel

Launchpad Janitor (janitor) wrote :

[Expired for debian-installer (Ubuntu) because there has been no activity for 60 days.]

Changed in debian-installer (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers