Ubuntu

Can't install Ubuntu 12.04 beta 2 Alternative

Reported by Johan Ryberg on 2012-04-08
90
This bug affects 20 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned

Bug Description

I have tried to install Ubuntu 12.04 Alternative without success. Both server and standard "live" installation works.

I have tried different methods but it seems like some dependencies does not met the installers expectations.

This is the image that I have tried: http://releases.ubuntu.com/12.04/ubuntu-12.04-beta2-alternate-amd64.iso

Installing the base systems seems OK but not the softwares. I got a big red screen with error message "An installation step failed..."

"Work around" is to install server and then ubuntu-desktop meta package. I want to use LVM and disk encryption so I cant use the standard installation.

This is the syslog error message:
Apr 8 11:27:02 in-target: Some packages could not be installed. This may mean that you have
Apr 8 11:27:02 in-target: requested an impossible situation or if you are using the unstable
Apr 8 11:27:02 in-target: distribution that some required packages have not yet been created
Apr 8 11:27:02 in-target: or been moved out of Incoming.
Apr 8 11:27:02 in-target: The following information may help to resolve the situation:
Apr 8 11:27:02 in-target:
Apr 8 11:27:02 in-target: The following packages have unmet dependencies:
Apr 8 11:27:02 in-target: gnome-control-center : Depends: libnm-gtk0 but it is not installable
Apr 8 11:27:02 in-target: network-manager-pptp : Depends: libnm-glib-vpn1 (>= 0.7.999) but it is not installable
Apr 8 11:27:02 in-target: network-manager-pptp-gnome : Depends: libnm-glib-vpn1 (>= 0.8.998) but it is not installable
Apr 8 11:27:02 in-target: xserver-xorg-video-all : Depends: xserver-xorg-video-ati but it is not installable
Apr 8 11:27:02 in-target: Depends: xserver-xorg-video-nouveau but it is not installable
Apr 8 11:27:02 in-target: E: Unable to correct problems, you have held broken packages.
Apr 8 11:27:02 in-target: tasksel: aptitude failed (100)
Apr 8 11:27:03 main-menu[368]: WARNING **: Configuring 'pkgsel' failed with error code 1
Apr 8 11:27:03 main-menu[368]: WARNING **: Menu item 'pkgsel' failed.
Apr 8 11:28:08 main-menu[368]: INFO: Modifying debconf priority limit from 'high' to 'medium'
Apr 8 11:28:08 debconf: Setting debconf/priority to medium
Apr 8 11:28:09 main-menu[368]: DEBUG: resolver (libnewt0.52): package doesn't exist (ignored)
Apr 8 11:28:09 main-menu[368]: DEBUG: resolver (ext2-modules): package doesn't exist (ignored)
Apr 8 11:28:16 main-menu[368]: INFO: Menu item 'save-logs' selected
Apr 8 11:28:22 main-menu[368]: DEBUG: resolver (libnewt0.52): package doesn't exist (ignored)
Apr 8 11:28:22 main-menu[368]: DEBUG: resolver (ext2-modules): package doesn't exist (ignored)

Providing all debug files from the installer as attachments

Johan Ryberg (jryberg) wrote :
Johan Ryberg (jryberg) wrote :
Johan Ryberg (jryberg) wrote :
Johan Ryberg (jryberg) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/976509/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Johan Ryberg (jryberg) on 2012-04-08
affects: ubuntu → debian-installer (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Tom (tomrittervg) wrote :

Not sure if this is helpful, but this seems very similar to 909880 - a graceful way to handle package dependency problems would resolve both.

hansaplast (9orums) wrote :

If you're installing from a USB-drive, you can fix this doing the following.

On your USB-drive:
- cd to "pool/main/x/xserver-xorg-video-ati/"
- Make sure all files end with the " _amd64.deb" (or _i386.deb if your'e on i386) extention. If not rename them!
- Do the same in "pool/main/x/xserver-xorg-video-nouveau"
- Installation will now proceed without errors (at least in my case)

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/976509

tags: added: iso-testing
BUGHUNTER (bughunter) wrote :

Had the same error in iso downloaded 2012-05-21.

Data (ubuntuaddress) wrote :

Might be the same bug as bug #989902 (which has a more detailed description of the problem).
I am not sure though...

znorris (znorris) wrote :

Still affected in ubuntu-12.04.1-alternate-amd64.iso

znorris (znorris) wrote :

I attempted the workaround @hansaplast suggested but it didn't work. I'm left with this in syslog:

in-target: The following packages have unmet dependencies:
in-target: xserver-xorg-video-ati : Depends: xserver-xorg-video-radeon but it is not installable

micxbro (micxbro) wrote :

@znorris
Rename the radeon file in the xserver-xorg-video-ati folder as well

xserver-xorg-video-radeon_6.14.99~git20111219.aacbd629-0ubunt.deb -> xserver-xorg-video-radeon_6.14.99~git20111219.aacbd629-0ubuntu2_amd64.deb

Joe Millenbach (jmillenbach) wrote :

Seems like it is related to making the USB bootable media on a Windows machine. znorris said in a forum thread that making the USB stick with DD let him install fine.

Felix Dreissig (f30) wrote :

@jmillenbach: I doubt that: I have been affected by the this problem as well and I didn't create the bootable USB drive on Windows for sure. In fact, I tried various ways with dd most likely being one if them; none if them worked.

check md5sum.txt for what the filenames should be

I'm using ubuntu-12.04.1-alternate-amd64

I had to rename three xserver-xorg-video* packages to match md5sum.txt, and then the install started to sail along.

Runar Ingebrigtsen (ringe) wrote :

This problem is still present on ubuntu-12.04.3-alternate-i386

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers