SATA disk's partitions not detected (but drive is)

Bug #90042 reported by Jimmy the shoe on 2007-03-06
4
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned

Bug Description

I have an HP nc8430 laptop with an Intel motherboard with an Intel SATA controller and Intel core 2 duo processor. When using the graphical installer of dapper, I am able to detect and manage partitions just fine (resize, reformat, etc) but when using the feisty alternate install CD, my hdd is detected and the partitioner gives me the option to format, but I can not make changes to my existing partition (e.g. reformat my ext3 partition to reiserfs). Will download a graphical live CD and try formating a drive with the alternate installer on my laptops at work and update this bug later (we have several thousand of these models)

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the output of 'lspci -vv' and 'lspci -vvn' to your bug report? Thanks in advance.

Jimmy the shoe (jdshewey) wrote :

Output is in attached documents. This was listed on ubuntu dapper.

Brian Murray (brian-murray) wrote :

Please let us know when you have also tested the graphical installer. Thanks in advance.

Jimmy the shoe (jdshewey) wrote :

I tried the graphical installer on my personal laptop and received the same results. I also tried testing one of my companies other nc8430s (as I mentioned, we have several thousand and a few dozen lying around the shop as replacements) and it responded by displaying a blank pane. lspci output for this laptop is attached (both lspci -vv and lspci -vvn) I will attach the error output for the text based install shortly, as it is different and saved on my personal computer (I am currently writing this using the fiesty live CD.

Jimmy the shoe (jdshewey) wrote :

For the above computer when it comes time to partition, The menu appears as:

0
Guided - Resize cdrom-retriever and user freed space
Guided - use entire disk
Guided - Use entire disk and set up LVM

selecting any option generates an error message saying:

No root filesystem defined

When this message pops up, selecting back yields no results and does not work

Changed in debian-installer:
assignee: brian-murray → nobody
status: Needs Info → Confirmed
Colin Watson (cjwatson) wrote :

Thanks for your report. This looks very much like bug 89004, which is fixed in the Feisty beta.

If you reproduce this again. lspci output isn't much use to me, but /var/log/syslog and /var/log/partman would be helpful.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers