partitioning fails during install (herd 5 kub alt)

Bug #89586 reported by bailout on 2007-03-04
4
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned

Bug Description

I just tried installing herd 5 using the alternate cd but couldn't get past the partition stage.

My drive has a win ntfs partition, then a fat32 and then I had let the edgy install use the remaing space and it created a swap and /. I deleted these before trying herd 5 so there was just freespace at the end of the drive.

At the partitioning stage of the install I got 4 choices, the first was something about a cd? which I didn't understand then three 'guided' options, there was no manual option that I could see. I tried the 'guided use free space' option but it just goes to a red screen with a message about there being no root partition allocated. There are two buttons, continue and go back, IIRC. Clicking either just reloads the red warning screen so I had to restart and abandon install.

I checked the md5sum of both the iso and the burnt cd and they were fine.

I was trying to install on my laptop (fujitsu-siemens pi1505) that has a sata disk but this wasn't a problem when I installed edgy.

Im having the same issue on Xubuntu Herd 5 on a XPS 1210 laptop. I'm using the alternate-install cd and once at the partitioning menu, I see no option for manual partitioning. If I click on ANY option, I get the red screen as well as a message - "No Root Filesystems"
I cant go back from this step

ChrisNeilson (mbjsscn2) wrote :

I found the same issue using herd 4 and herd 5 Kubuntu alternative install CDs on my Compaq Evo N1020v. The Kubuntu graphical install cds have similar problems with partitioning on this machine. My somewhat long-winded workround was to install Edgy (in my case via the alternative install CD) then do a dist-upgrade to feisty.

ChrisNeilson (mbjsscn2) wrote :

To add to my earlier comment re my Compaq Evo N1020v - Having installed Edgy and used dist-upgrade to overcome the problems I was having with the herd 5 cd - I found the grub menu.lst to be corrupted by the dist-upgrade. It was now trying to boot /dev/hd5 instead of /dev/hd8 which the Edgy install had earlier detected and set correctly as the root partition. I ran grub-install and grub-update from rescue mode and it started working as the relevent ext3 partition was now being identified in menu.lst by its disc id and not in /dev/hd* notation. I am assuming this, like the issues with the herd cds, was down to the three windows partitions already on this machine creating problems with the feisty install/upgrade process.

Mark Anderson (manderson23) wrote :

I have the same issue on my home-built machine. I have two IDE hard drives. One has a /, /boot and /home partition for Edgy and two NTFS partitions for Windows. The other disk has two FAT32 partitions.

I have previously installed Edgy on this setup using the alternative CD.

Colin Watson (cjwatson) wrote :

Thanks for your report. This is also bug 89004, fixed in current daily builds (not Herd 5).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers