Ubuntu

Ubuntu 11.10 luks+lvm+btrfs install fail

Reported by Kim Allamandola on 2011-10-13
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned

Bug Description

I try my standard setup since Natty (sorry for my bed English):
 /boot 150Mb as ext3
 LUKS as a PV
  LVM with
   lv-root (~10G)
   lv-home (all the free space)
   lv-swap (~1Gb)

At a hardware level I have tried various machine with both SSD (Intel X-25M
160Gb, OCZ Vertex 3 60Gb) and some platter disk.

Step to reproduce: download alternate-amd64 install cd, put onto a usb stick,
boot with it and install (loaded "donwload installer, parted and squashfs").
Partition as described above and before install the base system open a shell
(Alt+F2, <enter>) and remount both root and home with, if you are on an SSD:
 mount -o remount,compress,discard,ssd,space_cache /dev/mapper/...
or if you are on a platter disk use:
 mount -o remount,compress /dev/mapper/...

Now install the base system.

If you go back to the shell and take a look at /var/log/syslog:
 grep "No space left" /var/log/syslog
you'll see that linux-headers-3.0.0-12_3.0.0-12.20_all.deb fail to install
due to "No space left on device"; of course if you take a look a df you'll
see you have all the space you need... Also if you put a static df with -i
support you'll see that you aren't run out of inodes...

Installer continue without complain to user setup and mirror setup and
finally fail when try to install the rest of the system.

Choose linux-image-generic instead of linux-generic doesn't matter, same
choose not to download installer and not to load squashfs.

From /var/log/syslog (italian localisation, sorry):
 Oct 13 13:38:13 in-target: Estrazione di linux-headers-3.0.0-12 (da .../linux-headers-3.0.0-12_3.0.0-12.20_all.deb)...
 Oct 13 13:38:29 in-target: dpkg: errore nell'elaborare /media/cdrom//pool/main/l/linux/linux-headers-3.0.0-12_3.0.0-12.20_all.deb (--unpack):
 Oct 13 13:38:29 in-target: impossibile installare la nuova versione di "/usr/src/linux-headers-3.0.0-12/arch/ia64/sn/include/ioerror.h": No space left on device
 Oct 13 13:38:29 in-target: No apport report written because the error message indicates a disk full error

Full log attached, no idea on how to circumvent.

Kim Allamandola (spacexplorer) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Jan (jankanis) wrote :

I'm having the same problem. I'm trying to install Ubuntu 11.10 from the alternate iso by USB stick. I'm using a normal harddisk with a btrfs root, and an ext4 on LVM /home, but no LUKS.

The install fails at 'Select and install software'. Inspection of syslog shows that linux-headers-3.0.0-12-generic fails to install, because dpkg reports a disk-full error when extracting the package.

To narrow down the problem, I did the following in a shell in the installer environment:
> chroot /target bash
> cd /media/cdrom/pool/main/l/linux
> dpkg -i linux-headers-3.0.0-12-generic_3.0.0-12.20_amd64.deb
<dpkg gives an error indicating a disk-full while extracting the .deb>

I then tried generating more debug info:
> dpkg -i -D10 linux-headers-3.0.0-12-generic_3.0.0-12.20_amd64.deb 2>/tmp/dpkgout

And now suddenly it worked. I did the same with linux-headers-3.0.0-12_3.0.0-12.20_all.deb because I thought that was the one I really needed, with the same results: it failed first but worked with the -D10 flag.

I then did a 'apt-get -f install' (which previously failed with the same disk full error from dpkg) which now worked. After that I coundn't reproduce the dpkg error, but I didn't try forcefully removing the headers packages so as not to cause more problems, so I don't have the exact console output from dpkg.

I restarted the system install at 'install base system', and after that 'select and install software' also worked.

Jan (jankanis) wrote :

I restarted the install due to bug #774217, and changed the root partition from btrfs to ext4. This time the same install iso on the same system ran without a problem, so it's definately something triggered by btrfs and not ext4.

While still attempting to install on btrfs, I also ran into this error with package humanity-icon-theme. dpkg gave the following output:

(Reading database ... 82240 files and directories currently installed.)
Unpacking humanity-icon-theme (from humanity-icon-theme_0.5.3.11_all.deb) ...
dpkg: error processing humanity-icon-theme_0.5.3.11_all.deb (--install):
 unable to install new version of `/usr/share/icons/Humanity/actions/128/stock_media-stop.svg': No space left on device
Errors were encountered while processing:
 humanity-icon-theme_0.5.3.11_all.deb

I also attached my syslog from during the install. It contains several tries at running steps of the installer, so it's quite large.

Bob Schmertz (rschmertz) wrote :

I "upgraded" from 10.04 to 11.10 -- really a fresh install, preserving only the /home and /boot partitions, and reformatting /var and / as btrfs. So here's my disk setup:

 /boot 152Mb as ext4
 swap
 LVM with
    Group1--Root (6.6G/btrfs)
    Group1--Home (23G/ext4)
    Group1--Var (2.4G/btrfs)

I got through the install no problem, but am now seeing problems when I try to upgrade linux kernel headers using the Update Manager:

     linux-headers-generic: Depends: linux-headers-3.0.0-14-generic but it is not installed

and, at the suggestion of Update Manager, I run "apt-get install -f", and I get:

dpkg: error processing /var/cache/apt/archives/linux-headers-3.0.0-14-generic_3.0.0-14.23_amd64.deb (--unpack):
 unable to install new version of `/usr/src/linux-headers-3.0.0-14-generic/include/config/mfd/timberdale.h': No space left on device
No apport report written because the error message indicates a disk full error

I have 113M free on /boot (pretty sure /boot is not involved) and 2.4G free on the root partition.

Have not tried the workarounds mentioned by Jan.

Bob Schmertz (rschmertz) wrote :

I have followed up with the dpkg command with the -D10 option (why is it always the kernel headers?), followed by a repeat of the apt-get install -f command (again this is on an already installed system), and I got the same results as Jan. Now everything is sunshine and rainbows and kittens on my system. Thanks for the tip!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers