preseeded partition attempts to proceed too fast

Bug #859319 reported by Jamin W. Collins on 2011-09-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Medium
Unassigned

Bug Description

With a fully preseeded configuration, including automated partition via a custom recipe, the installer attempts to proceed through the partitioning too fast resulting in transient errors being presented to the user such as the following:

====8<========================================================>8=====

Could not stat device /dev/mapper/vg0-home - No such file or directory.

ERROR!!!
    Retry
    Cancel

 <Go Back>

====8<========================================================>8=====

The specific device it errors on tends to vary. Sometimes it errors on mutliples, sometimes only one. In every case, simply selecting Retry works.

Perhaps the partitioning process should attempt to sync out device changes and/or wait for changes made to settle in.

I've been able to reproduce this issue quite reliably using a virtual machine with a 40G drive and the attached seed file. The installs have been a seeded oem-config.

Jamin W. Collins (jcollins) wrote :
Jamin W. Collins (jcollins) wrote :

Should also be noted that I'm experiencing this using the 11.04 64-bit alternate installer CD.

tags: added: natty
Changed in debian-installer (Ubuntu):
importance: Undecided → Medium
Diego Morales (dgmorales) wrote :

This is probably the same as #964957, isn't it?

Maybe should be marked as duplicate?

Jamin W. Collins (jcollins) wrote :

Yes, it looks like a duplicate of this report. Which got more attention and presumably a fix committed.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers