Problems with partitioning on Feisty (alternate iso)

Bug #79490 reported by domcio on 2007-01-16
14
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
High
Unassigned

Bug Description

I have a 40GB HDD on my Toshiba Tecra A2 with partitions table configured as follows:

root@tosia:/home/domcio# fdisk -l

Disk /dev/hda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot Start End Blocks Id System
/dev/hda1 * 1 1020 8193118+ 7 HPFS/NTFS
/dev/hda2 1021 1472 3630690 83 Linux
/dev/hda3 1473 4864 27246240 5 Extended
/dev/hda5 1473 1594 979933+ 82 Linux swap / Solaris
/dev/hda6 1595 4864 26266243+ 7 HPFS/NTFS
root@tosia:/home/domcio#

However during install from Feisty Herd2 alternate ISO I've noticed following errors:
1. there is no manual partitioning option
2. other options see only swap partitions and there is still no manual re-partition option after automatic partitioning (although it should be there)
3. if i choose first option "cd-<something>" - sorry but i can't remember this option name right now - I get just a strange report which doesn't look like partition list at all

P.S. The same happened with herd1 alternate iso and network install from PXE. There were no problems with Dapper, or Edgy betas.

domcio (dczechowski) wrote :

Some additional info:

1. There is no problem with gparted from Desktop CD (only text-mode partitioning doesn't work correctly)
2. After dist-upgrade from Edgy to Feisty both fdisk and parted work correctly

There are 3 photos of my laptop screen in attachment:
- feisty_part_01.jpg shows first screen during partitioning
- feisty_part_02.jpg shows screen after choosing cdrom-retreiver
- feisty_part_03.jpg shows screen after choosing "No" and then "Go back"

domcio (dczechowski) wrote :
domcio (dczechowski) wrote :

partman run from Desktop CD terminal on the same laptop shows partition's list correctly - see attached photo

Ralf (ralf-weyer) wrote :

Hello,

the same problem here, tried it with alternate-CD's Herd-2 and daily-18.01 (today), both the same problem.

Worked perfect in breezy, dapper and edgy.

On my computer this was not the only problem, the installation is extremly slow, especially when the installer tries to detact the hardware (for example networkcards). It takes minutes before it finishes theses tasks. But I think I've seen this problem reported in another bug-report, so no knew report should be created?

Attached the output of hwinfo for detailed information about the hardware I'm using.

Regards,

Ralf

According to my testing I can confirm the bug on post Herd2 amd64.

Installing 20070117 alternate amd64 on a physical HDD (sata) with existing partitions fails in the same way - the installer cannot choose for installation neither free space nor select pre-formatted / and /swap partitions .

However the same build installs perfectly as a VM guest with blank vmdisk. I got me a new HDD today and will try soon to reproduce a nice alt install on it.

Is it accurate to suggest that if the bugs in the text installer regarding partitioning and formatting (in the case of existing partitions) are not solved, the desktop CD cannot move forward?

domcio (dczechowski) on 2007-01-20
Changed in debian-installer:
assignee: nobody → isotesting
assignee: isotesting → nobody

I assigned this bug to the Ubuntu Installer team. Is there anybody in specific who should be appointed?

Changed in debian-installer:
assignee: nobody → ubuntu-installer
status: Unconfirmed → Confirmed
Ralf (ralf-weyer) wrote :

Hello,

any news for this bug?

It still does not work in Herd-3 and todays daily-build alternate cd.

And there are even more problems if seen:

When I try to install without any options I only get an error message "Kernel not found" (when I switch to Ctrl+Alt+F4). I think there is already a bug filed, but I can't remember the bug number at the moment.

Only when I start the CD with the option "irqpoll hw-detect hw-detect/start_pcmcia=false" I get as far as the partitioner, but then I'm not able to create a partition, like mentioned before in this bug.

The hardware I use is already attached above.

I would really test feisty and look for problems, so they can be fixed until releasedate, but how can I, if I'm not able to install?

Regards,

rpw

Paulo Tanimoto (tanimoto) wrote :

Problem persists in Herd 3. Assigning to Colin Watson, just to call it to his attention. Please re-assign as necessary.

Changed in debian-installer:
assignee: ubuntu-installer → kamion
Paulo Tanimoto (tanimoto) wrote :

Just to be complete, here's a discussion thread on this problem.

http://www.ubuntuforums.org/showthread.php?t=336907

Hoàng Đức Hiếu (hdhoang) wrote :

The problem persists on 20070214 i386 alternate cd (note that the i386 image was pulled out of 20070214.1)
Hope this bug will be fixed in herd 4

steve.horsley (steve-horsley) wrote :

Problem confirmed still present in the daily download as of 15th Feb. It's a corker!
It thinks sda5 is a primary partition, it uses error text from an Exception as partition table data, and wants to write five separate sda7 partitions.

I added a comment to the forums thread: http://www.ubuntuforums.org/showpost.php?p=2166325&postcount=15

Tollef Fog Heen (tfheen) wrote :

Milestoning for next herd; Removing assignment to Colin.

Changed in debian-installer:
assignee: kamion → nobody

I can confirm this in Herd CD 4.

John Haines (wanderer) wrote :

I can confirm that this bug is in Herd 4 as well, I asked about it in the fiesty forums, in this thread (screenies are in it)

http://www.ubuntuforums.org/showthread.php?t=365762

 and was kindly pointed to this place and was suggested I post my experience as well as well (that's why I posted the thread addie I started)..

antoniolifer (antoniolifer) wrote :

I can also confirm this bug in Herd 4.

But, is anybody working on this? This bug should be marked as of high importance. If the bug is not solved then people won't be able to install Feisty!!

By the way, the bug description should be changed: this affects Feisty Herd1, Herd2, Herd3 and Herd4 (and not just Herd1 and Herd2).

Furthermore, the bug doesn't allow people to install on systems with existing partitions, so the description should read "Cannot install Feisty on systems with existing partitions".

Cheers,
Antonio

Changed in debian-installer:
importance: Undecided → High
antoniolifer (antoniolifer) wrote :

Hi,

This is happening with the normal ISO as well!

Cheers,
Antonio

Bernd (bernd80) wrote :

I can confirm the bug for herd-4 too.

JonM (jon-mechling) wrote :

I'm having a similar issue with Herd 5. In Herd 3, I was able to get the alternate CD partitioner to finally recognize my disks and partitions by getting to a point where I was told there was no root partition (red screen background), going back, and restarting the partitioner. If I did this several times, it seemed eventually partitioner found my partitions.

But in Herd 5, I tried several of the various non-sensical options:

cdrom-retreiver
IDE slave, partition # ()
0
Guided-resize cdrom-retreiver and use freed space

and I always get to a point where I get a red screen where I am told there is no root partition, and the two options ("back" and "okay" [or "forward" or "continue", I can't quite remember]) both do the same thing - nothing. To get off the red screen, I have to ctrl-alt-del reboot.

So for me, Feisty Herd 5 simply won't install, plain and simple. (In case it matters, HDA is a master IDE drive (dual booting Windows and Ubuntu), HDB is the slave IDE drive, and SDA is a lone SATA drive. Asus P4V8X-MX mobo - nothing exotic, and Edgy works beautifully on it.)

sandeepss (sandeepss) wrote :

I am seeing a similar issue in Xubuntu Herd 5. We had acyually filed a separate bug for it
https://launchpad.net/ubuntu/+bug/89586

Mathieu Dupuis (ubuntu-mathd) wrote :

I have the same problem with Herd 5 and the Desktop CD.

On my main SATA HD. I have 2 ntfs partition and I try to install on the rest on the disk. I have tried automatic and manual partitioning and the installation won't work.

Joon Guillen (flyderman) wrote :

I would like to second JonM's report - the same thing happens to my installation.

Colin Watson (cjwatson) wrote :

This is also bug 89004, and should be fixed in current daily images (not Herd 5). Sorry for not getting to this earlier.

Ralf (ralf-weyer) wrote :

Hello,

there still seems to be a problem with the partitioner.

I've got 3 partitions on my harddisc:

hda1, 20 GB, NTFS, Windows XP
hda5, 1 GB, Linux Swap
hda6, 20 GB, EXT3, Ubuntu 6.10

Downloaded the daily Ubuntu Feisty CD today, checked MD5SUM and started the installation. Now I see 4 entries in the partitioner menu. There I started the manual creation of the partition. In the next step I created the partition with proper mount point (/) and size (10 GB), and went on to the next step of the installation process.

Then I got the following error message:

------------------------------------
!! Harddisc partitioning

ISOFEISTY~1.X9D is 1466884k, but it has 4672 clusters (149504k).
Error !!

Ignore
Cancel
------------------------------------

Did not try further before knowing what this problem might be, so I canceled the installation at this point.

Regards,

rpw

Joon Guillen (flyderman) wrote :

I'd just like to report that the latest partman releases have eliminated my prior problems. Installation from alternate CD was successful using the 20070306 build.

I have 2 80gb hard drives, both on the primary IDE.

/dev/hda1 - windows partition (ntfs)
/dev/hda2 - windows partition (ntfs)
/dev/hdb1 ~7GB - /
/dev/hdb2 ~1GB - swap
/dev/hdb3 - windows partition (ntfs)
/dev/hdb4 - windows partition (ntfs)

domcio (dczechowski) wrote :

It looks like there is no problem with 20070311 build.

Ed Bunker (calvin441h) wrote :

Something is still wrong with 20070311 build.

Using expert install and manual partitioning, Partman incorrectly identifies my two EIDE (non SATA) disks as SCSI:

SCSI1 (0,0,0) sda - 251.0 GB ATA MAXTOR 6L250R0
wrong partitions list (/dev/sda1, /dev/sda2, and so on) follows;

SCSI1 (0,1,0) sdb - 82.0 GB ATA MAXTOR 6Y080P0
same as above: (/dev/sdb1, etc)

Ed Bunker: I think you should file a seperate bug, because as domcio confirmed this bug here is fixed and otherwise I'm afraid that nobody will pay attention to this bug.

Ed Bunker (calvin441h) wrote :

Thomas Hotz: Thanks for the tip, I've just filed another bug report concerning this matter: Bug #92014

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers