netinstall refuses to use local mirror

Bug #659632 reported by Chris Stark on 2010-10-13
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Medium
Unassigned

Bug Description

I am in charge of Ubuntu deployments at our organization, and in the past we have used kickstart + preseed files to deploy a tested, customized Ubuntu workstation. Although we do not have a huge number of Ubuntu users, I perform a substantial amount of testing on a configuration prior to mass deployment. Because of this all this testing, I have found that using apt-mirror to create a local mirror of packages saves me an enormous amount of time and bandwidth. This setup worked with both jaunty and lucid. However, with maverick, copying and updating the kickstart and preseed files does not work as before. While the system configuration settings from the kickstart seem to be followed correctly, the installer completely ignores the local mirror configuration and downloads every package from the Internet.

Chris Stark (cstark-gemini) wrote :
Chris Stark (cstark-gemini) wrote :

The PXE boot entry for this installation is:

label u1010c-64
 MENU LABEL Ubuntu 10.10 64-bit
 kernel bootfiles/ubuntu/10.10/x86_64/vmlinuz
 append vga=normal initrd=bootfiles/ubuntu/10.10/x86_64/initrd.gz ks=http://linuxmirror/pub/ks/u1010c-64.cfg ksdevice=eth0 preseed/url=http://linuxmirror/pub/ks/u1010c-64.seed ramdisk_size=65536 root=/dev/rd/0 devfs=mount,dall rw nomodeset --

...and attached is the preseed file

Chris Stark (cstark-gemini) wrote :
Rafael Luque (rluque-uco) wrote :

I solve this issue add

d-i mirror/country string manual

to preseed file and select in ks de mirror (url --url http...) (in my case, one copy ubuntu alternate cd)

Chris Stark (cstark-gemini) wrote :

Hi Rafael,

Thank you for your response. However, it appears I may not have made myself clear. My organization is trying to deploy Ubuntu using an internal mirror of the Ubuntu repositories. We do NOT want to connect to the Internet at all during a kickstart installation. Even if I replace all instances of references to external Internet mirrors with our own private mirror, the installer still insists upon accessing the Internet, thus drastically slowing down the installation process.

Thanks,
Chris

SteveM (stevem) wrote :

I believe I have the same issue.
We have been deploying Ubuntu by pointing the Ubuntu mirror to an internal mirror with a preseed file. This has been working for us since Ubuntu 7.04. I use the same preseed file and just change the directory. Now it's trying to install from gb.archive.ubuntu.com. The d-i installer stops with the error:
Bad archive mirror. An error has been detected while trying to use the specified Ubuntu archive mirror.

my preseed file mirror section:
d-i mirror/country string manual
d-i mirror/http/hostname string {our internal http server}
d-i mirror/http/directory string /ubuntu/1010-64
d-i mirror/suite string maverick
d-i mirror/http/proxy string

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in debian-installer.

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → debian-installer (Ubuntu)
Changed in debian-installer (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
William (kc-cobradevil) wrote :

Hi,

i have the exact same issue.
As a workaround i added two entries

d-i mirror/country string enter information manually
>> d-i mirror/http/countries string enter information manually
d-i mirror/http/hostname string yourmirror-here.org
>> d-i mirror/http/mirror string yourmirror-here.org
d-i mirror/http/directory string /ubuntu
d-i mirror/suite string natty
d-i mirror/http/proxy string

This seems to work but it's not a nice clean solution :)

Christian Orth (corth) wrote :

I use the following settings. The local server isn't used. Affects 12.04

d-i mirror/protocol string http
d-i mirror/country string manual de
d-i mirror/suite string precise
d-i mirror/http/hostname string 172.20.0.2
d-i mirror/http/mirror string 172.20.0.2
d-i mirror/http/directory string /ubuntu/
d-i mirror/http/proxy string

Paul Nijjar (paul-nijjar) wrote :

I ran into the following today too. Looking at the debian installer source (http://wiki.debian.org/DebianInstaller/CheckOut) it looks like support for the "enter information manually" strings have been removed in favour of "manual" . So the example from William at response #8 should be:

d-i mirror/country string manual
d-i mirror/http/countries string manual
d-i mirror/http/hostname string yourmirror-here.org
d-i mirror/http/mirror string yourmirror-here.org
d-i mirror/http/directory string /ubuntu
d-i mirror/suite string natty
d-i mirror/http/proxy string

And Christian Orth (#9) would not work because the string should be "manual" and not "manual de".

I am attaching the contents of "git show bb1bdcaa4eecfc47b69420c0687eb3c2bc8e1d01" from the source. The changelog message was: 'Drop backwards compatibility for preseeding "manual" mirror selection. Change was introduced in Lenny.
One release is enough for backwards compatibility support.'

I am guessing that there is a lot of documentation out there that needs to be changed now.

Leonardo Borda (lborda) wrote :

experiencing same behaviour in 12.04.1 LTS

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers