modules missing from omap netboot image.

Bug #652522 reported by Tobin Davis on 2010-09-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Medium
Colin Watson

Bug Description

Binary package hint: debian-installer

Using the files from http://ports.ubuntu.com/dists/maverick/main/installer-armel/20100211ubuntu28/images/omap/netboot/omap/ to do a netboot install boots into debian installer, but no keyboard input or serial console input is available, and the system appears to have locked up. Nothing on serial console output to indicate hang, but also no usb device detection happening, and all leds are lit solid, indicating hang state.

Tobin Davis (gruemaster) on 2010-09-30
tags: added: armel omap
Changed in debian-installer (Ubuntu):
importance: Undecided → Medium
Ricardo Salveti (rsalveti) wrote :

After booting using the serial console you can grab a shell and check that there's no modules loaded:
 ~ # lsmod
Module Size Used by

There's also no /lib/modules directory.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
tags: added: iso-testing
Colin Watson (cjwatson) wrote :

Which particular kernel modules ought to be present but aren't?

Colin Watson (cjwatson) wrote :

Could you try the images at http://people.canonical.com/~cjwatson/tmp/omap/ and see if they fix this?

Tobin Davis (gruemaster) wrote :

Ok, this has some of the modules, and I now have keyboard, but no network. Need all of the usb nic modules that are normally built for omap as well.

Colin Watson (cjwatson) wrote :

OK, that's straightforward. Thanks.

Colin Watson (cjwatson) on 2010-10-01
Changed in debian-installer (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20100211ubuntu29

---------------
debian-installer (20100211ubuntu29) maverick; urgency=low

  * Add input, NIC, and NFS modules to armel netboot images (LP: #652522).
 -- Colin Watson <email address hidden> Tue, 05 Oct 2010 22:01:29 +0100

Changed in debian-installer (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers