Debian installer fails to properly detect Marvell Avenger development platform

Bug #564992 reported by Tobin Davis on 2010-04-16
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Wishlist
Ubuntu ARM Team
flash-kernel (Ubuntu)
Wishlist
Unassigned
ubiquity (Ubuntu)
Undecided
Ubuntu ARM Team

Bug Description

Binary package hint: debian-installer

Installing on Marvell Avenger development system from netboot-installer failed to properly detect system. No uboot partition and no kernel was selected for install.

Will upload dmidecode info as soon as I can get it generated.
---
Architecture: armel
DistroRelease: Ubuntu 10.04
LiveMediaBuild: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha armel+dove (20100416)
Package: ubiquity 2.2.17
PackageArchitecture: armel
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-204.16-dove 2.6.32.11+drm33.2
Tags: lucid ubuntu-une
Uname: Linux 2.6.32-204-dove armv7l
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Tobin Davis (gruemaster) on 2010-04-16
Changed in debian-installer (Ubuntu):
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)

Avenger arrived too late to add support for Lucid 10.04 release. Marking Won't Fix.

Changed in debian-installer (Ubuntu):
status: New → Won't Fix
Tobin Davis (gruemaster) wrote :

Adding install logs for completeness, even though this won't be fixed this cycle.

Tobin Davis (gruemaster) wrote :

Ubiquity fails the same way. Adding it here as I believe the same info is required to fix it.

Changed in debian-installer (Ubuntu):
assignee: Ubuntu Installer Team (ubuntu-installer) → Ubuntu armel porters (ubuntu-armel)
Changed in ubiquity:
assignee: nobody → Ubuntu armel porters (ubuntu-armel)

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

tags: added: armel
Oliver Grawert (ogra) wrote :

Tobin: the output of /proc/cpuinfo is essential for enabling a new platform in d-i, please attach that, it will speed up enabling as soon as we can do it.

Tobin Davis (gruemaster) wrote :

Here it is.

ubuntu@ubuntu:~$ cat /proc/cpuinfo
Processor : Marvell PJ4 v7 Processor-wmmx-wco rev 2 (v7l)
BogoMIPS : 399.76
Features : swp half thumb fastmult vfp edsp iwmmxt thumbee
CPU implementer : 0x56
CPU architecture: 7
CPU variant : 0x0
CPU part : 0x581
CPU revision : 2

Hardware : Marvell MV88F6781-RD Avengers MID Board
Revision : 0000
Serial : 0000000000000000

Oliver Grawert (ogra) on 2010-04-20
Changed in debian-installer (Ubuntu):
status: Won't Fix → Confirmed
milestone: none → later
importance: Undecided → Wishlist
tags: added: iso-testing
Li Li (lli5) wrote :

Just saw this bug. I think this bug is related.
https://bugs.launchpad.net/ubuntu/+source/flash-kernel/+bug/515834

Oliver Grawert (ogra) wrote :

while you are right that they are related, the mentioned bug is missing the info we need to implement support for these platforms. can you add your /proc/cpuinfo output for the two other desired systems here and make the other one a duplicate (or move the avengers info from here over and make this one a duplicate) ?

(note though that we would also need the hardware to develop a proper bootloader handling patch for flash-kernel (or instead of teh hardware a proven patch for setting up teh bootloaders on these systems), the arch detection is only the first step to implement support for new platforms)

Changed in flash-kernel (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
milestone: none → later
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Colin Watson (cjwatson) on 2012-10-16
affects: ubiquity → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers