[FFE] Include 8021q module in the installer for VLAN support

Bug #530459 reported by Mathias Gug on 2010-03-02
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Colin Watson
linux (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: debian-installer

The 8021q kernel module (and its dependecies slp and garp) are not included in any of the installer media (whereas it's available in the -generic kernels). Having them included in the init ramdisk so that network installation can use vlan is also useful.

Mathias Gug (mathiaz) on 2010-03-02
summary: - Include 8021q module in the installer for VLAN support
+ [FFE] Include 8021q module in the installer for VLAN support
Mathias Gug (mathiaz) wrote :

Patch sent to <email address hidden>:

From 03b60d00498baa8ee3a25562493d0b10fcaea85b Mon Sep 17 00:00:00 2001
From: Mathias Gug <email address hidden>
Date: Tue, 2 Mar 2010 15:31:41 -0500
Subject: [PATCH] Add vlan (8021.Q) module package for d-i.

The 8021q kernel module (and its dependencies slp and garp) are not
included in any of the installer medias. Adding them would enable vlan
tagging to be used during installation.

Signed-off-by: Mathias Gug <email address hidden>
---
 debian.master/d-i/modules/vlan-modules | 3 +++
 debian.master/d-i/package-list | 6 ++++++
 2 files changed, 9 insertions(+), 0 deletions(-)
 create mode 100644 debian.master/d-i/modules/vlan-modules

diff --git a/debian.master/d-i/modules/vlan-modules b/debian.master/d-i/modules/vlan-modules
new file mode 100644
index 0000000..3d65a55
--- /dev/null
+++ b/debian.master/d-i/modules/vlan-modules
@@ -0,0 +1,3 @@
+slp ?
+garp ?
+8021q ?
diff --git a/debian.master/d-i/package-list b/debian.master/d-i/package-list
index ecc2094..042ce87 100644
--- a/debian.master/d-i/package-list
+++ b/debian.master/d-i/package-list
@@ -182,3 +182,9 @@ Priority: extra
 Description: squashfs modules
  This package contains squashfs modules.

+Package: vlan-modules
+Depends: kernel-image
+Priority: extra
+Description: vlan modules
+ This package contains vlan (8021.Q) modules.
+
--
1.7.0

Changed in linux (Ubuntu):
status: New → In Progress
importance: Undecided → Wishlist
Mathias Gug (mathiaz) on 2010-03-02
Changed in linux (Ubuntu):
assignee: nobody → Mathias Gug (mathiaz)
Mathias Gug (mathiaz) on 2010-03-03
Changed in linux (Ubuntu):
assignee: Mathias Gug (mathiaz) → nobody
Mathias Gug (mathiaz) wrote :
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
tags: added: kernel-series-unknown
Colin Watson (cjwatson) wrote :

Given that the kernel module's already been added and that this is an optional menu item in d-i (not to mention that it's already been made available in non-netboot installations), I don't think the rest of this really needs an FFE; if it goes wrong then we just ignore it! I've committed the addition to netboot images.

Changed in debian-installer (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: New → Fix Committed
Colin Watson (cjwatson) wrote :

The vlan-modules udeb was added in linux 2.6.32-16.23. Closing the linux task.

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20081029ubuntu92

---------------
debian-installer (20081029ubuntu92) lucid; urgency=low

  [ Colin Watson ]
  * Add vlan-udeb to netboot images (LP: #530459).

  [ Oliver Grawert ]
  * add support for armel+omap architecture
 -- Oliver Grawert <email address hidden> Sat, 27 Mar 2010 09:37:24 +0100

Changed in debian-installer (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers