Manual partitioning with LVM crashes (karmic,lucid)

Bug #503848 reported by Narcis Garcia on 2010-01-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Charlie Kravetz

Bug Description

Binary package hint: debian-installer

I've tried an alternate installation of Xubuntu GNU/Linux 9.10 and server installation of Ubuntu 10.04 (now in development) to make a RAID0 with 2 hard disks, and in both cases the partition step fails:

(tested in different computers)

1. Boot with the text-mode installation
2. Select language, keyboard and time zone
3. In the partition step, make new partition table for each hard drive
4. Make a 128M primary partition for /boot in the first HD, and an unused 128M space in second HD
5. Assigned the rest of space to a phisical volume for RAID
6. Configured a RAID0 with both volumes
7. Configured a LVM group with the entire RAID space:
    10G volume for root
    2G volume for swap
    rest of space for data

On this point, when I select a volume to specify the filesystem and mount point, the program crashes and restarts the partition tool, but this partition tool doesn't complete its "Starting up the partitioner" and seems to freeze.

Narcis Garcia (narcisgarcia) wrote :

Note: with the same procedure the partitiones doesn't crash in these Ubuntu versions: 8.04 (Hardy), 8.10 (Intrepid), 9.04 (Jaunty), and complete installation is successful with RAID, LVM and/or encryption.

Narcis Garcia (narcisgarcia) wrote :

Ooops!
I've tried again these steps with Ubuntu 9.04 server, selecting ext4 filesystems, and stalls in the same way.
Now I've tried the same steps with Ubuntu 10.04 server (developing version of 2010.01.01), selecting ext3 format for silesystems, and the process continues without this problem.

Then I see that the bug can be reproduced when the ext4 format is selected.

Narcis Garcia (narcisgarcia) wrote :

I moved the focus of this bug to this more exact other:
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/512002

Narcis Garcia (narcisgarcia) wrote :

I think the package affected is partman-ext3 ("Add to partman support for ext3 and ext4").
I can select ext3 format for normal partitions (it's a solution for traditional installations), but is not possible to make a manual partitioning, create an encrypted volume (because of a multisystem hard disk), and when configuring that encrypted volume change its default ext4 format.

Steps to reproduce:
1. Make a boot CD with ubuntu-9.10-alternate-i386.iso
2. Boot, select language and "install option", keyboard and time zone
3. Give a name for the system
4. Choose the "manual" partitioning method
5. In the unpartitioned space, create a primary partition and mark it to use as "physical volume for encryption"
6. Select the "Configure encrypted volumes" option, then choose the new partition, accept defaults, and write the password as required
7. Select the new appeared encrypted volume on top of the list.
8. You see that is selected to have an ext4 format by default; when you select this item to change, partman crashes and tries to restart with a "Starting up the partitioner" message that never completes, and you never return to partitioner/installer in this session (reboot needed, without solution).

Seeing that the Desktop installer doesn't give option to make manual partitioning with encryption, and the Debian Installer selects ext4 filesystem by default in manual partitioning (and crashes if you want to change the use):
KARMIC DOESN'T SEEM TO BE POSSIBLE TO BE INSTALLED ON AN ENCRYPTED VOLUME WITHOUT DELETING ALL THE DISK.

Narcis Garcia (narcisgarcia) wrote :

I've found the problem with LVM and Encryption because I've tried the alternate installation with these configurations.
The problem I've found (in 3 different computers) can be reproduced with:
- Xubuntu 9.10 alternate-CD i386
- Ubuntu 9.10 alternate-CD i386
- Ubuntu 10.04 (in development) Server i386

All other installations I've made (a lot), were successful with ext4 using the Desktop CD installer.

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for your efforts to pin this down. That does help the developers to resolve the issue.

Changed in debian-installer (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
tags: added: karmic lucid
Narcis Garcia (narcisgarcia) wrote :

In the meantime, can anybody answer this qüestion?:

How to avoid ext4 by default when installing?
http://ubuntuforums.org/showthread.php?p=8742907
(How can I do to avoid that in the alternate installation partitioner doesn't appear "ext4" filesystem as the default selection in any step)

Narcis Garcia (narcisgarcia) wrote :

Ooops!
This bug happens when working in "catalan" language, but it doesn't seem to happen when working in "spanish" language for installation. I've only experienced this in 1 installation.

Narcis Garcia (narcisgarcia) wrote :

The catalan language match may be for a different memory using.
Today I've reproduced the issue with Lubuntu 14.04 in a system with only 176MiB of RAM memory, but all works fine once grown the RAM to 256MiB.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers