can't set bootable flag when partitioning during install

Bug #477167 reported by Huuanito on 2009-11-07
This bug affects 16 people
Affects Status Importance Assigned to Milestone
debian-installer (Debian)
debian-installer (Ubuntu)

Bug Description

Binary package hint: ubiquity

server 9.10 64bit install on intel motherboard with 2 SATA drives with BIOS raid config set off

during install at partition stage cannot set bootable flag to 'on'
following instructions for setting up software RAID 1 from here:
steps to reproduce:
at partition stage: manual partition
2.Select 1st hard drive, and agree to "Create a new empty partition table on this device ?"
3. Repeat step 2 with 2nd hard drive
4. Select the "FREE SPACE" on the 1st drive then select "Create a new partition"
5. set partition size ( I used 100 MB intended for /boot but other sizes also fail)
6. Select 'beginning' (Primary is not available with this install software)
7. Select "physical volume for RAID" for Use as
8. Select 'bootable flag' and press enter

Expected behavior: 'bootable flag' changes to 'on'
Actual behavior: 'bootable flag' stays at 'off'

web search uncovered a similar problem on 9.04 server 64bit but there was no solution, only a workaround of installing on one hard drive then migrating to RAID 1 after install.

Colin Watson (cjwatson) on 2009-12-02
affects: ubiquity (Ubuntu) → debian-installer (Ubuntu)
Szabó Gergely (szger) on 2011-01-25
Changed in debian-installer (Ubuntu):
status: New → Confirmed
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Hieu Van Mach (van-hieu83) wrote :

status:New -> Confirmed
The Ubuntu server 11.10 64 bit having the same problem and it can install grub on any device so it does not boot.The pc with amd motherboard 2 SATA 2TB. I notice on the link above

Important initial facts

Before starting, be aware of the different metadata formats available. The default (at least on Lucid) is 0.90, which allows compatibility with most grub versions, but won't accept > 28 drives, nor drives >2TB.

I guess something wrong with the disk size because it is 2TB.

Please help.

Vadim Mikhalets (sneak007v) wrote :

I noticed, that if you select "ms-dos" partition table type - it works, but if you select "gpt" — you cant change bootable flag.

Changed in debian-installer (Debian):
status: New → Confirmed
Hieu Van Mach (van-hieu83) wrote :

Hi Vadim,

   Can you explain me more about "ms-dos" partition table type?And where is the step of choosing this?I do not see any where of selecting this option when installing Ubuntu server 11.10.


Alexander Adam (7ql6) wrote :

I used the Ubuntu server image and have the same problem now.
With manual partition mode, then choosing the recomended partition scheme and selecting root (ext4) & swap as raid 1, I end up with partitions without boot flag.
Manually setting the boot flag via "GUI" is not possible.

After trying to set the boot flag will show the process bar shortly and then the partititon setting dialogue again, with the old setting (non bootable) again. There is no error message or something. It just donesn't work and it is not t

Alexander Adam (7ql6) wrote :

It just doesn't work and it is not described what happened.
(sorry, somehow I sent the message already) :/

Chris Malton (chrism-u) wrote :

Just ran into this on an HP DL320e G8 v2 server in 12.04.03 - anyone know if it's been fixed since?

Bachi (m-bachmann) wrote :

Same here (HP Proliant Microserver, 2x 4TB WD red HDs)

dbclinton (dbclin) wrote :

This one hit me while installing on an ASUS P8Z77-V LK LGA 1155 mother board and an Intel i5-3470 Ivy Bridge CPU with 16GB RAM. But it doesn't stike me as having much too do with that part of the profile: I'm trying to install it to two 3TB HGST Deskstar NAS drives.

wmsxx (wmsxx) wrote :

I don't know if this is still a Problem. I run into this Problem recently. The principles described here

helped me. In particular the Information to install a 1 MB biosgrub Partition. This will be automatically detected.

Also here is some useful Information

James Park-Watt (jimmypw) wrote :

Just had this problem. It occours when the disk partition table is set to GUID. Reset to MSDOS instead and it worked as expected.

Still occurring using 14.04 mini x64 iso. Disks are partitioned with gpt - which is apparently default if you select a disk and "Create a new empty partition table on this device."

Works fine after re-partitioning as msdos.

Maximilien Levesque (maxlev) wrote :

Still occurring using 16.04.

Pontus Ohman (gh0st) wrote :

Any chance we can see a fix for this soon?! Because I´m using a 6TB disk and need to manual partion this due to a GRUB bug on large disks. :/

Alexander Adam (7ql6) wrote :

Wow, I ran into the same issue now just to realize that commented here in 2013 complaining about this.

Installation of 16.04.02 is still failling in the grub-installation step and it took a while until I found this issue here (again).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers