installer could check for newer releases.

Bug #397381 reported by rew on 2009-07-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: base-installer

Wishlist item.

The installer could verify internet connectivity, and if available, check with the ubuntu distribution server whether a newer release than that of the current CD is available. If that is the case, installing the newer version might be offered in a menu.

I'm thinking the installer has pretty much stabilized, so an intrepid installer could just as well download and install jaunty. (I've noticed a difference in the exact way a timezone is selected, but that's just

Of course some thought needs to be given to compatibility. First the newer installation could provide a special package called for example "install-from-intrepid-cd", that provides some way to allow the newer installation to provide some code/ compatibility scripts for the older distribution.

Similarly, something in the newer distribution (maybe the absence of such a compatibility package) should be able to inhibit such a cross-version install, if this is known not to work.

The compatibility package should install on the running installing system (running off CD/ramdisk), and it's post-install script could check whether an abort is necessary or maybe provide a menu to let the user chose. It could also "hijack" the install process, and make all necessary arrangements to install the newer version....

Colin Watson (cjwatson) wrote :

This is quite unlikely to happen, I think - it's just too likely to require time travel. There are a *lot* of cases where changes in the distribution require corresponding changes in the installer, even if they aren't user-visible. I think it would basically never be possible in reality.

I'll keep it open as a wishlist entry anyway in case we ever want to attempt this ...

(I don't think this makes sense at all in the desktop installer, which is by design not flexible enough to install from a network archive as opposed to from the live filesystem it has handy on the CD.)

affects: base-installer (Ubuntu) → debian-installer (Ubuntu)
Changed in debian-installer (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers