installer: dm-crypt support missing

Bug #39326 reported by Sascha Silbe on 2006-04-12
30
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Wishlist
Unassigned

Bug Description

It would be great if dm-crypt volumes could already be created during installation, so /var etc. can be encrypted (without having to copy over the files in single-user mode).

Colin Watson (cjwatson) wrote :

This feature is being worked on upstream; I expect we'll get it in Dapper+1.

Changed in debian-installer:
status: Unconfirmed → Confirmed
Martijn Vermaat (mvermaat) wrote :

The d-i in Etch now has dm-crypt support for some time (don't know for how long exactly), but last time I checked the d-i in Edgy did not. I guess the last sync with upstream was before they added it.

Can this functionality somehow be enabled on the Edgy alternate installer CD or is it really something for Edgy+1?

Colin, do you know if this will be featured on Edgy at all? Edgy is out and I don't see it on there.. Will it be Edgy+1? Before you said it would be in Dapper+1 but I still don't see anything.. Sorry to bother you but I'm very excited about this feature for my laptop..

Colin Watson (cjwatson) wrote :

Yeah, it didn't happen because cryptsetup, upstart, and usplash weren't friends. There's a plan (https://blueprints.launchpad.net/ubuntu/+spec/dm-crypt) for getting this done at last.

webjames (james-olney) wrote :

Well dm-crypt is still missing from the installer in Feisty, and seems to be missing in Gutsy i can see not plans to include it in the upcoming Gutsy. Perhaps if we make the need for encryption better known?

Yes please. This is something that needs to be included by default for
laptop users in particular. Do you believe this isn't happening because of
politics or lack of interest?

On 8/3/07, webjames <email address hidden> wrote:
>
> Well dm-crypt is still missing from the installer in Feisty, and seems
> to be missing in Gutsy i can see not plans to include it in the upcoming
> Gutsy. Perhaps if we make the need for encryption better known?
>
> --
> installer: dm-crypt support missing
> https://bugs.launchpad.net/bugs/39326
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Charles Sullivan
<email address hidden>

webjames (james-olney) wrote :

i don't believe it is because of lack of interest; more that people just haven't started anything yet. debian has the feature of encryption on the installer, and it works very well. i have followed this howto: (https://help.ubuntu.com/community/FeistyEncryptedRootWithInstaller) and now have encryption on my laptop, it can't be that difficult to implement, i guess we just need to stir up some interest and attention.
perhaps someone could alert the mailing list?

feistytester9 (fdewes) wrote :

it seems that installation on encrypted devices is now included by default.
the alternate install cd for gutsy beta can create encrypted devices.

webjames (james-olney) wrote :

Brilliant, i shall have a look at once!

On 28/09/2007, feistytester9 <email address hidden> wrote:
> it seems that installation on encrypted devices is now included by default.
> the alternate install cd for gutsy beta can create encrypted devices.
>
> --
> installer: dm-crypt support missing
> https://bugs.launchpad.net/bugs/39326
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Tel: 00447809457487
Email: <email address hidden>
www: http://www.happyjames.co.uk

Thanks to whoever made this happen.. I'll test once Gutsy is out of beta.

On 9/28/07, webjames <email address hidden> wrote:
>
> Brilliant, i shall have a look at once!
>
> On 28/09/2007, feistytester9 <email address hidden> wrote:
> > it seems that installation on encrypted devices is now included by
> default.
> > the alternate install cd for gutsy beta can create encrypted devices.
> >
> > --
> > installer: dm-crypt support missing
> > https://bugs.launchpad.net/bugs/39326
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
>
> --
> Tel: 00447809457487
> Email: <email address hidden>
> www: http://www.happyjames.co.uk
>
> --
> installer: dm-crypt support missing
> https://bugs.launchpad.net/bugs/39326
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Charles Sullivan
<email address hidden>

webjames (james-olney) wrote :

Well had a look, works fine. Use the alternative CD and select manual
partitioning i had one normal /boot then the the rest as type
encrypted, the rest is obvious, works well!

thank you!

On 03/10/2007, Charles Sullivan <email address hidden> wrote:
> Thanks to whoever made this happen.. I'll test once Gutsy is out of
> beta.
>
> On 9/28/07, webjames <email address hidden> wrote:
> >
> > Brilliant, i shall have a look at once!
> >
> > On 28/09/2007, feistytester9 <email address hidden> wrote:
> > > it seems that installation on encrypted devices is now included by
> > default.
> > > the alternate install cd for gutsy beta can create encrypted devices.
> > >
> > > --
> > > installer: dm-crypt support missing
> > > https://bugs.launchpad.net/bugs/39326
> > > You received this bug notification because you are a direct subscriber
> > > of the bug.
> > >
> >
> >
> > --
> > Tel: 00447809457487
> > Email: <email address hidden>
> > www: http://www.happyjames.co.uk
> >
> > --
> > installer: dm-crypt support missing
> > https://bugs.launchpad.net/bugs/39326
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
>
> --
> Charles Sullivan
> <email address hidden>
>
> --
> installer: dm-crypt support missing
> https://bugs.launchpad.net/bugs/39326
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Tel: 00447809457487
Email: <email address hidden>
www: http://www.happyjames.co.uk

Colin Watson (cjwatson) wrote :

As noted, this feature is now in Gutsy (alternate CD only for the moment).

Changed in debian-installer:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers