Karmic Beta: disk partitions not shown in installer.

Bug #365944 reported by Alessio on 2009-04-24
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: debian-installer

I tried to install Ubuntu 9.04 from Alternate and desktop CD but both don't see disk partition. In my disk i have two partition, one with XP and the other with Ubuntu 8.10. I wanted to install in the partition of ubuntu but looks like there is no partition and no other O.S. in my disk so it tells me to install in the entire Hard Disk. Something that obviously i don't want to do. What can i do?

dracflamloc (drac-dracsoft) wrote :

I have this same problem. I have Vista, XP, and a previous linux install. The partition editor shows *no* partition table on the HD (SATA)

Alessio (alessioballarin) wrote :

I just write down some hypothesis, I have restore a corrupted grub before this new installation of ubuntu. It's the only thing comes in my head now but I don't know if can be the reason.

Alessio (alessioballarin) wrote :

I forgot, I restore with "GRUB DISK"

fchambers (frank-fchambers) wrote :

System hardware
4 GB memory
2 160 GB hard drives
4GB memory

Software - Windows XP Pro installed

Tried to install 9.04 64 bit and have the same problem as above it doesn't see anything on the sda1 drive, only sdb. I tried the FAT32 partition workaround reported on Launchpad but it didn't work.

PruNe (batmat) wrote :

Hello,

I had the same problem on my laptop :
Partition 1 : Windows XP
Partition 2/3/4 : Ubuntu 8.xx

The installer didn't find any partition at all.

Using Ubuntu as a live CD and fdisk tool, i've seen that the partition table was incorrect:
- Too many cylinder count
- Partition overlap

To correct this i simply had to delete the linux partition using fdisk and write the new partition table on the disk.
Then after reboot, the installer was able to see the partitions correctly.

For me it looks like this is not a bug... maybe the installer could report the problems seen with fdisk to prevent any misunderstanding of the situation.
---
Mathieu

I can confirm this bug with the installer of Karmic Koala Beta, 64 bit, alternate cd.

These are my partition tables, they seem to be perfectly OK:
root@hardy64:~# fdisk -l /dev/sd?

Disk /dev/sda: 1500.3 GB, 1500301910016 bytes
255 heads, 63 sectors/track, 182401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x421eef0c

   Device Boot Start End Blocks Id System
/dev/sda1 2 263 2104515 83 Linux
/dev/sda2 * 264 5485 41945715 7 HPFS/NTFS
/dev/sda3 5486 182401 1421077770 5 Extended
/dev/sda5 5486 31593 209712447 da Non-FS data
/dev/sda6 31594 57701 209712478+ da Non-FS data
/dev/sda7 57702 121421 511830868+ 83 Linux
/dev/sda8 121422 182255 488649105 a7 NeXTSTEP

Disk /dev/sdb: 80.0 GB, 80026361856 bytes
192 heads, 48 sectors/track, 16959 cylinders
Units = cylinders of 9216 * 512 = 4718592 bytes
Disk identifier: 0x5d352b02

   Device Boot Start End Blocks Id System
/dev/sdb1 2 16959 78142464 83 Linux

Disk /dev/sdc: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xdb07f483

   Device Boot Start End Blocks Id System
/dev/sdc1 1 60801 488384001 a7 NeXTSTEP

====================

But the partitions on /dev/sda are not shown in the installer. If I press ENTER on sda, the installer wants to create a new partition table. Photo attached.

I'm going to change the title of this bug, since it won't get fixed for older version of Ubuntu anyway and it's relevant to the upcoming release.

summary: - Ubuntu 9.04 don't see disk partition during installation.
+ Karmic Beta: disk partitions not shown in installer.

Since I will change my partition table now for further experimenting I attach the raw partition table as given by fdisk for reference.

affects: debian-installer (Ubuntu) → partman-partitioning (Ubuntu)
Colin Watson (cjwatson) wrote :

Alessio, could you please attach /var/log/syslog and /var/log/partman from an installation attempt?

Anyone else, I'd ask that you please file a *new* bug and attach that information. This symptom basically just means that parted failed to understand your partition table, and there's more than one way that could happen; lumping it all together into one bug actually winds up not being all that helpful.

affects: partman-partitioning (Ubuntu) → debian-installer (Ubuntu)
Changed in debian-installer (Ubuntu):
status: New → Incomplete

Sorry for not opening a new bug. I will do so next time. It's just too hard to recognize what belongs together (same cause) or just looks the same (same symptoms). Please understand: I'm supposed to search for existing bugs (and add to those) to not produce unnecessary duplicates and on the other hand I'm supposed not to mix things together that don't belong together. That's much easier for you, that you have more insight. Also Alessio reported this half a year ago, so I expected that nothing will happen with this bug anymore anyway if noone adds new information.

Back ontopic: At least for my case i found the root-cause: Some time ago I used "fix partition ordering" of fdisk and there are known incompatibilites between that function and parted. See for example http://www.google.at/search?hl=de&q="Error%3A+Unable+to+satisfy+all+constraints+on+the+partition."+fdisk+fix+order . Of course I didn't know that partman is using parted or libparted until a few hours ago. I don't know if fdisk or parted is to blame now, but it's one of those two. One solution/workaround (the only that I've found) is in the last post here: http://parted.alioth.debian.org/cgi-bin/trac.cgi/ticket/201 . But be very careful with that: In the process of fixing this problem I lost one of my partitions due to overwriting the LUKS-header with a partition table.

I don't know if I was supposed to put that comment already into another, new bug? But I think it's not too bad here, because if I put it into something like "fdisk/parted-incompatibility" noone would find it, if he encounters the same symptoms that i did.

Searching for duplicates is great when you're reporting a bug that's
easily comprehensible, like "this icon is blue and should be grey" or
"Thunderbird doesn't have Mail-Followup-To support" or whatever. For
crashes, installation failures, and other such things where you simply
cannot tell without detailed reference to the code whether your bug is
the same as somebody else's, I strongly recommend against wasting your
time searching for duplicates, as it just does more harm than good.

For your case, I would ask that you please file a new bug so that we can
track and investigate it independently. It's much less important whether
other users can find it, since, as described above, they won't be able
to tell accurately whether they are suffering from the same problem
anyway. :-) The bug tracking system is meant for tracking changes that
need to be made to software by developers, not to act as a repository of
workarounds for users.

Maxei (maxei-95) wrote :

I wanted to install ubuntu 9.10-beta karmik and at the moment of partition, I could not do things the way I want. The partition tool did not allow me to set different partitions for /home, different to that from root "/". I must say that, comparing to the installer for Ubuntu 8.10 intrepid ibex, the installer for karmik beta 9.10 really sucks like a begginer. This is an incredible regression. What is going on? walking backwards like a fuckin' crab? Oh well. I will not install karmik this time. I lost my time, I lost a cd.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.