[intrepid alpha 4] /target/lib/modules/ ist empty on alternate install cd

Bug #258425 reported by Oleksij Rempel on 2008-08-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned

Bug Description

This issue have a lot of "if". If you use manual partitioning and use lvm, then instalation will brake on generating initram.img becouse initramfs-tools missing /target/lib/modules/linux-generk... Simple workaround is to copy modules from /lib/modules/linux... to /target/lib/modules/ . This issue is repiedeble.

Here is my partition table:
----------------------------------------------------------------
sudo fdisk -l /dev/sda

Platte /dev/sda: 80.0 GByte, 80026361856 Byte
255 Köpfe, 63 Sektoren/Spuren, 9729 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Disk identifier: 0xd538d538

   Gerät boot. Anfang Ende Blöcke Id System
/dev/sda1 * 1 9698 77899153+ 8e Linux LVM
/dev/sda2 9699 9729 249007+ 5 Erweiterte
/dev/sda5 9699 9729 248976 83 Linux
--------------------------------------------------------------------------
sudo vgs
  VG #PV #LV #SN Attr VSize VFree
  zwerg 1 3 0 wz--n- 74,29G 6,22G
----------------------------------------------------------------------
sudo lvs
  LV VG Attr LSize Origin Snap% Move Log Copy%
  home zwerg -wi-ao 55,00G
  root zwerg -wi-ao 10,00G
  swap_1 zwerg -wi-ao 3,07G
===================================

this problem do not accure if i use automaticly generated lvm table.

Oleksij Rempel (olerem) wrote :

i tested newest alternate-install-cd and didn't get to reproduce this issue. may be it's fixed.

Changed in debian-installer:
status: New → Fix Committed
Colin Watson (cjwatson) wrote :

Closing per the reporter's comments. We didn't do anything explicitly to fix this; chances are that this was a transient problem during Intrepid development, perhaps due to the kernel ABI (and hence package names) changing.

Changed in debian-installer:
status: Fix Committed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers