default fstab cdrom line does not support vfat file system

Bug #232184 reported by David Balažic on 2008-05-20
4
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Low
Unassigned

Bug Description

fresh install of ubuntu 8.04 desktop i386 CD

Upon inserting a FAT formatted DVD-RAM an error dialog appears:

Cannot mount volume
Invalid mount option when attempting to mount the volume 'DDDD'.

nothing related in /var/log

DDDD is the volume label
fs: FAT32

mount /dev/cdrw /mnt # works just fine

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

David Balažic (xerces8) wrote :

1.) I said that the command line mount works just fine, so the kernel (the old kernel) can handle it just fine.

2.) I know you are all busy, but a DVD-RAM costs a few dollars and it takes 10 seconds to format it. So you could get all the info you asked... from yourself.

3.) If I find the DVD and a Ubuntu installation on one of my PCs, I will report the results.

Hi David,

We had sent out an automated call for testing, which is why you received the above request for testing 2.6.27. From reviewing your previous comments, it seems this isn't an issue with the kernel. Can you comment which application is giving you the error message:

Cannot mount volume
Invalid mount option when attempting to mount the volume 'DDDD'.

The reason I ask is that this bug report should be reassigned to the appropriate package a not be against the 'linux' kernel package. Thanks.

Changed in linux:
status: New → Incomplete
David Balažic (xerces8) wrote :

What does the automatic mounting of optical media ?
If not else, it could be assigned to nautilus.
(although I doubt it is the correct package; maybe at least the nautilus guys know where to pass it on...)

Sebastien Bacher (seb128) wrote :

does "gnome-mount -v -b -d /dev/<device>" work correctly?

Changed in nautilus:
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

Closing this bug report as no further information has been provided. Please feel free to reopen this bug if you can provide the information asked for. Thanks!.

Changed in nautilus:
status: Incomplete → Invalid
David Balažic (xerces8) wrote :

NOTE: I reinstalled from the 8.04.01 x86 desktop CD

> does "gnome-mount -v -b -d /dev/<device>" work correctly?

No, it gives the same error dialog and this in the terminal :

stein@fanix:~$ gnome-mount -v -b -d /dev/scd0
gnome-mount 0.8
** (gnome-mount:5966): DEBUG: Mounting /org/freedesktop/Hal/devices/volume_uuid_10B8_EBCC
Device /dev/scd0 is in /etc/fstab with mount point "/media/cdrom0"
** Message: /bin/mount said error 8192, stdout='', stderr='mount: wrong fs type, bad option, bad superblock on /dev/scd0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so

'

Again, "mount /dev/scd0 /mnt" works fine.

Changed in nautilus:
status: Invalid → New
Sebastien Bacher (seb128) wrote :

not a nautilus bug since gnome-mount doesn't mount it either

David Balažic (xerces8) wrote :

If I add ",vfat" into fstab, then it suddenly starts to "JustWork(tm)".

Hopefully this is enough information to finally fix this.

Martin Pitt (pitti) wrote :

The problem is that our installer creates an fstab with a /cdrom line which has "udf,iso9660" file systems. That will not even try vfat.

Can you please test whether "udf,iso9660,auto" works, perhaps?

Eventually it's just the same old story that on desktops, fstab shouldn't have an entry for CD-ROMs in the first place, but it's still sort of required for servers.

Changed in gnome-mount:
status: New → Triaged
Artur Chmarzyński (szamot83) wrote :

No it not work after add "auto"
line looks like this after doing it:
/dev/scd0 /media/cdrom0 udf,iso9660,auto user,noauto,exec,utf8 0 0
When I try to mount system gives me this error:
mount: unknown filesystem type 'auto'.

I don't know why but since last update (ubuntu 8.04) I can not mount any dvd-video. Errors are same as in David post. Has anyone found solution?

David Balažic (xerces8) wrote :

Ubuntu 9.04 x64

It seems to work now.

I inserted the DVD and it is mounted properly, no errors.

Only the icon is funny, see screenshot.

Hi there all,

I have Ubuntu 10.04 LTS - Lucid Lynx, but since the previous version I have not being able to mount the cdrom/dvd, actually I had given up but now I decided to come back and try to find a solution for this, it's ridiculous I have a very nice computer with a very nice OS but I cannot use a CD/DVD.

So, could anybody tell me something about what could I do to solve this annoying issue?

This is my current fstab:
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda1 during installation
UUID=bb679f37-4a3c-4cf8-89b1-244a43913868 / ext3 relatime,errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=71300f7d-9151-4083-8057-1d9d395e69ff none swap sw 0 0
# /dev/sr0 /media/cdrom0 udf,iso9660 user,auto,exec,utf8 0 0
# /dev/sr0 /media/cdrom0 auto noatuo,user,ro,exec 0 0
# /dev/sr1 /media/cdrom0 udf,iso9660 user,auto,exec,utf8 0 0

# <file system> <mount point> <type> <options> <dump> <pass>
/dev/cdrom /media/cdrom0 iso9660 defaults,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

# this is to active the iPod
#/dev/sdb1 /mnt/ipod vfat noauto,user 0 0

Appreciate anything at all.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers