Ubuntu

Grub fails to install in Ubuntu Studio 8.04 beta installation

Reported by digitalpulse on 2008-04-14
12
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Athlon XP 1500 1.5GB ram 3 HDD. 1st HDD 2 partions 1=xp 2=ubuntu studio.

I have installed xp, wanted to setup dual boot. 2nd partion was destination for ubuntu studio 8.04 beta.

installer working fine until grub section. grub failed to load then I only had the choice to try lilo. this installed but apon reboot the MBR must have been messed or overwritten by LILO. system now only boots into ubuntu studio without splash screen whilst kernal loads. ubuntu working fine but I can't correct nor install grub.

The problem is GRUB failing to install at initial installation.

Also xp boot CD will not boot yet bios settings fine.

Thanks

Jay Finger (jcfinger) wrote :

I started noticing this same problem about a week ago. The installer seems to be downloading some stuff from the repos which apparently isn't working with the older stuff on the install CD. I had this problem with both the desktop and alternate CDs.

Running the installer without an internet connection will fix the problem. You get a working Hardy Beta system. Once running, the update manager can get all the fresh bits.

I think the real problem here is that the installer can download some packages that aren't compatible with the install process. I don't know if the solution for that is just increased testing by the package maintainers to make sure this doesn't happen, or if the installer should be changed to not try and download any updates.

Jay Finger (jcfinger) wrote :

By the way, this is a pretty commonly reported problem over on the "Development (Hardy Heron)" forum right now. http://ubuntuforums.org/forumdisplay.php?f=305

Colin Watson (cjwatson) wrote :

This doesn't happen with current daily builds. The change was necessary - I'm afraid there's nothing we can do about it other than ask people to use current daily builds. (The release candidate will be out tomorrow, so I'm not going to stress about keeping the beta working.)

Changed in debian-installer:
status: New → Fix Released
digitalpulse (alexander-noakes) wrote :

OK I do have my network cable in and have not tried with it romoved. I will also try the latest daily build. What is the most recent edition of Ubuntu Studio .I did not want to go the path of messing with the windows boot manager I wanted this to be all handled by linux. By the way Thanks so much for the prompt reply and advice. I think this what is actually meant by open source and support. Regards.

Colin Watson (cjwatson) wrote :

Current daily builds are at http://cdimage.ubuntu.com/ubuntustudio/daily/current/ - in general daily builds aren't reliable, but since we're coming up to release they should be pretty good in practice right now.

vgmarkovic (vgmarkovic) wrote :

gracias

Changed in debian-installer (Ubuntu):
status: Fix Released → New

On Wed, Jun 17, 2009 at 08:01:33PM -0000, vgmarkovic wrote:
> gracias
>
> ** Changed in: debian-installer (Ubuntu)
> Status: Fix Released => New

Can you explain why you reopened this bug, please? Otherwise I'll close
it again.

Thomas Hotz (thotz) on 2012-11-16
Changed in debian-installer (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers