Ubuntu 16.04 amd64 netboot install fails with segfault

Bug #1816876 reported by planetbeing on 2019-02-20
96
This bug affects 20 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned

Bug Description

It fails at around this stage:

Feb 20 16:55:10 dev env[6826]: {"facility":7,"severity":1,"tag":"anna[8535]","time":"2019-02-20T05:00:00.000Z","hostname":"21:55:10","address":"10.10.128.247","family":"IPv4","port":39315,"size":76,"msg":"DEBUG: retrieving libc6-udeb 2.23-0ubuntu11\n"}
Feb 20 16:55:10 dev env[6826]: {"facility":6,"severity":1,"tag":"anna[8535]","time":"2019-02-20T05:00:00.000Z","hostname":"21:55:10","address":"10.10.128.247","family":"IPv4","port":39315,"size":227,"msg":"2019-02-20 21:55:10 URL:http://us.archive.ubuntu.com/ubuntu/pool/main/g/glibc/libc6-udeb_2.23-0ubuntu11_amd64.udeb [1241450/1241450] -> \"/var/cache/anna/libc6-udeb_2.23-0ubuntu11_amd64.udeb\" [1]\n"}
Feb 20 16:55:10 dev env[6826]: {"facility":6,"severity":1,"tag":"kernel","time":"2019-02-20T05:00:00.000Z","hostname":"21:55:10","address":"10.10.128.247","family":"IPv4","port":39315,"size":153,"msg":"[ 59.710602] sh[8624]: segfault at 18 ip 00007f81bee488df sp 00007ffe26360300 error 4 in libc-2.23.so[7f81bee28000+1c0000]\n"}
Feb 20 16:55:10 dev env[6826]: {"facility":6,"severity":1,"tag":"kernel","time":"2019-02-20T05:00:00.000Z","hostname":"21:55:10","address":"10.10.128.247","family":"IPv4","port":39315,"size":153,"msg":"[ 59.711516] sh[8625]: segfault at 18 ip 00007f9a571818df sp 00007ffe28a8c690 error 4 in libc-2.23.so[7f9a57161000+1c0000]\n"}

On screen, I see that "Loading libc6-udeb failed for unknown reasons".

This has previously worked fine before a few weeks ago.

Danny Webb (dannyswebb) wrote :

I'm also hitting this bug with the netinstall.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Vili Kosednar (safesize) wrote :

I can confirm this. Our production relies on this therefore this is very urgent.

Netinstall loads the components, then tries to detect the disk and then crashes.

This worked perfectly well yesterday afternoon.

Is there any workaround?

Nanowish (nanowish) wrote :

This bug affect unattended installation too since yesterday afternoon. Any updates ?

Mr Robot (meltedrobot) wrote :

This started affecting us yesterday as well.

Saffi (rsaffi) wrote :

Also getting the same problem. It was working last Thursday (14.02.2019) and now it's crashing with the same error.

Andrew Grasso (andrew-grasso) wrote :

This appears to be fixed in the latest netboot installer published today (2019-02-21 13:49 UTC).

http://archive.ubuntu.com/ubuntu/dists/xenial-updates/main/installer-amd64/current/images/netboot/

Our tests on installers before that were seeing the segfaults, but everything seems to be working again using the latest installer.

Saffi (rsaffi) wrote :

Confirming that the updated netboot installer works. Thanks for the prompt reply, Andrew!!

Colin Leroy-Mira (colin-colino) wrote :

Is that the shortest-lived bug ever ? ;) Confirming it and confirming the fix too.

Jesse Rhoads (jrhoads80) wrote :

No, this problem started for us _after_ the installer was updated.

Michael Gregg (mgregg7) wrote :

This bug is still confirmed and active.

Other bugs are coming in that are dupes of this:
https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1817358

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments