bionic amd64 netboot.tar.gz - bad permission on uncompressed file

Bug #1781036 reported by Decembry Quentin on 2018-07-10
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

I find that the permission on a file is not correct.

Unpacking the tarball http://be.archive.ubuntu.com/ubuntu/dists/bionic/main/installer-amd64/current/images/netboot/netboot.tar.gz to prepare my TFTP server, I found that the permission on the file .../ubuntu-installer/amd64/linux is 600 instead of 644.

This prevents the process to perform a PXE installation.

FYI:
TZ=utc ls -n ./netboot.tar.gz
-rw-r--r-- 1 xxx xxx 54820328 avr 25 21:23 ./netboot.tar.gz

sha256sum ./netboot.tar.gz
5fe1e599ed7266abb39364b21c07870866b37f655d603c3b2191394a3e85ff39 ./netboot.tar.gz

TZ=utc ls -n ./ubuntu-installer/amd64/linux
-rw------- 1 xxx xxx 8249080 avr 25 20:10 ./ubuntu-installer/amd64/linux

sha256sum ./linux
beeab595bb361fa38f9eadac4bedff6082c2f7f06cb97507103a4316a291c0f5 ./linux

affects: unetbootin → livenetboot
affects: livenetboot → debian-installer
Colin Watson (cjwatson) on 2018-07-11
affects: debian-installer → debian-installer (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu Bionic):
status: New → Confirmed
Changed in debian-installer (Ubuntu Xenial):
status: New → Confirmed
Changed in debian-installer (Ubuntu):
status: New → Confirmed
Adam Conrad (adconrad) on 2018-07-22
Changed in debian-installer (Ubuntu):
status: Confirmed → Fix Committed

Hello Decembry, or anyone else affected,

Accepted debian-installer into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debian-installer/20101020ubuntu543.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in debian-installer (Ubuntu Bionic):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-bionic
Adam Conrad (adconrad) wrote :

Verified that the kernels in the new tarballs are world-readable.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu543.1

---------------
debian-installer (20101020ubuntu543.1) bionic; urgency=medium

  * Move master kernels to 4.15.0-29 for the 18.04.1 release.
  * Rebuild against new systemd for SCSI sync (LP: #1779815)
  * Fix permissions on the netboot.tar kernel (LP: #1781036)

 -- Adam Conrad <email address hidden> Sun, 22 Jul 2018 03:19:55 -0600

Changed in debian-installer (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for debian-installer has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Łukasz Zemczak (sil2100) wrote :

Does this also affect xenial? I have checked the netboot tarball for xenial-updates and linux seems to be 644 as expected. Should we mark it as invalid?

Decembry Quentin (qedinux) wrote :

File permission is OK now and the PXE process can proceed normally.

Sorry for the long delay before my answer. I didn't know that I should look into the ubuntu-proposed repository.

Decembry Quentin (qedinux) wrote :

I don't think this bug is related to Xenial. I just rebuild my TFTP server for PXE installations and all kernel files (linux) are world readable. The netboot.tar.gz for Xenial were last modified on February 28 and I have never encountered such a problem with Xenial.

It should be marked invalid for Xenial.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu547

---------------
debian-installer (20101020ubuntu547) cosmic; urgency=medium

  [ Adam Conrad ]
  * Fix permissions on the netboot.tar kernel (LP: #1781036)

  [ Andy Whitcroft ]
  * Move master kernels to 4.15.0-29.

 -- Andy Whitcroft <email address hidden> Wed, 25 Jul 2018 21:02:46 +0100

Changed in debian-installer (Ubuntu):
status: Fix Committed → Fix Released

Hello Decembry, or anyone else affected,

Accepted debian-installer into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debian-installer/20101020ubuntu451.24 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in debian-installer (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-xenial
removed: verification-done
Adam Conrad (adconrad) wrote :

Hello Decembry, or anyone else affected,

Accepted debian-installer into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debian-installer/20101020ubuntu451.25 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Adam Conrad (adconrad) wrote :

Verified that the xenial hwe-netboot tarball has the correct permissions on vmlinuz.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu451.25

---------------
debian-installer (20101020ubuntu451.25) xenial; urgency=medium

  * Bump FLOPPY_SIZE on amd64, i386 and powerpc for linux-firmware growth.

debian-installer (20101020ubuntu451.24) xenial; urgency=medium

  [ Łukasz 'sil2100' Zemczak ]
  * Move master kernels to 4.4.0-131.
  * Move hwe kernels to 4.15.0-29.
  * Rebuild against new systemd for SCSI sync (LP: #1779815)
  * build/config/amd64/hwe-*.cfg, build/config/ppc64el/hwe-*.cfg:
    - Strip off .efi.signed for signed hwe kernels.

  [ Adam Conrad ]
  * Fix permissions on the netboot.tar kernel (LP: #1781036)

 -- Łukasz 'sil2100' Zemczak <email address hidden> Fri, 27 Jul 2018 10:38:40 +0200

Changed in debian-installer (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers