Texts in the dialogues are faulty on alternate installer

Bug #1754646 reported by sudodus on 2018-03-09
60
This bug affects 7 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Critical
Łukasz Zemczak
Bionic
Critical
Łukasz Zemczak
installation-locale (Ubuntu)
Critical
Colin Watson

Bug Description

Lubuntu's alternate installer has a problem.

The texts in the dialogue in Swedish is faulty (in several but not all dialogue boxes). I have to guess based on my memory from earlier installations. This must be fixed before the final release.

Anyway, I was able to install a system using the whole drive according to the test case in the iso testing tracker. So it seems that the (only?) problem here is how the texts in the dialogue are managed.

This bug affects Lubuntu alternate Bionic beta 1.

I installed Lubuntu in my Toshiba laptop (on bare metal),

http://www.toshiba.se/laptops/satellite-pro/c850/satellite-pro-c850-19w/

sudodus (nio-wiklund) on 2018-03-09
description: updated
summary: Texts in the dialogue in Swedish is faulty in Lubuntu alternate Bionic
- alpha
+ beta 1
description: updated
sudodus (nio-wiklund) on 2018-03-09
description: updated

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1754646

tags: added: iso-testing
sudodus (nio-wiklund) wrote :

Ubuntu Server bionic daily suffers from the same bug, I am testing it right now with Swedish in a USB pendrive cloned from

bionic-server-amd64.iso

sudodus (nio-wiklund) wrote :

removed 'affects ec2-consistent-snapshot'

affects: ec2-consistent-snapshot → ubuntu
sudodus (nio-wiklund) on 2018-03-09
description: updated
Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue and help making Ubuntu better.

>The texts in the dialogue in Swedish is faulty (in several but not all dialogue boxes).

When you say faulty, does this mean bad translations or missing all together? Can you give some examples?

(I don't know which package contains the strings used for the alternate installer, but that would be a good place at which translations exists and whether they need to be updated. Have marked Ubuntu translations as also affected, in the hope that someone there might know :) )

tags: added: bionic
sudodus (nio-wiklund) wrote :
sudodus (nio-wiklund) wrote :
sudodus (nio-wiklund) wrote :
sudodus (nio-wiklund) wrote :
sudodus (nio-wiklund) wrote :
sudodus (nio-wiklund) wrote :
sudodus (nio-wiklund) wrote :

The photos of my laptop's screen in the previous comments are examples with faulty Swedish text.

They were made when booted into the installer of Lubuntu Alternate Beta 1 made from the beta 1 iso file 'bionic-alternate-i386.iso'.

The bug makes the dialogues look the same or very similar, when I run Ubuntu Server, made from the current daily iso file 'bionic-server-amd64.iso'.

Gunnar Hjalmarsson (gunnarhj) wrote :

@sudodus: If you haven't already, it would be valuable if you could try an English install too. That way we'd know if it's a translation issue or something else.

sudodus (nio-wiklund) wrote :

I have tried it in English (the default language, en-us). It works.

I think it is a translation issue, maybe an issue with the software managing the translation or with the data files containing the Swedish text strings. I have iso-tested Lubuntu Alternate in Swedish for several years, I think since Precise (2012) and something like this has never happened before.

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks.

Looking at your examples, it appears to me as if the program flips out once it encounters a non-ascii character like å, ä and ö. That would make it an encoding issue rather than a translation one.

I think the affected package is debian-installer; changing accordingly.

affects: ubuntu → debian-installer (Ubuntu)
sudodus (nio-wiklund) wrote :

Danish Nynorsk Deutsch are also more or less faulty (some dialogues are bad, some are better, some are good).

Gunnar Hjalmarsson (gunnarhj) wrote :

@Adam: Can this possibly be related to the new glibc?

https://launchpad.net/ubuntu/+source/debian-installer/20101020ubuntu533

sudodus (nio-wiklund) wrote :

Testing now in Lubuntu beta 2: this bug is still alive.

Simon Quigley (tsimonq2) on 2018-04-05
tags: added: rls-bb-incoming
sudodus (nio-wiklund) wrote :

The bug persists in Ubuntu Server beta 2 tested with bionic-server-amd64.iso in a Toshiba laptop, http://www.toshiba.se/laptops/satellite-pro/c850/satellite-pro-c850-19w/

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) on 2018-04-09
tags: removed: rls-bb-incoming
Changed in debian-installer (Ubuntu Bionic):
importance: Undecided → Critical
tags: added: id-5acbad417b9a776f2c169db9
Simon Quigley (tsimonq2) wrote :

Someone just pointed out in IRC that this is also an issue with Spanish.

Changed in debian-installer (Ubuntu Bionic):
assignee: nobody → Łukasz Zemczak (sil2100)
Thomas (t.c) wrote :

German Locale has the same problem. Also in Beta 2 and daily image.

summary: - Texts in the dialogue in Swedish is faulty in Lubuntu alternate Bionic
- beta 1
+ Texts in the dialogues are faulty on alternate installer
Łukasz Zemczak (sil2100) wrote :

I just started looking at this but it seems like there's a general issue with displaying non-latin characters in the installer, which might be leading to the issues seen with the <ERR> debconf strings.

Changed in debian-installer (Ubuntu Bionic):
status: Confirmed → In Progress
Jb (jebsolutions) wrote :

I do not speak/read Swedish.

But this shows up right after picking "Svenska" and selecting "Installera Lubuntu". The very next prompt has the "<ERR>" text in the installer and it happens 100% of the time.

Den valda platsen kommer att <ERR>

Note: I do not speak Swedish...nor do I have a Swedish keyboard. So after selecting "Svenska" I pressed F3 and set it to "Canada" so that my keyboard allows me to type the underscore character.

I'm booting in legacy mode so this tweak gets more debug info:
- press F6 to get additional options
- hit escape at the pop-up, and then pressed the left arrow three times so the cursor is positioned in front of the "---" in the boot command line.
- added this to the boot options: DEBCONF_DEBUG=developer DEBCONF_C_VALUES=true
- add an extra space after =true
- hit enter to start the install.

Similar trick works in UEFI mode, just hit "e" to edit the command line, etc.

When I see the <ERR> onscreen I switched to an alternate console (control-alt-f2) and hit enter to activate the console:

tail -n 50 /var/log/syslog | more

It's choking on debconf string: localechooser/shortlist TXT2

"Den valda platsen kommer att " the next word in this string is "anvandas" (with the second a having the umlaut double-dots on top).

I am troubleshooting this further, but hope it helps those who do.

Jb (jebsolutions) wrote :

I mean I am not troubleshooting this further.

Colin Watson (cjwatson) on 2018-04-17
no longer affects: console-setup (Ubuntu)
no longer affects: console-setup (Ubuntu Bionic)
Changed in installation-locale (Ubuntu):
status: New → Fix Committed
importance: Undecided → Critical
assignee: nobody → Colin Watson (cjwatson)
Łukasz Zemczak (sil2100) wrote :

It seems the issue was with the locale handling from libtextwrap. Both the newt and text plugins from cdebconf seemed to use textwrap() one way or another which was failing on mblen() when the locale was not correctly identified. This was causing all the <ERR> displays whenever an UTF-8 string was supposed to be wrapped and displayed in the installer. Colin remembered that in the past there seemed to be issues with the installation-locale C.UTF-8 locale requiring a rebuild against the newer glibc - and in this case it seemed to be the case indeed. Colin uploaded a no-change rebuild just now, so I would expect it to be good soon.

Colin Watson (cjwatson) wrote :

This happened because the on-disk locale format changed in glibc 2.17, and the installer's locale needed to be rebuilt to match.

Colin Watson (cjwatson) wrote :

Sorry, typo for glibc 2.27.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package installation-locale - 1.7build1

---------------
installation-locale (1.7build1) bionic; urgency=medium

  * Rebuild against locales 2.17 (LP: #1754646).

 -- Colin Watson <email address hidden> Tue, 17 Apr 2018 16:01:05 +0100

Changed in installation-locale (Ubuntu):
status: Fix Committed → Fix Released
Changed in debian-installer (Ubuntu Bionic):
status: In Progress → Fix Committed
no longer affects: ubuntu-translations
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu537

---------------
debian-installer (20101020ubuntu537) bionic; urgency=medium

  * No-change rebuild for the new installation-locale. LP: #1754646

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 17 Apr 2018 18:17:13 +0200

Changed in debian-installer (Ubuntu Bionic):
status: Fix Committed → Fix Released
Gannet (ken20001) wrote :

Hello, http://cdimages.ubuntu.com/ubuntu-server/daily/current/bionic-server-amd64.iso from 2018-04-18 still has this bug. Where is your fix?

Colin Watson (cjwatson) wrote :

That image was built before the fix landed in bionic (compare the timestamp of the image, which is in UTC, with what you get if you hover the mouse over the timestamp of the message from Launchpad Janitor above). Tomorrow's images should have it.

Łukasz Zemczak (sil2100) wrote :

I did a quick sanity-check in the latest bionic-server-amd64 image and the issue seems to be fixed. phew.

sudodus (nio-wiklund) wrote :

I installed a server using LVM with encryption (to test a complicated case) from the latest bionic-server-amd64 image. And the dialogue in the installer works in Swedish all the way. Thanks Lukasz :-)

sudodus (nio-wiklund) wrote :

... and the the dialogue in the installer works in Swedish from Lubuntu bionic-alternate-i386.iso too :-)

Gannet (ken20001) wrote :

Recently checked a daily build. Seems it is really fixed. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers