installer no ipv4 dhcp

Bug #1747170 reported by Jb on 2018-02-03
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned

Bug Description

At the configure the network stage

"Network autoconfiguration failed
Your network is probably not using the DHCP protocol. Alternatively, the DHCP serer may
be slow or some network hardware is not working properly.

<Continue>
"

The problem is ... that it only does DHCP for ipv6 but DHCP for ipv4 doesn't work.

Work around:

Press enter at the <Continue> prompt and select "Configure network manually" and give it a fixed ip address.

Jb (jebsolutions) on 2018-02-03
summary: - installer skips ipv4 dhcp
+ installer no ipv4 dhcp
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1747170

tags: added: iso-testing
Jb (jebsolutions) wrote :

It's trying ipv6 dhcp before ipv4. Previous install did it the other way around.

Failing ipv4 error from /var/log/syslog:

"Can't initialize context: failure

If you think you have received this message due to a bug rather
than a configuration issue please read the section on submitting
bugs on either our web page at www.isc.org or in the README file
before submitting a bug. These pages explain the proper
process and information we find helpful for debugging.."

If I switch to another console and manually run "dhclient -v" I get the exact same error.

Jb (jebsolutions) wrote :

retest:

bionic server daily 20180205 = still no ipv4 dhcp

Jb (jebsolutions) wrote :

this is the contents of /var/log/syslog right after the installer fails to get an ipv4 address from dhcp

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Talat Batheesh (talat-b87) wrote :

Hi,

Is there any workaround for this issue?

Yours,
Talat

Nick (n6ck) wrote :

One Workaround is to change to another console and use 'udhcpc -i <interface>' to get an IP. Then you can change back to the installer console and continue.

Jb (jebsolutions) on 2018-02-23
Changed in debian-installer (Ubuntu):
status: Confirmed → Fix Released
hboetes (hboetes) wrote :

I'm glad to hear the bug has been fixed.

But if I look at this up to date mirror http://ubuntu.inode.at/ubuntu/dists/bionic/main/installer-amd64/current/

I still see no newer release of the install image. Can somebody please regenerate the installer so we can test the fix? Thanks

hboetes (hboetes) wrote :

Thanks for updating the image. I just retried with the image from the 5th of march and I still got the same problem.

hboetes (hboetes) wrote :

Bug has been resolved with the latest image from the 15th of march

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers