Installing the zipl boot loader fails because "/boot' is located on a multi-target device-mapper device"

Bug #1680101 reported by bugproxy on 2017-04-05
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
Ubuntu on IBM z Systems
Medium
Unassigned
debian-installer (Ubuntu)
Medium
Skipper Bug Screeners

Bug Description

Installer version: 20101020ubuntu501
Kernel: 4.10.0-15

Description/Reproduction:

System is using two multipathed FCP-LUNs. A volume group is created over these two LUNs and logical volumes for root and home are defined.

~ # vgs
  VG #PV #LV #SN Attr VSize VFree
  rootvg 2 2 0 wz--n- 39.99g 0

~ # pvs
  PV VG Fmt Attr PSize PFree
  /dev/mapper/mpatha1 rootvg lvm2 a-- 20.00g 0
  /dev/mapper/mpathb1 rootvg lvm2 a-- 20.00g 0
  /dev/mapper/mpathc1 lvm2 --- 20.00g 20.00g
  /dev/mapper/mpathd1 lvm2 --- 20.00g 20.00g

~ # lvs
  LV VG Attr LSize Pool Origin Data% Meta% Move Log Cpy%Sync Convert
  homelv rootvg -wi-ao---- 11.18g
  rootlv rootvg -wi-ao---- 28.81g

The installer fails on "Install the ZIPL boot loader on a hard disk". In syslog you see the following errors:

Apr 5 12:39:49 zipl-installer: Root filesystem on /dev/mapper/rootvg-rootlv (/dev/mapper/rootvg-rootlv)
Apr 5 12:39:49 zipl-installer: info: Root filesystem is on LV ( rootvg rootlv)
Apr 5 12:39:49 zipl-installer: Error: Unsupported setup: Directory '/boot' is located on a multi-target device-mapper device
Apr 5 12:39:49 zipl-installer: Using config file '/etc/zipl.conf'
Apr 5 12:39:49 zipl-installer: Ignore section 'old': Image file '/boot/vmlinuz.old'
Apr 5 12:39:49 zipl-installer: Run /lib/s390-tools/zipl_helper.device-mapper /boot
Apr 5 12:39:49 zipl-installer: Error: Script could not determine target parameters
Apr 5 12:39:49 main-menu[355]: (process:17396): File descriptor 3 (pipe:[11141]) leaked on lvm invocation.
Apr 5 12:39:49 main-menu[355]: (process:17396): Parent PID 17397: /bin/sh
Apr 5 12:39:49 main-menu[355]: (process:17396): File descriptor 4 (/dev/pts/0) leaked on lvm invocation.
Apr 5 12:39:49 main-menu[355]: (process:17396): Parent PID 17397: /bin/sh
Apr 5 12:39:49 main-menu[355]: (process:17396): File descriptor 5 (/dev/pts/0) leaked on lvm invocation.
Apr 5 12:39:49 main-menu[355]: (process:17396): Parent PID 17397: /bin/sh
Apr 5 12:39:49 main-menu[355]: (process:17396): File descriptor 6 (/dev/pts/0) leaked on lvm invocation.
Apr 5 12:39:49 main-menu[355]: (process:17396): Parent PID 17397: /bin/sh
Apr 5 12:39:49 main-menu[355]: WARNING **: Configuring 'zipl-installer' failed with error code 1
Apr 5 12:39:49 main-menu[355]: WARNING **: Menu item 'zipl-installer' failed.

As the error message says, having the /boot partition on a device-mapper device is not supported. If that error is not a bug, then the partitioner should not allow having such a setup and display a warning.

Default Comment by Bridge

tags: added: architecture-s39064 bugnameltc-153197 severity-high targetmilestone-inin1704
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → debian-installer (Ubuntu)

I have not reproduced this bug yet, if true, I will try to fix, but I think it is too late to make onto 17.04 release media.

Changed in ubuntu-release-notes:
status: New → Confirmed

Adding candidate to be release noted as known issue.

Changed in ubuntu-release-notes:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Changed in debian-installer (Ubuntu):
importance: Undecided → High
Changed in debian-installer (Ubuntu):
importance: High → Medium
Changed in ubuntu-z-systems:
status: New → Confirmed

Creating warning and preventing partitioning should improve this, however this will make default autopartitioning recipe to fail. If clicking next blindly fails to install the system - is a very bad user experience.

I believe I need to introduce separate /boot recipe, and do automatic detection for must have separate /boot or not, and act appropriately.

Not sure if this will be an extra set of recipes in partman-auto or a new stanza.

------- Comment From <email address hidden> 2017-07-04 07:01 EDT-------
(In reply to comment #6)
> Creating warning and preventing partitioning should improve this, however
> this will make default autopartitioning recipe to fail. If clicking next
> blindly fails to install the system - is a very bad user experience.

Yes, indeed!

> I believe I need to introduce separate /boot recipe, and do automatic
> detection for must have separate /boot or not, and act appropriately.

That's IMO the best solution, to detect, whether /boot must be separate or not and having a separate recipe for setups with separate /boot.

> Not sure if this will be an extra set of recipes in partman-auto or a new
> stanza.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2017-11-29 04:14 EDT-------
Canonical, will this make it into 18.04 ?

Changed in ubuntu-z-systems:
importance: Undecided → Medium

Default Comment by Bridge

tags: added: id-5a7c3f25b2bfb6e1130ad694
Frank Heimes (frank-heimes) wrote :
Download full text (5.3 KiB)

My tests on 18.04 beta 2 show that this is fixed.

Installed and configured a system like follows and it boots fine - hence closing this ticket.

  ā”Œā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”¤ [!!] Partition disks ā”œā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”
  ā”‚ ā”‚
  ā”‚ This is an overview of your currently configured partitions and mount ā”‚
  ā”‚ points. Select a partition to modify its settings (file system, mount ā”‚
  ā”‚ point, etc.), a free space to create partitions, or a device to ā”‚
  ā”‚ initialize its partition table. ā”‚
  ā”‚ ā”‚
  ā”‚ - ā”‚
  ā”‚ Multipath mpatha (WWID 36005076306ffd6b60000000000002600) - 68.7 ā–’ ā”‚
  ā”‚ > #1 primary 68.7 GB K lvm ā–’ ā”‚
  ā”‚ Multipath mpathb (WWID 36005076306ffd6b60000000000002601) - 68.7 0 ā”‚
  ā”‚ > #1 primary 68.7 GB K lvm ā–’ ā”‚
  ā”‚ LVM VG rootvg, LV homelv - 100.0 GB Linux device-mapper (linear) ā–’ ā”‚
  ā”‚ > #1 100.0 GB f ext4 /home ā–’ ā”‚
  ā”‚ LVM VG rootvg, LV rootlv - 37.4 GB Linux device-mapper (linear) ā–’ ā”‚
  ā”‚ > #1 37.4 GB f ext4 / ā–’ ā”‚
  ā”‚ . ā”‚
  ā”‚ ā”‚
  ā”‚ <Go Back> ā”‚
  ā”‚ ā”‚
  ā””ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”˜

    ā”Œā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”¤ [!!] Partition disks ā”œā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”
    ā”‚ ā”‚
    ā”‚ If you continue, the changes listed below will be written to the ā”‚
    ā”‚ disks. Otherwise, you will be able to make further changes manually. ā”‚
    ā”‚ ā”‚
    ā”‚ The partition tables of the following devices are changed: ā”‚
    ā”‚ LVM VG rootvg, LV homelv ā”‚
    ā”‚ LVM VG rootvg, LV rootlv ā”‚
    ā”‚ ā”‚
    ā”‚ The following partitions are going to be formatted: ā”‚
    ā”‚ LVM VG rootvg, LV homelv as ext4 ā”‚
    ā”‚ LVM VG rootvg, LV rootlv as ext4 ā”‚
    ā”‚ ā”‚
    ā”‚ Write the changes to disks? ā”‚
    ā”‚ ā”‚
    ā”‚ <Yes> ...

Read more...

Changed in debian-installer (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-z-systems:
status: Confirmed → Fix Released

------- Comment From <email address hidden> 2018-04-11 03:41 EDT-------
IBM bugzilla closed -> Verifed by Canonical

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers