Lubuntu's alternate i386 installer cannot connect to a network

Bug #1616400 reported by sudodus on 2016-08-24
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
High
Adam Conrad
netcfg (Ubuntu)
High
Adam Conrad

Bug Description

Running Lubuntu's Yakkety alternate i386 beta1 installer fails.

I arrive at a red screen with the text: "No network interfaces were found ..."

This is in a Toshiba laptop, that I have used for testing since 2013, and it works with the corresponding current Lubuntu desktop iso files. I expect the wired ethernet to work with the alternate iso file like it worked, when I tested with Yakkety alternate i386 alpha 2.

http://www.toshiba.se/laptops/satellite-pro/c850/satellite-pro-c850-19w/

ctrl + alt + F4 shows the following log text:

-----
main-menu: menu item 'ethdetect' selected
net/hw-detect.hotplug: detected hotpluggable network interface lo
check-missing-firmware ...
...
check-missing-firmware: no missing firmware in loaded kernwel modules
main-menu: (process 16031) : modeprobe: invalid option -- 'l'
main-menu: DEBUG: resolver (libgcc1): package doesnotä exist (ignored)
...
main-menu: INFO: Menu item 'netcfg' selected
netcfg: INFO: Starting netcfg v.1.138ubuntu1
netcfg: WARNING: **: Couldno't read Wpasupplicant pid file, not trying to kill.
netcfg: INFO: Could not find valid BOOTIF= entry in /proc/cmdline
-----

It works to continue the installation without network. The installed system boots, but the installed system fails to connect to the internet. I have not tried to fix it, just noticed that ethernet does not work 'out of the box' as it should in the installed system.

sudodus (nio-wiklund) wrote :

Running Lubuntu's Yakkety alternate amd64 beta1 installer fails in the same way as described above for i386.

I arrive at a red screen with the text: "No network interfaces were found ..."

-o-

Lubuntu's Yakkety alternate i386 beta1 installer fails in the same way also in another laptop, a Lenovo X131.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1616400

tags: added: iso-testing
sudodus (nio-wiklund) wrote :

Just for information, the current Yakkety i386 mini.iso is not affected by this bug. 'Autoconfiguration has succeeded', and it is possible to install a system with a working ethernet connection.

Ian Bruntlett (ian-bruntlett) wrote :

This bug affects me, too.

The iso I tested was the 20160824 spin of 32-bit Lubuntu, here are the details:-

Output from md5sum, running on the iso I installed with:-
675238603d60670aa681f34e3dfd1ad6 yakkety-alternate-i386.iso

I am using a Samsung NC10 Netbook (32-bit Intel Atom CPU, 2 GiB RAM, 320GB hard drive), further hardware details can be found here:- https://gist.github.com/21b61903871ee685fc79

I managed to install the O.S. by selecting "Continue" on the red screen complaining about not seeing network interfaces. However, after booting the installed system, I was unable to access the Internet either by cable or by Wi-Fi (however, the networking applet could see the Wi-Fi networks nearby to me).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Adam Conrad (adconrad) wrote :

Fixed when images build against 20101020ubuntu471

Changed in debian-installer (Ubuntu):
status: Confirmed → Fix Released
Simon Quigley (tsimonq2) wrote :

This will be fixed by a new debian-installer version included in the Beta 1 respin coming soon.

sudodus (nio-wiklund) wrote :

The network bug is partially squashed in the new beta 1 iso file dated 20160825.

The network is available duing boot, but the installed system does not connect automatically via ethernet as it should.

With the previous iso file, I could not connect at all, now I can connect via wifi, so there is an improvement.

I don't know if this is another aspect of the bug 1616400, that the installer did not create a good installed system, or if it is a new bug, and in that case where to report it. (Wired network is greyed out in nm-applet.)

Tested in http://www.toshiba.se/laptops/satellite-pro/c850/satellite-pro-c850-19w/

sudodus (nio-wiklund) wrote :

There is nothing in /etc/network/interfaces.d/*

A copy of the file /etc/network/interfaces is attached

Martin Pitt (pitti) wrote :

Please attach the full /var/log/installer/ logs so that we can see what went wrong in netcfg. Apparently it failed to put the configured interface into /etc/network/interfaces (which is empty aside from the standard boilerplate about lo and source-directory).

Changed in debian-installer (Ubuntu):
status: Fix Released → New
status: New → Incomplete
sudodus (nio-wiklund) wrote :
sudodus (nio-wiklund) wrote :

The bug is still alive

Changed in debian-installer (Ubuntu):
status: Incomplete → Confirmed
Martin Pitt (pitti) wrote :

FTR: current netcfg design is that it wipes the generated ifupdown config if NetworkManager is installed, so the duplicate run (where the second one creates an essentially empty ifupdown file) is intended. It just needs to install a netplan policy corresponding to http://bazaar.launchpad.net/~ubuntu-core-dev/livecd-rootfs/trunk/view/head:/live-build/auto/build#L196 to unblacklist ethernets from NM.

Changed in netcfg (Ubuntu):
status: New → Fix Committed
assignee: nobody → Adam Conrad (adconrad)
Changed in debian-installer (Ubuntu):
status: Confirmed → In Progress
Changed in netcfg (Ubuntu):
importance: Undecided → High
Changed in debian-installer (Ubuntu):
importance: Undecided → High
Adam Conrad (adconrad) on 2016-08-25
Changed in debian-installer (Ubuntu):
status: In Progress → Fix Committed
assignee: nobody → Adam Conrad (adconrad)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netcfg - 1.138ubuntu2

---------------
netcfg (1.138ubuntu2) yakkety; urgency=medium

  * On NetworkManager-using systems, write a netplan config file to hand
    over control of all our interfaces to NetworkManager (LP: #1616400)

 -- Adam Conrad <email address hidden> Thu, 25 Aug 2016 09:29:05 -0600

Changed in netcfg (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu472

---------------
debian-installer (20101020ubuntu472) yakkety; urgency=medium

  [ Adam Conrad ]
  * Rebuild against netcfg 1.138ubuntu2 (LP: #1616400)

  [ dann frazier ]
  * arm64/xgene-uboot: Set the correct compression flag when generating
    a uImage of a gzip'd kernel.

 -- Adam Conrad <email address hidden> Thu, 25 Aug 2016 10:24:39 -0600

Changed in debian-installer (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers