Partition disks - The attempt to mount a file system with type ext4 in Encrypted volume (sda1_crypt) at / failed.

Bug #1572940 reported by bugproxy on 2016-04-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
High
Unassigned
debian-installer (Ubuntu)
Undecided
Dimitri John Ledkov

Bug Description

Problem Description
=====================
Installation SCSI LUN 0006 under LPAR p23lp50 failed :
Used Installer 20101020ubuntu447

Installation failed during installing of encrypted partitions as defined in Ubuntu Installation testcase#10.
Pop-up windows displays message: Partition disks - The attempt to mount a file system with type ext4 in Encrypted volume (sda1_crypt) at / failed.

== Comment: #3 - Gerhard G. Hiller <email address hidden> - 2016-04-19 05:21:43 ==
steps for encryption during partitioning, which ended with failure message.

== Comment: #4 - Gerhard G. Hiller <email address hidden> - 2016-04-19 05:23:50 ==
syslog output:

Apr 19 08:37:50 md-devices: mdadm: No arrays found in config file or automatically
Apr 19 08:37:51 partman: No matching physical volumes found
Apr 19 08:37:51 partman: Reading all physical volumes. This may take a while...
Apr 19 08:37:52 kernel: [ 791.994575] EXT4-fs (sda3): couldn't mount as ext3 due to feature incompatibilities
Apr 19 08:37:52 kernel: [ 791.994787] EXT4-fs (sda3): couldn't mount as ext2 due to feature incompatibilities
Apr 19 08:37:52 kernel: [ 792.005258] EXT4-fs (sda3): mounted filesystem with ordered data mode. Opts: (null)
Apr 19 08:37:52 kernel: [ 792.034297] EXT4-fs (sda3): couldn't mount as ext3 due to feature incompatibilities
Apr 19 08:37:52 kernel: [ 792.034505] EXT4-fs (sda3): couldn't mount as ext2 due to feature incompatibilities
Apr 19 08:37:52 kernel: [ 792.035293] EXT4-fs (sda3): mounted filesystem with ordered data mode. Opts: (null)
Apr 19 08:42:19 kernel: [ 1058.898101] Adding 976892k swap on /dev/sda2. Priority:-1 extents:1 across:976892k FS
Apr 19 08:42:19 partman: mke2fs 1.42.13 (17-May-2015)
Apr 19 08:44:14 anna-install: Installing cdebconf-newt-entropy
Apr 19 08:44:14 anna[10781]: DEBUG: resolver (libnewt0.52): package doesn't exist (ignored)
Apr 19 08:44:14 anna[10781]: DEBUG: retrieving cdebconf-newt-entropy 0.33
Apr 19 08:44:14 anna[10781]: 2016-04-19 08:44:14 URL:http://de.ports.ubuntu.com/ubuntu-ports//pool/main/c/cdebconf-entropy/cdebconf-newt-entropy_0.33_s390x.udeb [18652/18652] -> "/var/cache/anna/cdebconf-newt-entropy_0.33_s390x.udeb" [1]
Apr 19 08:44:14 anna[10781]: DEBUG: retrieving libslang2-udeb 2.3.0-2ubuntu1
Apr 19 08:44:15 anna[10781]: 2016-04-19 08:44:15 URL:http://de.ports.ubuntu.com/ubuntu-ports//pool/main/s/slang2/libslang2-udeb_2.3.0-2ubuntu1_s390x.udeb [243924/243924] -> "/var/cache/anna/libslang2-udeb_2.3.0-2ubuntu1_s390x.udeb" [1]
Apr 19 08:44:15 anna-install: Installing partman-crypto-dm
Apr 19 08:47:39 kernel: [ 1378.561923] Adding 976892k swap on /dev/sda2. Priority:-1 extents:1 across:976892k FS
Apr 19 08:47:39 partman: mke2fs 1.42.13 (17-May-2015)
Apr 19 08:52:29 partman-crypto: kernel entropy_avail: 188 bits
Apr 19 08:53:08 kernel: [ 1708.076915] NET: Registered protocol family 38
Apr 19 08:53:12 partman-crypto: kernel entropy_avail: 138 bits
Apr 19 08:58:27 kernel: [ 2027.052501] Adding 974844k swap on /dev/mapper/sda2_crypt. Priority:-1 extents:1 across:974844k FS
Apr 19 08:58:27 partman: mke2fs 1.42.13 (17-May-2015)
Apr 19 08:58:41 partman-crypto: No matching physical volumes found
Apr 19 08:58:41 partman-crypto: Reading all physical volumes. This may take a while...
Apr 19 09:01:52 kernel: [ 2232.285063] Unable to find swap-space signature
Apr 19 09:01:52 kernel: [ 2232.300412] Unable to find swap-space signature
Apr 19 09:01:52 kernel: [ 2232.315338] Unable to find swap-space signature
Apr 19 09:01:52 kernel: [ 2232.330548] Unable to find swap-space signature
Apr 19 09:01:52 kernel: [ 2232.345440] Unable to find swap-space signature
Apr 19 09:01:52 clear_partitions: Considering /boot,/dev/sda3.
Apr 19 09:07:10 main-menu[393]: (process:7110): mount: mounting /dev/sda1 on /tmp/tmp.e7lJnL failed: Invalid argument
Apr 19 09:07:10 main-menu[393]: (process:7110): mount: mounting /dev/sda2 on /tmp/tmp.e7lJnL failed: Invalid argument
Apr 19 09:07:10 main-menu[393]: (process:7110): mount: mounting /dev/sda1 on /tmp/tmp.QessbM failed: Invalid argument
Apr 19 09:07:10 main-menu[393]: (process:7110): mount: mounting /dev/sda2 on /tmp/tmp.QessbM failed: Invalid argument
Apr 19 09:07:10 main-menu[393]: (process:7110): sh: 4194304: unknown operand
Apr 19 09:07:10 main-menu[393]: (process:7110): cat: can't open '0-9206497279/mountpoint': No such file or directory
Apr 19 09:07:10 main-menu[393]: (process:7110): sh: 4194304: unknown operand
Apr 19 09:07:10 main-menu[393]: (process:7110): mount: mounting /dev/mapper/sda1_crypt on /target/ failed: Invalid argument
Apr 19 09:07:10 main-menu[393]: WARNING **: Configuring 'partman-base' failed with error code 2
Apr 19 09:07:10 main-menu[393]: WARNING **: Menu item 'partman-base' failed.

Default Comment by Bridge

tags: added: architecture-s39064 bugnameltc-140374 severity-high targetmilestone-inin16041
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1572940/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
dann frazier (dannf) on 2016-04-26
affects: ubuntu → debian-installer (Ubuntu)
Changed in debian-installer (Ubuntu):
assignee: Skipper Bug Screeners (skipper-screen-team) → Dimitri John Ledkov (xnox)
Frank Heimes (fheimes) on 2016-05-12
Changed in ubuntu-z-systems:
status: New → Triaged
importance: Undecided → High
bugproxy (bugproxy) on 2016-09-12
tags: added: targetmilestone-inin1610
removed: targetmilestone-inin16041

------- Comment From <email address hidden> 2016-10-24 04:02 EDT-------
Changed Target to 17.04 due to installer dependencies

tags: added: targetmilestone-inin1704
removed: targetmilestone-inin1610
Changed in debian-installer (Ubuntu):
milestone: none → ubuntu-17.03
Changed in debian-installer (Ubuntu):
milestone: ubuntu-17.03 → ubuntu-17.07
Frank Heimes (fheimes) wrote :

re-test needed

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-02-14 08:21 EDT-------
IBM Bugzilla status -> closed, re-tested withi Ubuntu 16.04 newest level. Not reproducable....

Frank Heimes (fheimes) on 2018-02-14
Changed in debian-installer (Ubuntu):
status: New → Fix Released
Changed in ubuntu-z-systems:
status: Triaged → Fix Released
tags: added: id-5a7c3b2676f5c6b27356bc7f
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers