netcfg/disable_autoconfig=true still prompts for "Auto-configure networking?"

Bug #1572607 reported by bugproxy on 2016-04-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Medium
Dimitri John Ledkov
debian-installer (Ubuntu)
High
Skipper Bug Screeners
Xenial
High
Skipper Bug Screeners
Yakkety
High
Unassigned
netcfg (Ubuntu)
High
Unassigned
Xenial
High
Unassigned
Yakkety
High
Unassigned

Bug Description

[Impact]

 * on s390x only, priority of dhcp question was lowered which resulted in a buggy behaviour for unattended installs. Without this fix it's not possible to complete unattended install as the installer "stalls" at dhcp question.

[Test Case]

 * Install unattended s390x machine with dchp
 * Install unattended s390x machine without dhcp (static netcfg)

[Regression Potential]

 * Changes to resolve this should only affect s390x

== Comment: - Ofer Baruch - 2016-04-20 05:28:06 ==
I am trying to install Ubuntu using a parm file so i won't get any prompts until SSH is available to connect to the guest.

the "Auto-configure networking?" prompt keeps popping although i have specifically asked to turn it off.

this used to work fine for me a week ago and i didn't even had the netcfg/disable_autoconfig=true in my parm file. now that i got the prompt (i assumed you guys fixed something) i added the netcfg/disable_autoconfig=true parameter but i still get the prompt.

i am attaching the console output.

This will affect affect IBM Wave functionality...
IBM Wave allows the user to install Ubuntu without any need to access z/VM (Wave will do everything for you). when SSH is available the user can continue the installation. as we get the prompt in the middle of the installation the user can't continue the install as SSH is not yet available and he does not have access to the z/VM console

Default Comment by Bridge

tags: added: architecture-s39064 bugnameltc-140501 severity-high targetmilestone-inin16041
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
Kevin W. Rudd (kevinr) on 2016-04-20
affects: ubuntu → debian-installer (Ubuntu)
Dimitri John Ledkov (xnox) wrote :

Yes, this is a bug that seen flag is not set on that question when disabel_autoconfig=true is preseed.

Could you try to specify these two things in the paramfile:

netcfg/disable_autoconfig=true netcfg/use_autoconfig=false

This should set the right seen flag, and the question should not pop-up with the current/latest installers.

Regards,

Dimitri.

Changed in netcfg (Ubuntu Xenial):
status: New → Triaged
Changed in debian-installer (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → High
Changed in netcfg (Ubuntu Xenial):
importance: Undecided → High
dann frazier (dannf) on 2016-04-20
Changed in ubuntu-z-systems:
status: New → Triaged
assignee: nobody → Dimitri John Ledkov (xnox)

------- Comment From <email address hidden> 2016-04-27 18:00 EDT-------
thank you... the workaround works fine.
sorry for the late response (Holiday).
i have added both of the parameters to our automatically generated parm file and it works fine.

Changed in ubuntu-z-systems:
status: Triaged → In Progress
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netcfg - 1.135ubuntu5

---------------
netcfg (1.135ubuntu5) yakkety; urgency=medium

  * When DHCP is disabled via preseed, do not ask the DHCP question on
    s390x by propagating the seen flags from preseed-only keys to the
    interactive question. This is a side-effect / regression from
    1.135ubuntu3. LP: #1572607

 -- Dimitri John Ledkov <email address hidden> Wed, 11 May 2016 11:44:18 +0100

Changed in netcfg (Ubuntu Yakkety):
status: Triaged → Fix Released
Changed in ubuntu-z-systems:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu456

---------------
debian-installer (20101020ubuntu456) yakkety; urgency=medium

  * Cherry-pick fix from Debian git for dosfstools 4.0 regression.

debian-installer (20101020ubuntu455) yakkety; urgency=medium

  * Rebuild to include updated netcfg package. LP: #1572607, LP: #1567687

 -- Adam Conrad <email address hidden> Fri, 13 May 2016 11:15:51 -0600

Changed in debian-installer (Ubuntu Yakkety):
status: Triaged → Fix Released
Changed in ubuntu-z-systems:
importance: Wishlist → Medium
description: updated

Hello bugproxy, or anyone else affected,

Accepted netcfg into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/netcfg/1.135ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in netcfg (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

Hello bugproxy, or anyone else affected,

Accepted debian-installer into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debian-installer/20101020ubuntu451.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in debian-installer (Ubuntu Xenial):
status: Triaged → Fix Committed
Dimitri John Ledkov (xnox) wrote :

Validated that:
d-i netcfg/disable_autoconfig boolean true

operates as expected with xenial-proposed installer.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netcfg - 1.135ubuntu4.1

---------------
netcfg (1.135ubuntu4.1) xenial; urgency=medium

  * With vlan connection type, finish-install.d would decide to purge
    network configuration and writeout loopback interfaces only, due to
    the assumption that !wired, must be wireless. Write out loopback only
    config with wireless only connection type. With this change vlan
    settings propagate through to the system, after additional
    network-manager changes were added. LP: #1567687

  * When DHCP is disabled via preseed, do not ask the DHCP question on
    s390x by propagating the seen flags from preseed-only keys to the
    interactive question. This is a side-effect / regression from
    1.135ubuntu3. LP: #1572607

 -- Dimitri John Ledkov <email address hidden> Thu, 19 May 2016 11:34:16 +0100

Changed in netcfg (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for netcfg has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu451.1

---------------
debian-installer (20101020ubuntu451.1) xenial; urgency=medium

  * Rebuild with updated netcfg package:
    - fix propagation of netcfg/vlan_id settings LP: #1567687
    - fix disabling dhcp via preseed on s390x LP: #1572607

 -- Dimitri John Ledkov <email address hidden> Fri, 20 May 2016 05:42:25 +0100

Changed in debian-installer (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers