Using of IPv6 address in url for preseed file causes an error in installer

Bug #1547629 reported by bugproxy on 2016-02-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Dimitri John Ledkov
preseed (Debian)
Fix Released
Unknown
preseed (Ubuntu)
Undecided
Dimitri John Ledkov

Bug Description

== Comment: #0 - IRINA YASHINA - 2016-02-18 07:31:18 ==
I tried to install Ubuntu16.04 with preseed file.
When IPv6 address was used in preseed/url:

preseed/url=http://[fd00:9:152:48:1822:ffff:162:199]/ubuntu/ira/s83lp25.preseed

the error message with wrong url appeared in installer (error scrinshot),
the preseed file couldn't be used.

In the syslog we can see the following messages with incorrectly changed url:

Feb 18 07:33:31 main-menu[501]: DEBUG: resolver (libc6-udeb): package doesn't exist (ignored)
Feb 18 07:33:31 main-menu[501]: INFO: Menu item 'network-preseed' selected
Feb 18 07:34:48 main-menu[501]: (process:517): http://[fd00.boeblingen.de.ibm.com:9:152:48:1822:ffff:162:199]/ubuntu/ira/s83lp25.preseed: Invalid IPv6 numeric address.
Feb 18 07:34:48 main-menu[501]: WARNING **: Configuring 'network-preseed' failed with error code 1
Feb 18 07:34:48 main-menu[501]: WARNING **: Menu item 'network-preseed' failed.
Feb 18 07:35:14 main-menu[501]: INFO: Modifying debconf priority limit from 'high' to 'medium'
Feb 18 07:35:14 debconf: Setting debconf/priority to medium
Feb 18 07:35:14 main-menu[501]: DEBUG: resolver (libc6-udeb): package doesn't exist (ignored)

The syslog is attached.

Here are the output of the 'fetch-url' and 'wget' commands in shell:

~ # fetch-url http://[fd00:9:152:48:1822:ffff:162:199]/ubuntu/ira/s83lp25.preseed
No such file or directory

~ # wget http://[fd00:9:152:48:1822:ffff:162:199]/ubuntu/ira/s83lp25.preseed
--2016-02-18 09:17:37-- http://[fd00:9:152:48:1822:ffff:162:199]/ubuntu/ira/s83lp25.preseed
Connecting to [fd00:9:152:48:1822:ffff:162:199]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3390 (3.3K) [text/plain]
Saving to: 's83lp25.preseed'

s83lp25.preseed 100%[==================================================================================================================>] 3.31K --.-KB/s in 0s

2016-02-18 09:17:37 (883 MB/s) - 's83lp25.preseed' saved [3390/3390]

With IPv4 address in preseed/url no problems were found,
the preseed file was successfully applied in installer.

== Comment: #9 - IRINA YASHINA - 2016-02-19 05:22:35 ==
I've checked the last version of the installer:

http://ports.ubuntu.com/ubuntu-ports/dists/xenial/main/installer-s390x/20101020ubuntu423/

The bug still takes place.

== Comment: #10 - Hendrik Brueckner <email address hidden> - 2016-02-19 11:14:22 ==
I have opened a Debian bug to address this issue. A problem fix is also attached.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815166

Default Comment by Bridge

tags: added: architecture-s39064 bugnameltc-137452 severity-medium targetmilestone-inin1604
bugproxy (bugproxy) wrote : syslog

Default Comment by Bridge

Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
Kevin W. Rudd (kevinr) on 2016-02-19
affects: ubuntu → debian-installer (Ubuntu)
dann frazier (dannf) on 2016-02-19
Changed in debian-installer (Ubuntu):
assignee: Skipper Bug Screeners (skipper-screen-team) → Dimitri John Ledkov (xnox)
Changed in debian-installer (Debian):
status: Unknown → New
affects: debian-installer (Debian) → preseed (Debian)
Changed in preseed (Debian):
status: New → Fix Released
Changed in preseed (Ubuntu):
status: New → In Progress
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in debian-installer (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package preseed - 1.71ubuntu1

---------------
preseed (1.71ubuntu1) xenial; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Change the "keymap" alias to keyboard-configuration/layoutcode.
    - Change default preseed root to "d-i/xenial/./preseed.cfg".

preseed (1.71) unstable; urgency=medium

  [ Hendrik Brueckner ]
  * auto-install: correctly handle IPv6 addresses Closes: #815166, LP:
    #1547629

preseed (1.70) unstable; urgency=medium

  [ Colin Watson ]
  * Use HTTPS for Vcs-* URLs, and link to cgit rather than gitweb.

preseed (1.69) unstable; urgency=medium

  [ Raphaël Hertzog ]
  * Invert env-preseed and initrd-preseed so that the former overrides
    the latter. Closes: #805291

 -- Dimitri John Ledkov <email address hidden> Wed, 24 Feb 2016 11:40:47 +0000

Changed in preseed (Ubuntu):
status: In Progress → Fix Released
Changed in debian-installer (Ubuntu):
status: Triaged → In Progress
Changed in debian-installer (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu428

---------------
debian-installer (20101020ubuntu428) xenial; urgency=medium

  * Rebuild with preseed package that accepts IPv6 urls. LP: #1547629.

 -- Dimitri John Ledkov <email address hidden> Mon, 29 Feb 2016 14:57:05 +0000

Changed in debian-installer (Ubuntu):
status: Fix Committed → Fix Released

------- Comment From <email address hidden> 2016-03-02 08:15 EDT-------
The fix was successfully verified with 20101020ubuntu428.
The problem has been solved.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.