Selecting and install software fails on ubnutu server xenial

Bug #1517746 reported by Lyn Perrine
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Fix Released
High
Colin Watson

Bug Description

Install Ubuntu server in accordance with the instructions for a testcase 1337 for install Default for ubuntu server. Run this installation and I when going to select and install software I get a red screen saying select and install software failed and cannot get the install to complete using the November 18th iso for ubuntu server.

I expected it to install I will install all the reuqired logs it appears this iso was made with systemd-pam and systemd that cannot be installed together and created a dependency hell when this serve image was created. I expected it to install I will install all the reuqired logs it appears this iso was made with systemd-pam and systemd that cannoy be

Tags: iso-testing
Revision history for this message
Lyn Perrine (walterorlin) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1517746

tags: added: iso-testing
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Revision history for this message
Doug Smythies (dsmythies) wrote :

I got stuck at the "select and install software" step as described herein. I tried a few times, and double checked by md5sum on the USB I was using. I went back to my daily iso from 2105.10.30, and it worked fine. Ubuntu server 64 bit.

Revision history for this message
Doug Smythies (dsmythies) wrote :

Additionally,

after successful installation using the older iso, I ran updates, then re-booted. The network no longer worked and attempts to login on the terminal flashed some sort of error on the screen and went back to the login screen. I have no clue if the root cause is the same, but the system is unusable.

Revision history for this message
Lyn Perrine (walterorlin) wrote :

I tried the minimal testcase that only installs the ubuntu minimal server in a kvm vm so this might not be the installer and select and install software with the thing in ubuntu-standard. However since I attached syslog that is what I thought the logs stated. Also the debian installer alternate images for lubuntu are still working as well.

Revision history for this message
Yung Shen (kaxing) wrote :

I don't have any problem installing(testcase:1337) build:20151115 via usb flash drive with network enabled.
But I got other problem with pxe installation: bug #1523396

Revision history for this message
Doug Smythies (dsmythies) wrote :

The daily server 64 bit iso of 2015.12.09.2 now completes the installation. However, the login loop mentioned in comment #5, now prevents actually using the system.

Revision history for this message
Doug Smythies (dsmythies) wrote :

Addendum:
It is specifically selecting "Samba Server" at the select software step that will subsequently cause the login loop issue.
(perhaps I should enter a new bug report for this.)

Revision history for this message
Doug Smythies (dsmythies) wrote :

I believe, but am not sure, the login loop issue when selecting "Samba Server" is due to bug 1515207.
So, as of daily 2015.12.09.2, this bug no longer effects me.

Revision history for this message
cariboo (cariboo) wrote :

I ran into the same problem as Doug, running the desktop version.

Setting up a shared directory asks to install samba and libpam-smbpass caused the problem. Removing libpam-smbpass fixed the problem for me.

Revision history for this message
Doug Smythies (dsmythies) wrote :

The issue of this bug report, getting stuck at the selecting and installing software step has returned. The daily of 2105.12.17 has the problem. The daily of 2015.12.16 does not have the problem.

Revision history for this message
Colin Watson (cjwatson) wrote :

The original problem from this report was due to the squashfs base system on the image being out of sync with packages provided as .debs. This was a consequence of a file locking bug on the master image build server, which I fixed in this commit:

  http://bazaar.launchpad.net/~ubuntu-cdimage/ubuntu-cdimage/mainline/revision/1557

Any other problems that persist should be filed as separate bugs, attaching full logs.

Changed in debian-installer (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: Confirmed → Fix Released
Revision history for this message
Doug Smythies (dsmythies) wrote :

The issue of this bug report has returned. I am using the daily of 2016.03.06. I don't have another recent daily to compare to.

Changed in debian-installer (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Doug Smythies (dsmythies) wrote :

Same with the daily of 2016.03.07.

It does seem possible to get past the "select and install" software failure loop, by not selecting anything, but then it seems to load the mail server stuff and wants to configure it.
I was able to run tasksel afterwards and install what I really wanted in the first place.

Revision history for this message
Doug Smythies (dsmythies) wrote :

Same with the daily of 2016.03.08. I seem to be the only person testing server daily ISO's. Setting the importance to high, as it is not good to not be able to select and install software at this stage of the cycle.

Changed in debian-installer (Ubuntu):
importance: Undecided → High
Revision history for this message
Doug Smythies (dsmythies) wrote :

Same with the daily of 2016.03.15.

Brendan submitted a pass test case two days ago. Did it not install the mail server stuff and want to configure it, even though it wasn't asked for?

Revision history for this message
Lyn Perrine (walterorlin) wrote :

oh oops I think yeah that is not asked for but it completed the install I think without failing in my virtual machine. Was there a change in defualt server utilitlies in tasksel?

Revision history for this message
Doug Smythies (dsmythies) wrote :

For the selecting stuff and failing:

The daily ISOs of 2016.03.06, 2016.03.07, 2016.03.08 FAIL.
The daily ISO of 2016.03.15 O.K.

The changelog for d-i doesn't explain why it is now working again.

The mailsever thing has been moved to a separate bug report, bug 1557936.
Setting this back to "Fix Released

Changed in debian-installer (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers