No installer support for the Perc 4e/Di Controller.

Bug #14530 reported by Scott Robinson
This bug report is a duplicate of:  Bug #14101: No driver for Perc 4e/Di Controller. Edit Remove
6
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Medium
Colin Watson

Bug Description

This is related to 7759, and 7883, but it's a report against the installer so it
shows up in the bug list for it.

The Dell Perc4e/Di controller is not supported in Ubuntu. It's a RAID controller
which requires the megaraid2 / megaraid_mm kernel drivers.

Matt Zimmerman noted in https://bugzilla.ubuntu.com/show_bug.cgi?id=7759#c3 that
Ubuntu had to choose between one or the other. Is is possible to, at least,
provide the kernel object file as a workaround and blacklist it in the automatic
detection code? That way, regressions won't occur but those of us who _need_ it
can still force the use?

Revision history for this message
Matt Zimmerman (mdz) wrote :

They are one and the same issue; the driver is not built by the kernel at all,
so the controller is not supported in the installer or elsewhere.

It might be possible to build both drivers if we modify the kernel build process
and carefully exclude the new driver from autodetection; let's discuss in bug #14101.

This bug has been marked as a duplicate of bug 14101.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.