netboot mini.iso doesn't support UEFI boot

Bug #1429030 reported by William Grant on 2015-03-06
118
This bug affects 26 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

The amd64 mini.iso (in at least trusty through current vivid) has an EFI boot partition, but it's empty. This renders the image unbootable on systems without BIOS boot enabled.

This is easily worked around by copying {boot,grub}x64.efi from eg. a desktop image into the empty partition.

tags: added: trusty utopic vivid
Changed in debian-installer (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Shih-Yuan Lee (fourdollars) wrote :
summary: - mini.iso's UEFI boot partition is empty
+ netboot mini.iso doesn't support UEFI BIOS mode installation.
William Grant (wgrant) on 2015-10-08
summary: - netboot mini.iso doesn't support UEFI BIOS mode installation.
+ netboot mini.iso doesn't support UEFI boot
Changed in debian-installer (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
importance: Medium → High
status: Confirmed → Triaged
tags: added: wily

When will this be fixed?

Naël (nathanael-naeri) wrote :

I once had to install 14.04 LTS by booting from the mini ISO image on the internal hard disk instead of booting from a thumb drive made from that image (2008 Apple Macbook Pro can't boot from USB, can you believe that).

I wished the EFI folder of that ISO hadn't been empty.

WILL THIS BUG EVER BE FIXED!!!!!!

tags: added: xenial
BPM (britishben) wrote :

In the 16.04 mini.iso, extracting /boot/grub/efi.img to the root of the image works too - the UEFI support is provided, but not enabled.

Naël (nathanael-naeri) wrote :

Is there a good reason why this is up to the user to do it, instead of done by default?

Orher than their LAZY I don't see any reason they can't do. They do it for their desktop cds and Debian does it for their daily net install isos

Elliot Huffman (elliot-labs) wrote :

Amd64 variant of the ubuntu netboot images does not include UEFI enabled by default.

Successfully enabled EFI by extracting the grub images like was suggested above.

Ubuntu version: 16.04.1 LTS x64 netboot mini.iso

Naël (nathanael-naeri) wrote :

@Elliot, can you give more details please? I don't know how to extract files to the root of an image and obtain a new image. I'd like to try.

You shouldn't have to do that, Ubuntu should fix the mini.iso. Debian's net install iso works with UEFI so Ubuntu's should as well.

tags: added: zesty
Naël (nathanael-naeri) on 2017-02-13
tags: added: yakkety
removed: utopic vivid wily

Will this ever be fixed?

tags: added: artful
tags: removed: yakkety

Is this ever going to be fixed, if Debian can have it working so can you.

tags: added: bionic
tags: added: cosmic
Wladimir Mutel (mwg) wrote :

Add my vote for getting Ubuntu mini.iso compliant with Debian and currently-common sense overall.

I tried Precise, Trusty, Bionic and Cosmic amd64 Mini ISOs and all of them are booting successfully in QEMU with OVMF. However, none of them are booting in a UEFI physical machine.

It's strange this bug is present for three years: both Desktop and Server images have a functional bootloader. Those unused FAT12 partition take as much as 1/6 of the Mini image sizes.

Niklas Holm (niklas-holm) wrote :

This bug caused me a significant amount of time before figuring out how to fix it manually. It should be trivial to fix this on the ISO as well.

HOW, AFTER FOUR YEARS, IS THIS NOT FIXED YET???

Steve Langasek (vorlon) wrote :

> HOW, AFTER FOUR YEARS, IS THIS NOT FIXED YET???

The mini iso is an artifact of the debian-installer package build and is not a supported installer that we reference anywhere on <https://www.ubuntu.com/download>. It undergoes exactly zero testing as part of the release process, and is not something that we invest in. I would recommend that you use one of the supported install images linked from https://www.ubuntu.com/download instead.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers