net-install for current 14.04 via iPXE on VMWare stalls for 20 minutes

Bug #1389754 reported by Rasmus Edgar Jørgensen on 2014-11-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned

Bug Description

After the debian installer has succesfully configured networking, the installer will hang for about 20 minutes after fetching Packages.gz from a local apt-cacher-ng mirror.

This can clearly be seen in the attached logs. Check syslog 11:38.

I have also attached the current preseed file.

The initial version of Ubuntu 14.04 did not have this issue, and I believe that this issue was introduced later.

How to replicate:
Boot from iPXE iso (the only one I've tested) and install via http.

Rasmus Edgar Jørgensen (regj) wrote :
Rasmus Edgar Jørgensen (regj) wrote :
Rasmus Edgar Jørgensen (regj) wrote :

Anyone interested in trying to solve this? I have also tried installing from a non apt-cacher-ng mirror. With the same result.

Rasmus Edgar Jørgensen (regj) wrote :

I am still struggling with this problem. Nothing in the logs give any hint to what is wrong. Automated installations are not very interesting when they take just as long as a manual installation. Anyone?

Rasmus Edgar Jørgensen (regj) wrote :

I have narrowed the problem down to dependent on having access to the internet. On VLANs with internet access the installer completes without hanging. Without it hangs 20 minutes before partitioning and 10-15 minutes at "73% .. updating list of available packages. "

There is no evidence in the logs that the debian-installer (anna) is trying to access the internet.

This is not related to apt-cacher-ng.

I have tried forcing the installer to use the local repo (d-i mirror/http/mirror select myrepo), but this doesn't solve the problem.

This sounds like a duplicate of bug 1389555

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers