Corrupted filenames in ISO Ubuntu 12.04.4 Server amd64

Bug #1283240 reported by Matthew Busche on 2014-02-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned

Bug Description

This bug report notes the same problems described in bugs 1161771 and 1130381, but is filed separately to make it clear it also applies to the lastest 64 bit LTS server release. Likely, it applies to other releases as well.

In the ISO named ubuntu-12.04.4-server-amd64.iso downloaded from this URL:

                  http://www.ubuntu.com/download/server

these 29 files have all had both their extensions truncated to 3 characters and their root names (not counting leading path names) truncated to 61 characters. So counting the "dot" character, they have all had their base file names trimmed to a total of 65 characters:

./pool/main/l/linux-lts-saucy/block-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd6.ude
./pool/main/l/linux-lts-saucy/crypto-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd.ude
./pool/main/l/linux-lts-saucy/firewire-core-modules-3.11.0-15-generic-di_3.11.0-15.25~preci.ude
./pool/main/l/linux-lts-saucy/floppy-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd.ude
./pool/main/l/linux-lts-saucy/fs-core-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_am.ude
./pool/main/l/linux-lts-saucy/fs-secondary-modules-3.11.0-15-generic-di_3.11.0-15.25~precis.ude
./pool/main/l/linux-lts-saucy/input-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd6.ude
./pool/main/l/linux-lts-saucy/ipmi-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd64.ude
./pool/main/l/linux-lts-saucy/irda-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd64.ude
./pool/main/l/linux-lts-saucy/message-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_am.ude
./pool/main/l/linux-lts-saucy/mouse-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd6.ude
./pool/main/l/linux-lts-saucy/multipath-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_.ude
./pool/main/l/linux-lts-saucy/nic-pcmcia-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1.ude
./pool/main/l/linux-lts-saucy/nic-shared-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1.ude
./pool/main/l/linux-lts-saucy/nic-usb-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_am.ude
./pool/main/l/linux-lts-saucy/parport-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_am.ude
./pool/main/l/linux-lts-saucy/pata-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd64.ude
./pool/main/l/linux-lts-saucy/pcmcia-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd.ude
./pool/main/l/linux-lts-saucy/pcmcia-storage-modules-3.11.0-15-generic-di_3.11.0-15.25~prec.ude
./pool/main/l/linux-lts-saucy/plip-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd64.ude
./pool/main/l/linux-lts-saucy/sata-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd64.ude
./pool/main/l/linux-lts-saucy/scsi-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd64.ude
./pool/main/l/linux-lts-saucy/serial-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd.ude
./pool/main/l/linux-lts-saucy/speakup-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_am.ude
./pool/main/l/linux-lts-saucy/squashfs-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_a.ude
./pool/main/l/linux-lts-saucy/storage-core-modules-3.11.0-15-generic-di_3.11.0-15.25~precis.ude
./pool/main/l/linux-lts-saucy/virtio-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd.ude
./pool/main/l/linux-lts-saucy/vlan-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd64.ude
./pool/main/l/linux-signed-lts-saucy/kernel-signed-image-3.11.0-15-generic-di_3.11.0-15.25~precise.ude

Before someone suggests that the ISO is fine and that the filenames must have been clobbered by whatever tool I was using to examine the ISO file, know that the ISO file has independently been examined by windows 8 file explorer, zip7, Windows ISO Mounter, and WinRAR and they all show these same truncated file names.

So what you say? Is this really a problem? I'm guessing it must NOT be a problem for normal CD-based installations (perhaps CD drivers expect long file names to be shortened???) or you would have had too many complaints to be ignroed, but for my USB installations these clobbrered names are causing much grief. I have attempted to build an installation flash drive with this ISO using both LiLi USB Creator and unetbootin-windows-585.exe. With both tools, the USB copies these files along with their truncated names perfectly. No surprise there. But attempting to install from such a USB results in the following error while loading installer components:

There was a problem reading data from the CD-ROM. Please make sure it is in the drive. If retrying does not work, you should check the integrity of your CD-ROM.

Failed to copy file from CD-ROM. Retry?

Once I realized what the problem was (which took me an entire day), I modified all of the file names above so they all consistently ended with the string "precise1_amd64.udeb" and then everything worked.

You say maybe my USB drivers are just finicky? They are asking too much to expect the encoded filenames to match the requested filenames! Well, there have been at least two others that have taken the effort to submit bug reports documenting this same problem (as noted above). One was closed as invalid. The other was simply ignored and timed out. In addition, there are countless forum posts where people have documented and discussed this same problem. Here are just a few:

http://askubuntu.com/questions/127398/usb-drive-install-of-ubuntu-12-04-server-fails-cant-find-components-from-cd-r
http://ubuntuforums.org/showthread.php?t=1538056
http://ubuntuforums.org/showthread.php?t=2152193
http://ubuntuforums.org/showthread.php?t=1692104

This "Official" Ubuntu documentation tells people you can install Ubuntu from a flash drive and list LiLi and unetbootin-windows as tools to create the bootable flash drive from windows:

https://help.ubuntu.com/community/Installation/FromUSBStick

But it doesn't work.

Thanks for reading.

Matt Busche
Lakewood, CO

Matthew Busche (mtbusche) wrote :

I just took the ISO file in question and mounted it directly on an ubuntu system. Much to my chagrin, the file names in the ISO do actually appear to be good. But this means that at least 6 different windows applications all showed the same truncated filenames.

In any case, there still seems to be some fundamental problem with the windows-based flash-drive creation process used by both LiLIi and unetbootin-windows. Is there ANY windows-based mechanism for creating a bootable ubuntu flash drive that successfully preserves the long filenames?

Sorry for my false claims.

Matt Busche

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Oliver Etchebarne (drmad) wrote :

I just have the same problem right now, using unetbootin 585 on xubuntu linux 13.10.

drmad@lenny:/mnt/pool/main/l/linux-lts-saucy$ ls | head -n 3
block-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd6.ude
crypto-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd.ude
fat-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd64.udeb

and the installer fails.

Oliver Etchebarne (drmad) wrote :

I just create a new USB it with usb-creator-gtk, and the files are written ok.

It seems it's a unetbootin problem.

Matthew Busche (mtbusche) wrote :

Oliver,

The bug report (which I embarrassingly authored) mistakenly suggested the problem was with the iso itself. But as I said in the first comment, the actual problem is with at least two different windows-based creator facilities: LiLi and unetbootin. I was on a Windows XP machine. I don't know if the problem exists with other Windows releases.

Currently, LiLi and unetbootin are the first two utilities listed on the official Ubuntu documentation for how to create an installation flash-drive from a windows machine, and neither of them work:

https://help.ubuntu.com/community/Installation/FromUSBStick#Creating_a_bootable_Ubuntu_USB_flash_drive_from_Windows

I think the page should be immediately updated to either remove reference to these flaky USB creation facilities (until they fix their respective problems); or if the problem affects only certain combinations of windows&Ubuntu releases, then update the page to describe which releases work and which ones don't.

That would be better than letting people continue to bang their head against the wall wondering if they have a bad flash drive, or if they did something wrong, or whatever. (I had to do a lot of drywall repairs.) I don't know who's responsible for help.ubuntu.com web pages, or how to make them aware of this issue.

I've had an email exchange with the LiLi developer, he is at least aware of the problem and has seen it himself with some server releases. If I understood him correctly, the problem is rooted in some windows-based mechanism for reading ISOs. He hopes to find a work-around, but was at the time of our communication busy with other tasks.

Anyway, that's my best understanding of this problem at this time.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers