[7.10] [xubuntu] Install fails "Failed to determine codename for the release"

Bug #122402 reported by Duncan Lithgow on 2007-06-26
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ubiquity

Install of Xubuntu 7.10 (Gutsy Gibbon) Tribe 1 alternative CD fails with the message:

[!!] Install the base system
Debootstrap Error
Failed to determine codename for the release.

Seems rather trivial, but it refuses to go any further. Hardware is an IBM A30 Thinkpad.

description: updated
Colin Watson (cjwatson) wrote :

alternate install CD => not ubiquity

ljp37 (finite-automaton) wrote :

This happens with the 7.04 (feisty) xubuntu alternate install cd also.

It happens when the user is trying to perform an installation without a working cdrom.

In my case, I mounted another partition containing the xubuntu iso, and then used the loop device to mount that iso as /cdrom
Mounting /cdrom one's self appears to omit some critical step; apparently the release codename is decided when the cdrom is mounted by the installer.

Installation hits a brick wall at the "Install Base System" step because of the fatal "Failed to determine codename for the release" error.

ljp37 (finite-automaton) wrote :

I think I've found a workaround for this. After you mount another partition or an ISO to /cdrom, get to the installer menu and choose "load installer components from cd". Install the machinery for detecting and loading ISOs. Then unmount your /cdrom (and whatever other partition you may have mounted) and let the installer detect and mount the ISO. The release codename will be correctly determined and you will be able to install the base system.

See also http://ubuntuforums.org/showthread.php?p=2942322#post2942322

Colin Watson (cjwatson) wrote :

Mounting /cdrom yourself from a loop-mounted .iso certainly isn't supported; you will find that many partitioning scenarios unavoidably fail later if you do that, since the kernel will have the partition table locked and will refuse to re-read it without a reboot. If you need to loop-mount an .iso, you'll need to use the documented method to install from USB.

Duncan, did you try to do this?

Timo Saloranta (timo-saloranta) wrote :

I'm still seeing this problem constantly when trying to install from an external USB DVD-ROM.

The same problem occurs with
- Ubuntu 8.04.1 alternate CD
- Debian Etch
- Debian Lenny

Charlie Kravetz (charlie-tca) wrote :

Please attach the following information if using a USB drive:

1. Initiate the problem situation, then quickly get the output of dmesg
2. Output of uname -a
3. Output of lsb_release -a
4. Output of lsusb -v
5. any other data relevant to your problem

Thanks in advance.

Changed in debian-installer:
assignee: nobody → charlie-tca
status: New → Incomplete
Charlie Kravetz (charlie-tca) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in debian-installer:
assignee: charlie-tca → nobody
status: Incomplete → Invalid
Murz (murznn) wrote :

I try to install a debian lenny 5.01 from USB stick.

My USB stick is successfully mounted to the /cdrom folder.

Debian Installer succesfully detect the cdrom and base files.

After step "Partition disks" I go to the step "Install the base system" and see the error:
"Failed to determine codename for the release".

After that Installs stops and send me back to step "Install the base system".

I try go to the console (Alt-F2) and type commands:

# uname -a
Linux hostname 2.6.26-2-amd64 #1 SMP <date> x86_64 unknown

# lsb_release -a
-/bin/sh: lsb_release: not found

# lsusb -v
-/bin/sh: lsusb: not found

What is "codename for the release"? Where I can change or set it?
What additional info I can tell to solve the problem?

Murz (murznn) wrote :

I add the additional info for bug analysis.

Changed in debian-installer (Ubuntu):
status: Invalid → Confirmed
Charlie Kravetz (charlie-tca) wrote :

Murz:
It seems like you have this bug in debian lenny 5.01. If so, you should report it to Debian following the procedures at http://www.debian.org/Bugs/Reporting. Since launchpad is used to report for Ubuntu, Debian does not get the report from here.

If you are reporting the bug using Ubuntu, please include:

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu.
2) The version of the package you are using, via 'apt-cache policy packagename' or by checking in Synaptic.

Changed in debian-installer (Ubuntu):
status: Confirmed → Incomplete
Murz (murznn) wrote :

I have downloaded and checked an ubuntu-9.04-alternate-amd64.iso CD and see this bug too.
Steps to reproduce:
1. Download ubuntu-9.04-alternate-amd64.iso

2. Create a bootable USB (or HDD) using unetbootin from this iso

3. Boot a comuter from this USB (or HDD)

4. Process the install to the step "load installer components from cd" (ignoring failed detection of CDROM)

5. Go to console (alt+f2)

6. Mount drive with installer files to the /cdrom:
# mount -t vfat /dev/sdb1 /cdrom

7. Copy folder /cdrom/dists/jaunty to /cdrom/dists/stable (because if we copy ISO to the FAT system via unetbootin, symlink /cdrom/dists/stable converts to empty file) with commands:
# rm /cdrom/dists/stable
# cp /cdrom/dists/jaunty /cdrom/dists/stable -R

8. Go back to installer (alt+f1)

9. Start the step "load installer components from cd" again.

9.1. Solve the unetbootin bug (when copying files, file pool/main/l/linux/fs-secondary-modules-2.6.28-11-generic-di_2.6.28-11.42_amd64.udeb saves as pool/main/l/linux/fs-secondary-modules-2.6.28-11-generic-di_2.6.28-11.42_amd64.ude):
- when we see the error "problem reading data from the CDROM" we goes to console (alt+f2) and type
# cp /cdrom/pool/main/l/linux/fs-secondary-modules-2.6.28-11-generic-di_2.6.28-11.42_amd64.ude/cdrom/pool/main/l/linux/fs-secondary-modules-2.6.28-11-generic-di_2.6.28-11.42_amd64.udeb
after that returns to the installer (alt+f1) and on "Retry" click "Yes".

10. Process next steps, partitioning, etc....
11. On step "Install the base system" we will see the error:
[!!] Install the base system
Debootstrap Error
Failed to determine codename for the release.

And I don't know how I can solve this error. Screenshots of this error is attached

Murz (murznn) wrote :
Changed in debian-installer (Ubuntu):
status: Incomplete → Confirmed
Changed in debian-installer (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Murz (murznn) wrote :

I have added bugs described on 7 and 9.1 steps to unetbootin bug tracker: https://bugs.launchpad.net/unetbootin/+bug/373089

Hi,

In my case (net iso of 22 dec 2009) this was a file marker, i.e.

$ /cdrom/.disk/base_installable

rename/remove it (since we want to get files from outside), e.g.

$ mv /cdrom/.disk/base_installable /cdrom/.disk/base_installable.false

in that case mirror settings will be used to retrieve components (debs) instead of cdrom itself.

Hope this help.

Regards,
Sergei.

Michael Adams (unquietwiki) wrote :

Running into this with xubuntu and server alternate i386 installers for 11.10, when using the hd-media installer dated 10-08-2011.

Andrew Zheng (pandaren89) wrote :

Solved,

the codename for debstrap the target install is generated when a valid cdrom image is confirmed.

1) make sure the partition that contains the iso image not mounted. if it is already mounted as /hd-media, which is impossible to unmount, simply create a new 750mb partion and copy the iso image to that partition.

2) try again from the scan devices for an iso image. this time select the partion which is not mounted. it will simply mount it itself and scan the iso image.

3) after the iso image has been capture, the installer doesnt know if it is valid or not, so the code name is still not generated. now chose from load contents from the media, select check cdrom-integrty.

4) go back, you'll see theres cdrom check options from the installer, run it. the code should be generated.

5) now install base system.

Good luck,

Andrewbecks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers