ubuntu server ppc quantal server fails on linux-image-server

Bug #1067970 reported by Walter Lapchynski on 2012-10-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned

Bug Description

i'm not sure if the issue here is linux-image-server or the installer or the preseed. i'm inclined to believe the latter because most of the server testcases seem copied from x86 (they refer to grub and not yaboot).

in any case everything seems to go just peachy until installing packages, specifically failing on linux-image-server. i get the usual business that it's not available but referred to by another package. furthermore, it says it has no installation candidate and pkgsel fails with error code 100. i gather this is all standard fare for saying that whenever it tried to install linux-image-server, it couldn't find it. perhaps there's no ppc package with this name?

btw this is with 20121017.2.

Colin Watson (cjwatson) wrote :

I wouldn't expect there to be a powerpc package by that name. It'd help to have full installer logs here; you can extract them using "Save debug logs" from the installer main menu, or by running 'anna-install openssh-client-udeb' on tty2 and using scp to copy them to another machine.

Colin Watson (cjwatson) wrote :

Never mind, I tracked down the test case details. Your guess was right and this is indeed a bug in the preseed file; the line "d-i base-installer/kernel/override-image string linux-image-server" should be dropped, as it's at best a no-op nowadays and breaks both non-x86 architectures and amd64 systems requiring secure boot. I've asked Carlos on IRC to fix that.

In the meantime, closing this bug as it's not a bug in the installer. If you're feeling particularly enthusiastic, perhaps you might take a local copy of that preseed file without the offending line and try again ...

Changed in debian-installer (Ubuntu):
status: New → Invalid

i have a few other tests to wade through and then will come back to this. so if carlos fixes it, please post here. thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers