Rescue mode doesn't reinstall grub with all operating systems

Bug #1040306 reported by Nicholas Skaggs on 2012-08-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Low
Unassigned

Bug Description

When using rescue mode on the 12.04.1 images on a disk which contrained 2 seperate installations of ubuntu (both 64-bit, with the 64-bit alt image), executing a re-installation of grub resulted in only one installation being availible.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1040306

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Nicholas Skaggs (nskaggs) wrote :

Trying to recreate this, rescue mode appears to only work properly if grub contained the right values beforehand. If the grub config listed only one entry, resinstalling grub via rescue mode only seems to re-install grub with one entry. If grub contains all the installations, a grub re-install via rescue mode seems to work properly.

In fact if I uninstall grub, and then try to rescue my installation, it fails. i get a boot to grub rescue>.

Changed in debian-installer (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers