Ubuntu

Quantal daily fails to complete installation

Reported by Lars Noodén on 2012-06-01
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
High
Unassigned
mdadm (Ubuntu)
High
Unassigned

Bug Description

The current pre-Alpha image boots but does not install. It gets through the step "detecting disks and all other hardware" and consistently hangs at the step "Starting up the partitioner" It only ever gets as far as 41%

Pressing ESC or Ctrl-C has no effect on the installer, it stays hung.

This is regardless of medium and happens both on CDRW and USB stick.

Steps:

1) download image from http://iso.qa.ubuntu.com/qatracker/milestones/219/builds/16652/downloads
2) verify checksum
3) burn image or write to USB stick
4) verify burn/ stick
5) install

Edit 2012-06-25: happens on Alpha2, also.

Lars Noodén (larsnooden) wrote :
Lars Noodén (larsnooden) wrote :

There was no /var/log/installer directory. Just the two log files only.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1007394

tags: added: iso-testing
Lars Noodén (larsnooden) wrote :

The image from 2012 06 02 seems to work ok.

Lars Noodén (larsnooden) wrote :

This is present in the Alpha 1 Alternate powerpc image.

Lars Noodén (larsnooden) wrote :
Lars Noodén (larsnooden) wrote :
Lars Noodén (larsnooden) wrote :

Still a problem in the 2012 06 12 image.

Lars Noodén (larsnooden) wrote :

Still a problem in the 2012 06 15 Alternat image

description: updated
summary: - Quantal daily from 20120531 fails to complete installation
+ Quantal daily fails to complete installation
Lars Noodén (larsnooden) wrote :

It's a problem also in the 27 June Alpha2 image. Are more log files needed?

Lars Noodén (larsnooden) wrote :
sam tygier (samtygier) wrote :

from the last syslog from Lars, it looks like possible a problem in mdadm

Jun 28 16:08:22 kernel: [ 720.365461] INFO: task mdadm:19586 blocked for more than 120 seconds.
Jun 28 16:08:22 kernel: [ 720.365472] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Jun 28 16:08:22 kernel: [ 720.365484] mdadm D 0ff56468 0 19586 19585 0x00000000
Jun 28 16:08:22 kernel: [ 720.365487] Call Trace:
Jun 28 16:08:22 kernel: [ 720.365510] [ef07bcb0] [c0009e04] __switch_to+0x94/0xf4
Jun 28 16:08:22 kernel: [ 720.365522] [ef07bcd0] [c0628f84] __schedule+0x23c/0x6a8
Jun 28 16:08:22 kernel: [ 720.365531] [ef07bdf0] [c062a448] rwsem_down_failed_common+0xd8/0x148
Jun 28 16:08:22 kernel: [ 720.365543] [ef07be20] [c015f3b0] get_super+0xb8/0xf4
Jun 28 16:08:22 kernel: [ 720.365554] [ef07be50] [c019b654] fsync_bdev+0x24/0x6c
Jun 28 16:08:22 kernel: [ 720.365565] [ef07be60] [c02fd72c] blkdev_ioctl+0x400/0x8e4
Jun 28 16:08:22 kernel: [ 720.365576] [ef07bea0] [c01701d8] do_vfs_ioctl+0xa8/0x79c
Jun 28 16:08:22 kernel: [ 720.365584] [ef07bf10] [c0170958] sys_ioctl+0x8c/0x9c
Jun 28 16:08:22 kernel: [ 720.365593] [ef07bf40] [c001731c] ret_from_syscall+0x0/0x38
Jun 28 16:08:22 kernel: [ 720.365611] --- Exception: c01 at 0xff56468
Jun 28 16:08:22 kernel: [ 720.365611] LR = 0xff563d0

Stéphane Graber (stgraber) wrote :

Can you attach the output of "lsof -n" at the time of the failure or if not available, the output of "ls -l /proc/<pid of hung process>/fd/"?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Changed in mdadm (Ubuntu):
status: New → Confirmed
Greg Faith (gregfaith) wrote :

My failure occurs at "detecting network hardware" iso testing powerpc Lubuntu 20120711. Tried with ethernet cable and without same results.

Using dd built USB

Greg Faith (gregfaith) wrote :

Tried install in expert mode got to 41% of "starting the partitioner" and the computer froze using daily 20120711.

Lars Noodén (larsnooden) wrote :

lsof is not available, how would I find the process id of the stuck process? The version of ps included in the installer is rather primitive and does not have the usual options.

Changed in mdadm (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (dmitrij.ledkov)
Dimitri John Ledkov (xnox) wrote :

Is this bug powerpc specific? Or is it also reproducible on i386/amd64/armhf ? (the listed platforms are the ones I have easy access to)

On Fri, Jul 13, 2012 at 1:30 PM, Dmitrijs Ledkovs
<email address hidden> wrote:
> Is this bug powerpc specific? Or is it also reproducible on
> i386/amd64/armhf ? (the listed platforms are the ones I have easy access
> to)

It is specific to powerpc 12.10 alternate builds from my side of the testing.
I have not experienced it on amd64 or i386 builds.

nm_geo Greg

Greg Faith (gregfaith) wrote :

Yes it is powerpc 12.10 specific on my testing.

Colin Watson (cjwatson) wrote :

Lars: Esc and Ctrl-C won't interrupt the installer while it's doing something, unless it's specifically displaying a cancellable progress bar. The way to distinguish between just the userspace installer code being hung and the entire system being hung is to try to switch to a different virtual console. The installer itself is on Alt-F1; there are shells on Alt-F2 and Alt-F3; and the syslog is on Alt-F4.

Lars Noodén (larsnooden) wrote :

If it is mdadm that is hanging, here is the output from ls -l /proc/

ps shows:

19105 root 2504 D mdadm --examine --scan --config=partitions

Lars Noodén (larsnooden) wrote :

Now with the right subdirectory.

Stéphane Graber (stgraber) wrote :

Right, so it doesn't have any mapper entry open, making it more likely to be a kernel problem (/dev/sda1 hanging in I/O wait) than anything else.

Can you perhaps try something like:
dd if=/dev/sda1 of=/dev/zero bs=1024 count=1

And see if that hangs as well?

(I'm only assuming the I/O wait is on /dev/sda1, there's no clear proof of that but it's certainly the most likely)

Lars Noodén (larsnooden) wrote :

Stéphane, following the above, dd works fine even while the installation itself has hung.

Changed in debian-installer (Ubuntu):
importance: Undecided → High
Changed in mdadm (Ubuntu):
importance: Undecided → High
Changed in debian-installer (Ubuntu):
milestone: none → quantal-alpha-3
Changed in mdadm (Ubuntu):
milestone: none → quantal-alpha-3
tags: added: rls-q-incoming
Greg Faith (gregfaith) wrote :

Got a failure again on the daily 20120721 of the Lubuntu quantal powerpc.iso. I am attaching the syslog.

Greg Faith (gregfaith) wrote :

As requested the computer I test the powerpc isos Desktop and Alternate is the following:

https://docs.google.com/document/d/1HAlDyGp4RKP4RieVDiuVH7nITomTFCifQdJFMEEzAEE/edit?pli=1

I only do hardware installs both Alternate and Desktop on my PowerBook G4 1000Mhz 1025MB.

Lars Noodén (larsnooden) wrote :

FWIW, here are the system specs for the G4 hardware I am using for this:

http://people.ubuntu.com/~larsnooden/Hw/g4.ti.lshw.html

Lars Noodén (larsnooden) wrote :
Changed in debian-installer (Ubuntu):
status: Confirmed → Fix Released
tags: removed: rls-q-incoming
Dimitri John Ledkov (xnox) wrote :

Based on the comment #31 this appears to have been resolved. It it hasn't please mark this bug as confirmed again.

Changed in mdadm (Ubuntu):
milestone: quantal-alpha-3 → none
status: Confirmed → Incomplete
Changed in mdadm (Ubuntu):
assignee: Dmitrijs Ledkovs (xnox) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers