floppy0 comes out of nowhere

Bug #74657 reported by Alexander Jones on 2006-12-06
34
Affects Status Importance Assigned to Milestone
debian-installer-utils (Ubuntu)
Undecided
Colin Watson
Edgy
Undecided
Unassigned

Bug Description

I just installed Ubuntu on a fresh disk today.

I do not have a floppy drive, yet in my /etc/fstab file I have:

/dev/ /media/floppy0 auto rw,user,noauto 0 0

This causes a rogue entry named "Floppy 1" to show up in various places in GNOME.

I think floppy drives should be detected automatically, not just guessed like this.

Thanks!

Colin Watson (cjwatson) wrote :

Your kernel actually does think that there's a floppy drive, as far as I can tell; I bet you'll find a /sys/block/fd0 directory or similar, perhaps representing a floppy drive controller without an actual floppy drive attached. We don't just guess (nowadays). The real bug here seems to be that the device node used is "/dev/"; I fixed this bug in list-devices a little while ago upstream, and should be able to merge it into Feisty shortly.

Colin Watson (cjwatson) wrote :

debian-installer-utils (1.41ubuntu1) feisty; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Work around some weirdness in di_exec that caused log-output sometimes
      to hang in poll(). We now install a no-op SIGCHLD handler to make sure
      that poll() returns EINTR when the subsidiary process exits.
    - user-params: Don't propagate ks=* or vga=* to installed system.
  * list-devices RAID fix also fixes floppy detection as a useful
    side-effect (LP: #74657).

 -- Colin Watson <email address hidden> Wed, 6 Dec 2006 20:47:21 +0000

debian-installer-utils (1.41) unstable; urgency=low

  * list-devices: Fall back to assuming that cciss, ida, and rd RAID devices
    are disks if udevinfo doesn't provide an ID_TYPE for them.
  * list-devices: Check for both ID_CDROM= and ID_TYPE=cd to work around
    #400258.

  [ Updated translations ]
  * Kurdish (ku.po) by Erdal Ronahi

 -- Colin Watson <email address hidden> Fri, 24 Nov 2006 20:08:40 +0000

Changed in debian-installer-utils:
assignee: nobody → kamion
status: Unconfirmed → Fix Released
Colin Watson (cjwatson) wrote :

If we ever do a point release of Edgy, this would be a good candidate.

Changed in debian-installer-utils:
status: Unconfirmed → Confirmed
Dee (dee24) wrote :

Hmmm... has anyone issued a fix for this problem?

I'm running Feisty and I'm getting the same issue.

Dee (dee24) wrote :

Eh, I meant: When I installed Feisty on this pc, I got this issue. Applying the latest updates has not resolved this issue.

I could simply ignore it but at the same time, I'd appreciate it if there was a fix made available.

Omegatron (omegatron) wrote :

I noticed this after upgrading to Feisty. Not sure if it was there before the upgrade. I have an old IBM Thinkpad with a port on the side for an external floppy drive, which is probably where this is coming from ("perhaps representing a floppy drive controller without an actual floppy drive attached"). I do see a /sys/block/fd0/.

"The real bug here seems to be that the device node used is "/dev/"; I fixed this bug in list-devices a little while ago upstream"

To fix this manually, should this line be removed? Or changed to /dev/fd0 or something? Will removing the line prevent me from ever using the external floppy? (Not that I'm ever going to use a floppy in 2007, but it would be best to do it correctly...) :-)

Richard Johnson (nixternal) wrote :

I only get this if I enable floppy support in my bios. When I shut it off it doesn't appear. The floppy recognition comes from the bios, as a floppy drive is a dumb drive, generic in firmware, requiring nothing special. The only way to get this to not occur is to remove floppy support from your bios. This same thing goes with Windows machines as well, if you don't disable floppy support int he bios, you will see see the drivers installed for the floppy block in system settings.

Alexander Jones (alex-weej) wrote :

On Windows it somehow knows that I don't have a floppy drive, so doesn't present an A: device.

Hew (hew) wrote :

Ubuntu Edgy Eft is no longer supported, so a SRU will not be issued for this release. Marking Edgy as Won't Fix.

Changed in debian-installer-utils:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers