dman is provided by both debian-goodies and bikeshed

Bug #1701065 reported by Jeremy Bicha on 2017-06-28
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
bikeshed (Ubuntu)
High
Unassigned
debian-goodies (Debian)
New
Unknown
debian-goodies (Ubuntu)
High
Unassigned

Bug Description

/usr/bin/dman is provided by both bikeshed and debian-goodies in Ubuntu 17.10. This is a violation of Debian policy.

By the way, why don't you try to push the bikeshed tools into debian-goodies or some other package so that Debian users can have access to them too? After all, ubuntu-dev-tools is available in Debian.

Jeremy Bicha (jbicha) on 2017-06-28
Changed in bikeshed (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in debian-goodies (Debian):
status: Unknown → New
Axel Beckert (xtaran) wrote :

Hi Jeremy,

I don't see why this bug report are declared as affecting debian-goodies in _Debian_. This seems to be an ubuntu-specific issue to me as no package named bikeshed exists in Debian.

Jeremy Bicha (jbicha) wrote :

Axel, thank you for your comment.

The bug is indeed in Ubuntu. I added a reference to the Debian bug that may end up being part of the solution for this Ubuntu bug. If debian-goodies' version of dman is an adequate replacement for bikeshed's dman, than bikeshed's version should be dropped.

Also, even though it is Ubuntu's bug, it is possible for it to be fixed in Debian. For instance, debian-goodies could be changed to not install dman when debian-goodies is built on an Ubuntu system.

tags: added: package-conflict
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.