debconf: DbDriver "passwords" warning: could not open /var/cache/debconf/passwords.dat: Permission denied

Bug #959364 reported by Sam_ on 2012-03-19
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
debconf (Ubuntu)
Undecided
Unassigned

Bug Description

Output from .xsession-errors:
debconf: DbDriver "passwords" warning: could not open /var/cache/debconf/passwords.dat: Permission denied
Use of uninitialized value $template in exists at /usr/share/perl5/Debconf/Template.pm line 81, <> line 3.
Use of uninitialized value $item in exists at /usr/share/perl5/Debconf/DbDriver/Cache.pm line 39, <> line 3.
## multiple times repeated.

Expected.
debconf should be informed that permission is denied before attempting to open the file.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: debconf 1.5.42ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-19.30-generic 3.2.11
Uname: Linux 3.2.0-19-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Mon Mar 19 15:43:31 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120204)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: debconf
UpgradeStatus: No upgrade log present (probably fresh install)

Sam_ (and-sam) wrote :
Sam_ (and-sam) on 2012-03-19
description: updated
Sam_ (and-sam) wrote :

While .xsession-errors was pretty useless in past weeks, now it's fixed (951597) and almost empty, in fact debconf indications can no longer be viewed. Since there was no package update not sure how to trigger the output.

Sam_ (and-sam) wrote :

Updates via terminal or update-manager don't expose debconf warnings in .xsession-errors any longer.

Changed in debconf (Ubuntu):
status: New → Fix Released
Charles Dow (charles-dow) wrote :

After removing not purging all php related programs, not purging. I tried to reinstall using tasksel, I received this message

debconf: DbDriver "passwords" warning: could not open /var/cache/debconf/passwords.dat: Permission denied
debconf: DbDriver "passwords" warning: could not open /var/cache/debconf/passwords.dat: Permission denied
debconf: DbDriver "config": could not write /var/cache/debconf/config.dat-new: Permission denied
tasksel: debconf failed to run

Sam_ (and-sam) wrote :

.xsession-errors indeed contents the warning again twice, each repeated four times, context unclear, uptime 9d - reopen bug.
debconf: DbDriver "passwords" warning: could not open /var/cache/debconf/passwords.dat: Keine Berechtigung

~$ LANG=C apt-cache policy debconf
debconf:
  Installed: 1.5.42ubuntu1
  Candidate: 1.5.42ubuntu1
  Version table:
 *** 1.5.42ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Changed in debconf (Ubuntu):
status: Fix Released → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debconf (Ubuntu):
status: New → Confirmed
NoOp (glgxg) wrote :

$ apt-cache policy debconf
debconf:
  Installed: 1.5.42ubuntu1
  Candidate: 1.5.42ubuntu1
  Version table:
 *** 1.5.42ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1200003 (Authentica)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
debconf: DbDriver "passwords" warning: could not open /var/cache/debconf/passwords.dat: Permission denied
debconf: DbDriver "passwords" warning: could not open /var/cache/debconf/passwords.dat: Permission denied

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers