Debconf asks to choose from one option

Bug #42187 reported by Tero Karvinen on 2006-04-30
16
Affects Status Importance Assigned to Milestone
debconf (Ubuntu)
Medium
Colin Watson

Bug Description

Running software updates on Dapper 6.06 beta 2, debconf asks user to "select the desired default display manager". There is only one option, gdm.

sam tygier (samtygier) wrote :

i just updated to todays gdm 2.14.4-0ubuntu2 using the update-manager, and did not see this.

what did you use to do the upgrade?
do you have any other *dm package? kdm or xdm

Changed in gdm:
status: Unconfirmed → Needs Info
sam tygier (samtygier) wrote :

after installing xdm, and running
sudo dpkg-reconfigure gdm
i was asked to choose between gdm and xdm

Gary Coady (garycoady) wrote :

Do you use the GNOME frontend to debconf?

Gary Coady (garycoady) wrote :

The GNOME frontend shows questions even when there's only one, because Debconf::Element::Gnome::Select inherits first from Debconf::Element::Gnome, and then from Debconf::Element::Select - the second one has the correct definition of visible().

However, Debconf::Element::Gnome inherits from Debconf::Element, which has a basic 'show everything' definition of visible(), so this is used instead.

Gary Coady (garycoady) wrote :

Reassigning to the debconf package...

Changed in gdm:
status: Needs Info → Confirmed

This takes the implementation of Debconf::Element::Select->visible and copies it into Debconf::Element::Gnome::Select->visible, because the wrong function was being selected due to multiple inheritance.

If there's another way to do this without duplicating code, that would be better though.

Sebastien Bacher (seb128) wrote :

Gary, you rock if I didn't say it already ;)

Colin Watson (cjwatson) wrote :

Thanks; I've committed a slightly different patch upstream that does '*visible = \&Debconf::Element::Select::visible;' to avoid the code duplication; it also corrects the Gnome multiselect element and the Kde select and multiselect elements, which had similar problems.

I've also backported this change to Dapper:

debconf (1.4.72ubuntu8) dapper; urgency=low

  * Backport from trunk (closes: Malone #42187):
    - Stop the Gnome and Kde frontends from displaying select questions with
      zero or one choices, or multiselect questions with zero choices; this
      was broken due to an error in multiple inheritance (thanks, Gary
      Coady; closes: https://launchpad.net/bugs/42187).

 -- Colin Watson <email address hidden> Mon, 15 May 2006 10:28:53 +0100

Changed in debconf:
assignee: nobody → kamion
status: Confirmed → Fix Released
Colin Watson (cjwatson) wrote :

Make that:

debconf (1.4.72ubuntu9) dapper; urgency=low

  * Backport from trunk (closes: Malone #42187):
    - Stop the Gnome and Kde frontends from displaying select questions with
      zero or one choices, or multiselect questions with zero choices; this
      was broken due to an error in multiple inheritance (thanks, Gary
      Coady; closes: https://launchpad.net/bugs/42187).

 -- Colin Watson <email address hidden> Mon, 15 May 2006 11:03:13 +0100

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers