Jaunty oem installer doesn't get run after reboot

Bug #347648 reported by Stéphane Graber on 2009-03-23
2
Affects Status Importance Assigned to Milestone
debconf (Ubuntu)
Critical
Colin Watson
Jaunty
Critical
Colin Watson

Bug Description

Binary package hint: oem-config

With current jaunty beta candidate, installing with OEM selected gives you the "Prepare for shipping" option on the desktop after installation. Clicking it asks for the password as expected, then after reboot nothing happens and I'm back to the same desktop with the "Prepare for shipping" launcher.

Changed in oem-config (Ubuntu):
milestone: none → ubuntu-9.04-beta
Colin Watson (cjwatson) wrote :

This appears to be due to a corrupted debconf database. Investigating.

Stéphane Graber (stgraber) wrote :
Stéphane Graber (stgraber) wrote :
Colin Watson (cjwatson) on 2009-03-24
Changed in debconf (Ubuntu):
importance: Undecided → Critical
status: New → Confirmed
Changed in oem-config (Ubuntu):
assignee: nobody → cjwatson
Colin Watson (cjwatson) on 2009-03-24
Changed in debconf (Ubuntu Jaunty):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debconf - 1.5.26ubuntu3

---------------
debconf (1.5.26ubuntu3) jaunty; urgency=low

  * debconf-apt-progress: DEBIAN_HAS_FRONTEND is always set here at some
    point, even if only on the second run after starting debconf, so we need
    to invert our handling of the check for whether we started the debconf
    frontend ourselves (LP: #347648).

 -- Colin Watson <email address hidden> Tue, 24 Mar 2009 03:22:29 +0000

Changed in debconf:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers