ubiquity location always set to Algiers

Bug #271652 reported by Pelládi Gábor on 2008-09-18
10
Affects Status Importance Assigned to Milestone
debconf (Ubuntu)
Medium
Unassigned
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ubiquity

Using current Intrepid 8.10, ubiquity 1.9.16. No matter what language I choose on the first page, on the second page the location will be set to Algiers. Furthermore, the keyboard layout will be set to USA.
Expected behavior: If I select Hungarian language, the location should be set to Budapest (Hungary), and the keyboard layout to Hungarian.

Colin Watson (cjwatson) wrote :

Reproduced, thanks. Odd ...

Changed in ubiquity:
importance: Undecided → Medium
status: New → Triaged
Colin Watson (cjwatson) wrote :

This is a debconf bug, amazingly enough:

debconf (developer): <-- METAGET localechooser/continentlist Choices-en.UTF-8
debconf (developer): --> 1

debconf should fall back to Choices here, but doesn't.

Colin Watson (cjwatson) wrote :

The keyboard layout bug seems to be something separate.

Changed in ubiquity:
importance: Undecided → Medium
status: New → Triaged
Colin Watson (cjwatson) wrote :

Actually, the keyboard part of this bug is bug 253749. Rather than try to mark half of this bug as a duplicate somehow, I'll just suggest that you subscribe to that bug if you're interested in its resolution! I should have it fixed soon.

Changed in ubiquity:
status: Triaged → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debconf - 1.5.23ubuntu1

---------------
debconf (1.5.23ubuntu1) intrepid; urgency=low

  * Backport from trunk:
    - Fall back to untranslated fields if asking explicitly for any
      nonexistent translated field, not just Choices-C. For example, asking
      for Choices-en.UTF-8 should fall back to Choices if Choices-en.UTF-8
      doesn't exist. LP: #271652
    - Remove some dead code in Debconf::Template::AUTOLOAD.

 -- Colin Watson <email address hidden> Fri, 19 Sep 2008 01:59:06 +0100

Changed in debconf:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers