Ubuntu

debconf gtk+ dialog boxes do not remember window sizes on ubuntu.

Reported by bash321 on 2013-01-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice Productivity Suite
Won't Fix
Medium
Nautilus
Invalid
High
Unity
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
debconf (Ubuntu)
Undecided
Unassigned

Bug Description

Gtk window placement not remembering size when it is an open or save dialog window.
Problem:
1. Open the open dialog on libreoffice.
2. Window overlaps off screen. Does not fit on screen.
3. Click the maximise button and the window adjusts as a maximised window that fits on the screen.
4. Close window.
5. Open window again.
6. Same problem overlaps on screen does not remember that it was in a maximised state when I closed it from last time.
7. Have to click maximise again!

What it needs to do:
1. The 2nd window should remember where it was in a maximised state (not overlap when i open it again) as I had left it when I had closed the 1st window.
2. Window open and save dialog s should remember there state no matter how they are adjusted.

I have filed a gtk bug.
My response so far is that it is a Ubuntu problem and maybe a unity problem.

What I think is happening:
The open and save dialog window knows that it needs to be at a resolution as it was before... And that is what it is directly doing. But, What the window needs to do though is to be told when it is opened to go to that size and resolution but to also go back into maximise mode as I had left it before.

Links:
https://bugs.launchpad.net/ubuntu/+s...iz/+bug/760645 launchpad bug:
Bug filed with gtk developer: https://bugzilla.gnome.org/show_bug.cgi?id=685347
Screenshots in both links of what is going wrong.

I have had this problem with many versions of ubuntu since 10.04.. Earlier. It would be great if it could be fixed... still happens in quantal 12.10.

It is quite annoying when the dialog doesn't remember its position or fits on the screen??
this happens on any open or save window in ubuntu on any program. Including Firefox... Chromium... Libreoffice... Archive manager.... Nautilus.... And many many many others.

more links are attached from existing bug reports...

if this bug needs to be cleaned up for more information I am happy to provide a clearer outline.

Please help,
bash321.

Dialog box window sizes (mainly open dialog box and save dialog box)
Gtk window placement is not remembering size when it is an open or save dialog window on a normal monitor for a computer running ubuntu.
Problem:
1. Open the open dialog on libreoffice.
2. Window overlaps off screen. Does not fit on screen.
3. Click the maximise button and the window adjusts as a maximised window that fits on the screen.
4. Close window.
5. Open window again.
6. Same problem overlaps on screen does not remember that it was in a maximised state when I closed it from last time.
7. Have to click maximise again!

What it needs to do:
1. The 2nd window should remember where it was in a maximised state (not overlap when i open it again) as I had left it when I had closed the 1st window.
2. Window open and save dialog s should remember there state no matter how they are adjusted.

I have filed a gtk bug.
My response so far is that it is a Ubuntu problem.

What I think is happening:
The open and save dialog window knows that it needs to be at a resolution as it was before... And that is what it is directly doing. But, What the window needs to do though is to be told when it is opened to go to that size and resolution but to also go back into maximise mode as I had left it before.

Links:
https://bugs.launchpad.net/ubuntu/+s...iz/+bug/760645 launchpad bug:
Bug filed with gtk developer: https://bugzilla.gnome.org/show_bug.cgi?id=685347
Screenshots in both links of what is going wrong.

I have had this problem with many versions of ubuntu since 10.04.. Earlier. It would be great if it could be fixed... still happens in quantal 12.10.

It is quite annoying when the dialog doesn't remember its position or fits on the screen??

occurs from libreoffice 3.5 and onwards......

bash321 (bash321) wrote :
summary: - debconf gtk+ dialog boxes ubuntu do not remember display resolution
+ debconf gtk+ dialog boxes do not remember window sizes on ubuntu.
Changed in nautilus:
importance: Unknown → High
status: Unknown → Invalid
Changed in df-libreoffice:
importance: Unknown → Critical
status: Unknown → New

Changing version to 3.5 as Version reflects the earliest version that we see the problem and reporter has said 3.5 onwards

Also changing priority as CRITICAL is overstating the issue.

@Reporter - Critical is intended for bugs that result in crashes, data loss, etc...

Michael: on pc Debian x86-64 with master sources updated today + Gnome/unity, I can't even change the size of Open dialog window. Any idea about this tracker?
I don't know if it depends on the env only, LO only or a mix of both

Changed in df-libreoffice:
importance: Critical → Medium

Bug has partially been resolved in LO 4.0.0.3.
Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)
Ubuntu 13.04 Raring 64 Bit.

Open Dialogue Window does not overlap any more when checkbox is checked in CompizConfigSettings manager for maximised windows under the Window Rules Option.

The WIndow is fully maximised with Unity Integration in LibreOffice, and it remembers its maximised state in the application.

The problem is that this only occurs when it is checked using CompizConfigSettings Manager, can this now be constructed as being the default process for Open and Save Dialogue windows that are maximised in Ubuntu?
Without having to check the maximised windows option in CompizConfigSettings Manager, so that they may have full unity integration on the display monitor.
I would also like to escalate this query to other programs within Ubuntu, as it has the same maximise issue for open and save dialogue windows in programs such as Rhythmbox, and Evince Document Viewer.
It is a common bug on Ubuntu Systems with Unity.

when CCSM has maximised windows enabled for the open dialog box it cannot resize the window at all. it defaults automatically to only stay in a maximised state for that specific window.

Bug has partially been resolved in LO 4.0.0.3.
Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)
Ubuntu 13.04 Raring 64 Bit.

Open Dialogue Window does not overlap any more when checkbox is checked in CompizConfigSettings manager for maximised windows under the Window Rules Option.

The WIndow is fully maximised with Unity Integration in LibreOffice, and it remembers its maximised state in the application.

The problem is that this only occurs when it is checked using CompizConfigSettings Manager, can this now be constructed as being the default process for Open and Save Dialogue windows that are maximised in Ubuntu?
Without having to check the maximised windows option in CompizConfigSettings Manager, so that they may have full unity integration on the display monitor.
I would also like to escalate this query to other programs within Ubuntu, as it has the same maximise issue for open and save dialogue windows in programs such as Rhythmbox, and Evince Document Viewer.
It is a common bug on Ubuntu Systems with Unity.

I know that when you set CCSM to maximise windows specifically for the open dialog box window in libreoffice, you cannot resize the window because it has manually been set to maximise everytime it is opened.
to solve that problem of not resizing the window would be to untick or disable maximise windows in CompizConfigSettings Manager, to be able to resize windows again.

Bug has partially been resolved in LO 4.0.0.3.
Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)
Ubuntu 13.04 Raring 64 Bit.

Open Dialogue Window does not overlap any more when checkbox is checked in CompizConfigSettings manager for maximised windows under the Window Rules Option.

The WIndow is fully maximised with Unity Integration in LibreOffice, and it remembers its maximised state in the application.

The problem is that this only occurs when it is checked using CompizConfigSettings Manager, can this now be constructed as being the default process for Open and Save Dialogue windows that are maximised in Ubuntu?
Without having to check the maximised windows option in CompizConfigSettings Manager, so that they may have full unity integration on the display monitor.
I would also like to escalate this query to other programs within Ubuntu, as it has the same maximise issue for open and save dialogue windows in programs such as Rhythmbox, and Evince Document Viewer.
It is a common bug on Ubuntu Systems with Unity.

bash321 (bash321) wrote :

Screen Cast Video Dialog Box Window Problem in LibreOffice and Evince PDF Document Viewer for Open and Save Dialog Box Windows.

Video has been converted to small ogg format.. and squashed. it can be opened in vlc.

Hopefully this can explain the problem.

bash321 (bash321) wrote :

Screencast of Dialog Box Window in a proper maximised state always.
Compiz Settings Manager Window Size Rule as Maximum always keeps the window maximised and it cannot be resized unless the window size rule is disabled and switched off.

bash321 (bash321) on 2013-02-22
Changed in unity:
status: New → Invalid
Changed in compiz (Ubuntu):
status: New → Invalid
status: Invalid → Confirmed
Changed in unity:
status: Invalid → Confirmed
Changed in debconf (Ubuntu):
status: New → Incomplete

> I would also like to escalate this query to other programs within Ubuntu,
> as it has the same maximise issue for open and save dialogue windows
> in programs such as Rhythmbox, and Evince Document Viewer.
> It is a common bug on Ubuntu Systems with Unity.

If this affects other apps - and indeed we really use a pretty bog-standard / plain-and-simple Gtk+ file picker with only some LibreOffice API wrappers around it - then this is clearly a Unity bug and not a LibreOffice bug.

So in the absence of any better data => NOTOURBUG.

Thanks !

Changed in df-libreoffice:
status: New → Won't Fix

*** Bug 55600 has been marked as a duplicate of this bug. ***

I can hopefully find someone that can resolve this bug.

ljelly.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.